Как изменить журнал "счета"?

  • Автор темы DeathExpectation
  • Дата начала
D

DeathExpectation

#1
Заводится документ "Счет", на основании счета делается "Отгрузка..." либо "Оказание услуг...". Подскажите, как сделать так, чтоб бухгалтер в журнале "Счета" видел, по каким из счетов была отгрузка или оказаны услуги?

версия: 1С 7.7 редакция 4.5
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#2
Как-то тема слабо коррелирует с текстом сообщения...
По теме: в конфигураторе.
По сообщению: сделайте в журнале счетов дополнительную колонку и выводите в нее признак какой-то при наличии подчиненных документов.
 
D

DeathExpectation

#3
ну так это не изменение журнала счета чтоли?
 
D

DeathExpectation

#4
Что ни кто не знает чтоли? Или просто не охото помогать? Тогда зачем нужен форум?
 
K
#5
Посмотри в типовой бух, как реализовано в журнале платежных поручений
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#7
ну так это не изменение журнала счета чтоли?
С моей точки зрения, изменение журнала есть ни что иное, как модификация состава журнала и граф журнала, т.е. изменение метаданных.
Задача же, описанная в самом теле сообщения, относится к модификации представления журнала (без изменения метаданных).
Что ни кто не знает чтоли? Или просто не охото помогать? Тогда зачем нужен форум?
Форум - это место общения на профессиональные или околопрофессиональные темы (по крайней мере, этот). Посему, следует принимать тот факт, что задав вопрос, вы получите ответ только в том случае, если кто-то посчитает интересным для себя и для других ответить на него. Что касается конкретно вашего вопроса, он показывает ваше нежелание читать документацию, а также разбираться с типовыми решениями. В этом мы, увы, не сможем вам помочь.
Еще раз хочу напомнить, что вам никто ничего не должен.
 

unknown181538

НеГуру
28.12.2008
1 417
0
#9
С моей точки зрения, изменение журнала есть ни что иное, как модификация состава журнала и граф журнала, т.е. изменение метаданных.
Задача же, описанная в самом теле сообщения, относится к модификации представления журнала (без изменения метаданных).
Мне кажется, речь идет об изменение модуля формы и диалога журнала "Счета". Это ли не изменение метаданных?
 
D

DeathExpectation

#10
Я добавил колонку в журнал счета

Вот функция которая заполняет эту колонку

Функция ПоказатьСтатусСчета()
ДокиПодч = СоздатьОбъект("Документ");
Рез="";
Если ПустоеЗначение(ТекущийДокумент)=1 Тогда
Возврат Рез;
Иначе
Если ДокиПодч.ВыбратьПодчиненныеДокументы(,,ТекущийДокумент)=1 Тогда
Пока ДокиПодч.ПолучитьДокумент()=1 Цикл
Если ДокиПодч.Проведен()=1 Тогда
Если (ДокиПодч.Вид()="Выписка") тогда
ДокиПодч.ПолучитьСтроку();
Рез=ДокиПодч.ТекущийДокумент();
КонецЕсли;
КонецЕсли;

КонецЦикла;

Возврат Рез;
Иначе
Возврат Рез;
КонецЕсли;
КонецЕсли;
КонецФункции

Она выводит выписку которая была сделана на основании счета.
Подскажите как мне сделать так чтобы она выводила следующие данные


или подскажите как пожно сделать чтобы при нажатии на колонку где у нас вывелось выписка в журнале счета открывалась сама выписка
 

vbs

Well-known member
18.02.2007
1 708
1
#11
Надо из нужной строки выписки вытащить реквизиты "ДатаДокВходящий" и "НомерДокВходящий"
 

unknown181538

НеГуру
28.12.2008
1 417
0
#13
[codebox]ДокиПодч.ВыбратьСТроки();
Пока докиПодч.ПолучитьСтроку()=1 Цикл
Если ДокиПодч.КакТамНазываетсяРеквизитВКоторомСЧет=ТекущийДокумент Тогда
ДатаПлатежки=ДокиПодч.КакТамНазываетсяДАтаДОк;
НомерПлатежки=ДокиПодч.КакТамНазываетсяНомерПлатежки;
КонецЕсли;
КонецЦикла;[/codebox]
 
D

DeathExpectation

#14
[codebox]ДокиПодч.ВыбратьСТроки();
Пока докиПодч.ПолучитьСтроку()=1 Цикл
Если ДокиПодч.КакТамНазываетсяРеквизитВКоторомСЧет=ТекущийДокумент Тогда
ДатаПлатежки=ДокиПодч.КакТамНазываетсяДАтаДОк;
НомерПлатежки=ДокиПодч.КакТамНазываетсяНомерПлатежки;
КонецЕсли;
КонецЦикла;[/codebox]
Спасибо
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#15
Мне кажется, речь идет об изменение модуля формы и диалога журнала "Счета". Это ли не изменение метаданных?
А разве 1С не говорит при этом "...не вызвали изменения метаданных"? Или для вас является секретом то, что 1С позволяет хранить модули отдельно от конфигурации, что называется "в базовой комплектации"?
 
D

DeathExpectation

#16
Подскажите как сделать то же самое в 1С редакции 1.3. пожалуста
 

unknown181538

НеГуру
28.12.2008
1 417
0
#17
1.3 - версия платформы?) Тогда не знаю.
Если редакция конфигурации - то какая разница?
 

vbs

Well-known member
18.02.2007
1 708
1
#18
Судя по всему, у него УСН. Там "Выписка" устроена примерно так же, как и в Бух 4.5
ДокиПодч.ВыбратьСТроки();
Пока докиПодч.ПолучитьСтроку()=1 Цикл
Если ДокиПодч.ПервичныйДокумент=ТекущийДокумент Тогда
ДатаПлатежки=ДокиПодч.ДатаДокВходящий;
НомерПлатежки=ДокиПодч.НомерДокВходящий;
КонецЕсли;
КонецЦикла;