Как организовать подбор из справочника и Таблицу Значений?

Тема в разделе "1C и всё что с ней связано", создана пользователем shane13, 22 авг 2008.

Статус темы:
Закрыта.
  1. shane13

    shane13 Гость

    Собственно сабж... Спасибо заранее!
     
  2. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    Тз = сОЗДАТЬоБЪЕКТ("ТаблицаЗначений");
    Тз.НоваяКолонка("Параметр");

    Процедура Добавить()// на кнопку
    ОткрытьПодбор("Справочник.Товары","ДляВыбора"); // первое - справочник, второе - какая форма
    КонецПроцедуры

    Процедура обработкаПодбора(выб)
    Тз.НоваяСтрока()
    Тз.параметр = Выб;
    КонецПроцедуры
     
  3. shane13

    shane13 Гость

    А где писать
    Тз = сОЗДАТЬоБЪЕКТ("ТаблицаЗначений");
    Тз.НоваяКолонка("Параметр"); ??
    уж простите....
     
  4. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    В форме. Например в процедуре ПриОткрытии()
    Если их просматривать и редактировать в форме надо, тогда вставить в форму объект ТаблицаЗначений , обозвать его и ссылаться напрямую - тогда

    Тз = сОЗДАТЬоБЪЕКТ("ТаблицаЗначений");
    Тз.НоваяКолонка("Параметр");

    не надо

    можно вместо таблицы список воткнуть тогда
    Процедура обработкаПодбора(выб)
    СПС.ДобавитьЗначение(Выб); // Где СПС - список значений в форме
    КонецПроцедуры
     
  5. shane13

    shane13 Гость

    спасибо! Буду пробовать!
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей