Как организовать подбор из справочника и Таблицу Значений?

  • Автор темы shane13
  • Дата начала
Статус
Закрыто для дальнейших ответов.

puh14

Well-Known Member
11.07.2008
1 412
0
#2
Тз = сОЗДАТЬоБЪЕКТ("ТаблицаЗначений");
Тз.НоваяКолонка("Параметр");

Процедура Добавить()// на кнопку
ОткрытьПодбор("Справочник.Товары","ДляВыбора"); // первое - справочник, второе - какая форма
КонецПроцедуры

Процедура обработкаПодбора(выб)
Тз.НоваяСтрока()
Тз.параметр = Выб;
КонецПроцедуры
 
S

shane13

Гость
#3
А где писать
Тз = сОЗДАТЬоБЪЕКТ("ТаблицаЗначений");
Тз.НоваяКолонка("Параметр"); ??
уж простите....
 

puh14

Well-Known Member
11.07.2008
1 412
0
#4
В форме. Например в процедуре ПриОткрытии()
Если их просматривать и редактировать в форме надо, тогда вставить в форму объект ТаблицаЗначений , обозвать его и ссылаться напрямую - тогда

Тз = сОЗДАТЬоБЪЕКТ("ТаблицаЗначений");
Тз.НоваяКолонка("Параметр");

не надо

можно вместо таблицы список воткнуть тогда
Процедура обработкаПодбора(выб)
СПС.ДобавитьЗначение(Выб); // Где СПС - список значений в форме
КонецПроцедуры
 
Статус
Закрыто для дальнейших ответов.