Как Поставить Защиту В Папку Конфигурации 8.2

Тема в разделе "1C и всё что с ней связано", создана пользователем semerko, 7 янв 2014.

  1. semerko

    semerko Active Member

    Регистрация:
    31 май 2012
    Сообщения:
    31
    Симпатии:
    0
    Здравсвтуйте!!

    Помогите, я видел в одном конфе (не лицензионная), что когда работаешь в компе все нормально, но в случае когда копируешь папку или выгружаешь как cf , и открываешь в другом компе, где тоже работаю в 1С 8.2 , заходить в 1С и сразу исчезает. потом понял, что в папку bin необходимо было скопировать dll файл PSAddIn.dll, и после этого он работал нормально.

    Как сделал чтоб оно у меня тоже таким образом сработал, где и что пропустил?! Вот так написал в Модуль обычного режима.

    Код (Text):
    Перем глЗащита Экспорт;

    Процедура ЗапускЗащиты(Отказ)
    Отказ = Истина;
    Попытка
    Путь = "";
    Если Не ЗначениеЗаполнено(Путь) Тогда
    Путь = КаталогПрограммы();
    КонецЕсли;
    Файл = Новый Файл(Путь + "\PSAddIn.dll");
    Если Файл.Существует() Тогда
    Отказ = Ложь;
    глЗащита = Истина;
    Иначе
    Отказ = Истина;
    глЗащита = Ложь;
    КонецЕсли;
    Исключение
    Отказ = Истина;
    глЗащита = Ложь;
    КонецПопытки;
    КонецПроцедуры
     
Загрузка...

Поделиться этой страницей