Как Поставить Защиту В Папку Конфигурации 8.2

semerko

Active member
31.05.2012
31
0
#1
Здравсвтуйте!!

Помогите, я видел в одном конфе (не лицензионная), что когда работаешь в компе все нормально, но в случае когда копируешь папку или выгружаешь как cf , и открываешь в другом компе, где тоже работаю в 1С 8.2 , заходить в 1С и сразу исчезает. потом понял, что в папку bin необходимо было скопировать dll файл PSAddIn.dll, и после этого он работал нормально.

Как сделал чтоб оно у меня тоже таким образом сработал, где и что пропустил?! Вот так написал в Модуль обычного режима.

Код:
Перем глЗащита Экспорт;

Процедура ЗапускЗащиты(Отказ)
Отказ = Истина;
Попытка
Путь = "";
Если Не ЗначениеЗаполнено(Путь) Тогда
Путь = КаталогПрограммы();
КонецЕсли;
Файл = Новый Файл(Путь + "\PSAddIn.dll");
Если Файл.Существует() Тогда
Отказ = Ложь;
глЗащита = Истина;
Иначе
Отказ = Истина;
глЗащита = Ложь;
КонецЕсли;
Исключение
Отказ = Истина;
глЗащита = Ложь;
КонецПопытки;
КонецПроцедуры