Как проверить проведен ли документ?

Тема в разделе "1C и всё что с ней связано", создана пользователем 9AAAA, 11 июл 2011.

  1. 9AAAA

    9AAAA Гость

    Мне нужен следующий пример в коде 1С
    Если документ.реализация проведен то ...
    Нужно ли при этом пользоваться методом СоздатьОбъект?
     
  2. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    1. См. метод Проведен()
    2. Нужно, если не находишься в форме документа
     
  3. 9AAAA

    9AAAA Гость

    а вы можете дать свой номер ICQ?
     
  4. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    9AAAA, зачем ты собираешь у людей аску, вместо того чтобы учить мат.часть?
    ЖКК имеешь? если нет - есть в топах тема для начинающих

    P/S твоя проверка элементарена
    Код (Text):
    Если Реализация.Проведен() = 1 Тогда
    Сообщить("Реализация проведена");
    КонецЕсли;
    главное чтобы переменная Реализация уже несла в себе ссылку на документ, собственно то о чем говорил vbs
     
  5. 9AAAA

    9AAAA Гость

    что такое ЖКК?

    Добавлено: И надо ли после того как создал, но еще не проверил проведен ли документ искать нужный документ. Если да, то как?
     
  6. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    ЖКК - Желто-красные книги, т.е. документация!
    Создал кого? Если документ создал только - то он естественно будет не проведен
     
  7. alxrie

    alxrie Гость

    Док = СоздатьОбъект("Документ.Реализация"); // если под "создал" имелось в виду это, то
    Док.НайтиДокумент(НужныйДокумент); // да, надо спозиционироваться на нужный документ

    //в данном случае НужныйДокумент - это реквизит или переменная со значением типа Документ,
    //но можно искать по номеру, например:

    Док.НайтиПоНомеру("12345",'01.01.2011');

    или ещё как-то. Ну а затем проверить, например,

    Если Док.Проведен()=1 Тогда
    Сообщить("Однако, документ проведен");
    КонецЕсли;

    P.S. И присоединяюсь к уже высказанному пожеланию читать ЖКК, а также тексты программ типовых конфигураций.
     
  8. 9AAAA

    9AAAA Гость

    ЖКК для семерки нет, есть для восьмерки, пробовал читать, не помогает, слишком много слов, совершенно нет кода. Мисту уже облазил, хороший сайт.
    А в синтаксис помощнике не судьба посмотреть.
    alxrie Спасибо за помощь
     
  9. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    За неимением простой пытаемся писать на гербовой ?

    Это что-то особенного (с) :)
     
  10. alxrie

    alxrie Гость

    И не поможет. Как не поможет немецко-французский словарь при изучении английского языка. 7-ка и 8-ка отличаются весьма сильно (более того, даже 8.2 от 8.1 сильно отличаются).

    "ЖКК для 7-ки" - где-то в Сети пробегал. Так что найти при желании можно.
     
  11. 9AAAA

    9AAAA Гость

    У меня есть документы типа реализация, некоторые проведены, некоторые нет. Нужно ли использовать метод НайтиДокумент или НайтиПоНомеру или достаточно просто создать объект путем ДокРеал=СоздатьОбъект (Документ.Реализация) Если ДокРеал.Проведен=1 тогда далее мой текст кода
     
  12. alxrie

    alxrie Гость

    Что такое "есть документы"? Откуда они "есть"? Постарайся описать задачу по-человечески - тогда и получишь ответ.

    Возможно, ты перебираешь документы за период. Тогда так:

    Док = СоздатьОбъект("Документ.Реализация");
    Док.ВыбратьДокументы(НачДата,КонДата);
    Пока Док.ПолучитьДокумент()=1 Цикл
    Если Док.Проведен()=1 Тогда
    Сообщить("Реализация № "+Док.НомерДок+" от "+Док.ДатаДок+" проведена");
    Иначе
    Сообщить("А вот реализацию № "+Док.НомерДок+" от "+Док.ДатаДок+" - провести забыли (забили?)");
    КонецЕсли;
    КонецЦикла;

    Возможно, у тебя совсем другая задача.

    Читай документацию (только не по 8-ке - ты же не пользуешься немецко-французским словарём при изучении английского языка?). Хотя бы для того читай, чтобы задавать вопрос на понятном языке.

    Добавлено:
    Что такое "есть документы"? Откуда они "есть"? Постарайся описать задачу по-человечески - тогда и получишь ответ.

    Возможно, ты перебираешь документы за период. Тогда так:

    Док = СоздатьОбъект("Документ.Реализация");
    Док.ВыбратьДокументы(НачДата,КонДата);
    Пока Док.ПолучитьДокумент()=1 Цикл
    Если Док.Проведен()=1 Тогда
    Сообщить("Реализация № "+Док.НомерДок+" от "+Док.ДатаДок+" проведена");
    Иначе
    Сообщить("А вот реализацию № "+Док.НомерДок+" от "+Док.ДатаДок+" - провести забыли (забили?)");
    КонецЕсли;
    КонецЦикла;

    Возможно, у тебя совсем другая задача.

    Читай документацию (только не по 8-ке - ты же не пользуешься немецко-французским словарём при изучении английского языка?). Хотя бы для того читай, чтобы задавать вопрос на понятном языке.
     
  13. 9AAAA

    9AAAA Гость

    плюсик бы тебе поставить, да я к сожалению не могу

    Добавлено: Тошда такой вопрос, на форме отчета есть два поля типа дата с идентификатором ДатаНачала, ДатаКонца. Могу ли я их использовать при поиске документа за период в строчке Док.ВыбратьДокументы(ДатаНачала, ДатаКонца)
     
  14. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Можешь

    Добавлено:
    Это - к модераторам. Человек наваял порядочную главу за последний месяц,
    а сообщений у него ЧЕТЫРЕ и это число никак не увеличивается
     
  15. 9AAAA

    9AAAA Гость

    у меня тоже ситуация, сообщений четыре и число не увеличивается.
    Где создавать тему, поскольку личных сообщений я писать не могу
    vbs подскажи
     
  16. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    9AAAA, вообще-то уважаемый vbs как раз о тебе и писал эти строки! :lool:
    поэтому обратись к модераторам форума.


    P.S. может и к лучшему то что ты не можешь писать личных сообщений, а то бы точно всех достал в привате :blush:
     
  17. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Что интересно, у alxrie тоже 4 сообщения.
    Возможно, это какой-нибудь "баг 4-х сообщений")


    Добавлено: if username = "9AAAA" then
    post_count=4; // а то точно достанет всех в привате.
     
  18. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Ну, уж это слишком жестко - пусть хоть девять будет !
     
  19. Hryv

    Hryv Гость

    Если нужный документ еще не найден, то откуда будет известно какой документ проверять?
    Прежде чем задавать такой вопрос попробуй просто мыслить логично
     
Загрузка...

Поделиться этой страницей