Как проверить проведен ли документ?

  • Автор темы 9AAAA
  • Дата начала
9

9AAAA

#1
Мне нужен следующий пример в коде 1С
Если документ.реализация проведен то ...
Нужно ли при этом пользоваться методом СоздатьОбъект?
 

vbs

Well-known member
18.02.2007
1 708
1
#2
1. См. метод Проведен()
2. Нужно, если не находишься в форме документа
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#4
9AAAA, зачем ты собираешь у людей аску, вместо того чтобы учить мат.часть?
ЖКК имеешь? если нет - есть в топах тема для начинающих

P/S твоя проверка элементарена
Код:
Если Реализация.Проведен() = 1 Тогда
Сообщить("Реализация проведена");
КонецЕсли;
главное чтобы переменная Реализация уже несла в себе ссылку на документ, собственно то о чем говорил vbs
 
9

9AAAA

#5
что такое ЖКК?

Добавлено: И надо ли после того как создал, но еще не проверил проведен ли документ искать нужный документ. Если да, то как?
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#6
что такое ЖКК?

Добавлено: И надо ли после того как создал, но еще не проверил проведен ли документ искать нужный документ. Если да, то как?
ЖКК - Желто-красные книги, т.е. документация!
Создал кого? Если документ создал только - то он естественно будет не проведен
 
A

alxrie

#7
И надо ли после того как создал, но еще не проверил проведен ли документ искать нужный документ. Если да, то как?
Док = СоздатьОбъект("Документ.Реализация"); // если под "создал" имелось в виду это, то
Док.НайтиДокумент(НужныйДокумент); // да, надо спозиционироваться на нужный документ

//в данном случае НужныйДокумент - это реквизит или переменная со значением типа Документ,
//но можно искать по номеру, например:

Док.НайтиПоНомеру("12345",'01.01.2011');

или ещё как-то. Ну а затем проверить, например,

Если Док.Проведен()=1 Тогда
Сообщить("Однако, документ проведен");
КонецЕсли;

P.S. И присоединяюсь к уже высказанному пожеланию читать ЖКК, а также тексты программ типовых конфигураций.
 
9

9AAAA

#8
ЖКК для семерки нет, есть для восьмерки, пробовал читать, не помогает, слишком много слов, совершенно нет кода. Мисту уже облазил, хороший сайт.
А в синтаксис помощнике не судьба посмотреть.
alxrie Спасибо за помощь
 

vbs

Well-known member
18.02.2007
1 708
1
#9
ЖКК для семерки нет, есть для восьмерки, пробовал читать, не помогает, слишком много слов
За неимением простой пытаемся писать на гербовой ?

А в синтаксис помощнике не судьба посмотреть
Это что-то особенного (с) :)
 
A

alxrie

#10
ЖКК для семерки нет, есть для восьмерки, пробовал читать, не помогает
И не поможет. Как не поможет немецко-французский словарь при изучении английского языка. 7-ка и 8-ка отличаются весьма сильно (более того, даже 8.2 от 8.1 сильно отличаются).

"ЖКК для 7-ки" - где-то в Сети пробегал. Так что найти при желании можно.
 
9

9AAAA

#11
У меня есть документы типа реализация, некоторые проведены, некоторые нет. Нужно ли использовать метод НайтиДокумент или НайтиПоНомеру или достаточно просто создать объект путем ДокРеал=СоздатьОбъект (Документ.Реализация) Если ДокРеал.Проведен=1 тогда далее мой текст кода
 
A

alxrie

#12
У меня есть документы типа реализация,
Что такое "есть документы"? Откуда они "есть"? Постарайся описать задачу по-человечески - тогда и получишь ответ.

Возможно, ты перебираешь документы за период. Тогда так:

Док = СоздатьОбъект("Документ.Реализация");
Док.ВыбратьДокументы(НачДата,КонДата);
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.Проведен()=1 Тогда
Сообщить("Реализация № "+Док.НомерДок+" от "+Док.ДатаДок+" проведена");
Иначе
Сообщить("А вот реализацию № "+Док.НомерДок+" от "+Док.ДатаДок+" - провести забыли (забили?)");
КонецЕсли;
КонецЦикла;

Возможно, у тебя совсем другая задача.

Читай документацию (только не по 8-ке - ты же не пользуешься немецко-французским словарём при изучении английского языка?). Хотя бы для того читай, чтобы задавать вопрос на понятном языке.

Добавлено:
У меня есть документы типа реализация,
Что такое "есть документы"? Откуда они "есть"? Постарайся описать задачу по-человечески - тогда и получишь ответ.

Возможно, ты перебираешь документы за период. Тогда так:

Док = СоздатьОбъект("Документ.Реализация");
Док.ВыбратьДокументы(НачДата,КонДата);
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.Проведен()=1 Тогда
Сообщить("Реализация № "+Док.НомерДок+" от "+Док.ДатаДок+" проведена");
Иначе
Сообщить("А вот реализацию № "+Док.НомерДок+" от "+Док.ДатаДок+" - провести забыли (забили?)");
КонецЕсли;
КонецЦикла;

Возможно, у тебя совсем другая задача.

Читай документацию (только не по 8-ке - ты же не пользуешься немецко-французским словарём при изучении английского языка?). Хотя бы для того читай, чтобы задавать вопрос на понятном языке.
 
9

9AAAA

#13
плюсик бы тебе поставить, да я к сожалению не могу

Добавлено: Тошда такой вопрос, на форме отчета есть два поля типа дата с идентификатором ДатаНачала, ДатаКонца. Могу ли я их использовать при поиске документа за период в строчке Док.ВыбратьДокументы(ДатаНачала, ДатаКонца)
 

vbs

Well-known member
18.02.2007
1 708
1
#14
Можешь

Добавлено:
плюсик бы тебе поставить, да я к сожалению не могу
Это - к модераторам. Человек наваял порядочную главу за последний месяц,
а сообщений у него ЧЕТЫРЕ и это число никак не увеличивается
 
9

9AAAA

#15
у меня тоже ситуация, сообщений четыре и число не увеличивается.
Где создавать тему, поскольку личных сообщений я писать не могу
vbs подскажи
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#16
Можешь

Добавлено:
Это - к модераторам. Человек наваял порядочную главу за последний месяц,
а сообщений у него ЧЕТЫРЕ и это число никак не увеличивается
9AAAA, вообще-то уважаемый vbs как раз о тебе и писал эти строки! :lool:
поэтому обратись к модераторам форума.


P.S. может и к лучшему то что ты не можешь писать личных сообщений, а то бы точно всех достал в привате :blush:
 

unknown181538

НеГуру
28.12.2008
1 417
0
#17
Что интересно, у alxrie тоже 4 сообщения.
Возможно, это какой-нибудь "баг 4-х сообщений")


Добавлено: if username = "9AAAA" then
post_count=4; // а то точно достанет всех в привате.
 
H
#19
Добавлено: И надо ли после того как создал, но еще не проверил проведен ли документ искать нужный документ.
Если нужный документ еще не найден, то откуда будет известно какой документ проверять?
Прежде чем задавать такой вопрос попробуй просто мыслить логично