Как В 1с Удалить Строку Из Созданной Формы Кнопкой?

  • Автор темы Vitek2
  • Дата начала
V

Vitek2

#1
Создал Справочник2. Создал фому ФормаВыбора
На нее наложил кнопку

Процедура Кнопка2Нажатие(Элемент)
СправочникОбъект.<Справочник2>
Удалить
КонецПроцедуры


Выдаётся отладчиком
{Справочник.Справочник2.Форма.ФормаВыбора(19,18)}: Ожидается идентификатор
СправочникОбъект.<<?>><Справочник2>
{Справочник.Справочник2.Форма.ФормаВыбора(19,19)}: Неопознанный оператор
СправочникОбъект.<<<?>>Справочник2>

В чём причина и что делать, чтобы программа работала?
 

Вложения

Дайнеко

Well-known member
19.11.2009
951
0
#2
Действия таковы:
* Обратится к эементу формы со списком. В нем извлечь строку на которой стоит курсор (ТекущиеДанные())
* Потом правильной командой ее удалить.
Ищите примеры.
 
V

Vitek2

#3
Действия таковы:
* Обратится к эементу формы со списком. В нем извлечь строку на которой стоит курсор (ТекущиеДанные())
* Потом правильной командой ее удалить.
Ищите примеры.
Создан Справочник2 – справочник сотрудников (код, наименование, ФИО, Т.N. Создана ФормаСписка. В ней создана кнопка.

Процедура Кнопка1Нажатие(Элемент)
Справочники.Справочник2.Форма.ФормаСписка.СправочникСписок.Код.Значение();
// Этаформа.СправочникСписок.Код.Значение();
//ТЕКУЩИЕДАННЫЕ();
Элемент.УДАЛИТЬ();
КонецПроцедуры

На это выдаётся такое сообщение:
Обнаружены ошибки:
{Справочник.Справочник2.Форма.ФормаСписка(3)}: Поле объекта не обнаружено (Форма)
Справочники.Справочник2.Форма.ФормаСписка.СправочникСписок.Код.Значение();

Если

Процедура Кнопка1Нажатие(Элемент)
// Справочники.Справочник2.Форма.ФормаСписка.СправочникСписок.Код.Значение();
Этаформа.СправочникСписок.ТЕКУЩИЕДАННЫЕ();
//ТЕКУЩИЕДАННЫЕ();
Элемент.УДАЛИТЬ();
// Вставить содержимое обработчика.
КонецПроцедуры

На это выдаётся такое сообщение: Метод объекта не обнаружен (ТЕКУЩИЕДАННЫЕ)
Обнаружены ошибки:
{Справочник.Справочник2.Форма.ФормаСписка(4)}: Метод объекта не обнаружен (ТЕКУЩИЕДАННЫЕ)
Этаформа.СправочникСписок.ТЕКУЩИЕДАННЫЕ();

В VisualFoxPro это делается просто:
Select “Имя таблицы”
Go top &&– если нужна первая запись
&&Locate for ThisForm.Grid1.Column1.Text1.Value=15 &&– если например нужна запись со значением 15
Delete
A например, присвоить элементу формы значение и того проще ThisForm.”Объект”.”ЭлементОбъекта”.Value=”Значение “. Например:
ThisForm.Grid1.Column1.Text1.Value=15
ThisForm..Refresh() – Для обновления формы, если это надо.

А в 1С не знаю как быть? Помогите! Со своей стороны, если нужна помощь в VisualFoxPro всегда рад помочь.