1. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление

как записать документ?

Тема в разделе "Базы данных и администрирование", создана пользователем shane13, 10 ноя 2008.

  1. shane13

    shane13 Гость

    Репутация:
    0
    как-то так получилось, что никогда не записывала документы программно... не получается(
    //*******************************************
    Процедура Сформировать()
    Поставка = СоздатьОбъект("Документ.ЛогистикаПоставка");
    Поставка.ВыбратьДокументы(НачДата, КонДата);
    Пока Поставка.ПолучитьДокумент() = 1 Цикл
    ТекПоставка = Поставка.ТекущийДокумент();
    Если ПустоеЗначение(ТекПоставка.ДатаПрибытия) = 1 Тогда
    ТекПоставка.ДатаПрибытия = ТекПоставка.ДатаДок;
    ТекПоставка.Записать();
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры

    Что не так? Пишет: Не выбран документ!

    )))) блин... Всё!!! Сама разобралась.
     
Загрузка...

Поделиться этой страницей