1. Спонсор публикаций Marketplace codeby. Сервис, который так долго ждали. При расчетах используем биткоин. Первый товар уже в продаже: Консультация на тему ИБ от Ondrik8

    Скрыть объявление
  2. Спонсор публикаций Marketplace codeby. Сервис, который так долго ждали. При расчетах используем биткоин. Второй товар маркетплейса: Надёжная обфускация вашей программы от PingVinich

    Скрыть объявление

как записать документ?

Тема в разделе "1C и всё что с ней связано", создана пользователем shane13, 10 ноя 2008.

  1. shane13

    shane13 Гость

    Репутация:
    0
    как-то так получилось, что никогда не записывала документы программно... не получается(
    //*******************************************
    Процедура Сформировать()
    Поставка = СоздатьОбъект("Документ.ЛогистикаПоставка");
    Поставка.ВыбратьДокументы(НачДата, КонДата);
    Пока Поставка.ПолучитьДокумент() = 1 Цикл
    ТекПоставка = Поставка.ТекущийДокумент();
    Если ПустоеЗначение(ТекПоставка.ДатаПрибытия) = 1 Тогда
    ТекПоставка.ДатаПрибытия = ТекПоставка.ДатаДок;
    ТекПоставка.Записать();
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры

    Что не так? Пишет: Не выбран документ!

    )))) блин... Всё!!! Сама разобралась.
     
Загрузка...

Поделиться этой страницей