как записать документ?

  • Автор темы shane13
  • Дата начала
S

shane13

#1
как-то так получилось, что никогда не записывала документы программно... не получается(
//*******************************************
Процедура Сформировать()
Поставка = СоздатьОбъект("Документ.ЛогистикаПоставка");
Поставка.ВыбратьДокументы(НачДата, КонДата);
Пока Поставка.ПолучитьДокумент() = 1 Цикл
ТекПоставка = Поставка.ТекущийДокумент();
Если ПустоеЗначение(ТекПоставка.ДатаПрибытия) = 1 Тогда
ТекПоставка.ДатаПрибытия = ТекПоставка.ДатаДок;
ТекПоставка.Записать();
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Что не так? Пишет: Не выбран документ!

)))) блин... Всё!!! Сама разобралась.