• Codeby web-security - Курс "Тестирование Веб-Приложений на проникновение с нуля" от команды codeby. Общая теория, подготовка рабочего окружения, пассивный фазинг и фингерпринт, Активный фаззинг, Уязвимости, Пост-эксплуатация, Инструментальные средства, Social Engeneering и многое другое. Подробнее ...

  • Мобильный клиент нашего форума для Android гаджетов доступен в Google Play Market по этой ссылке. Клиент можно скачать с нашего форума по этой ссылке. Последняя версия МК в нашем телеграм канале вот здесь

Проблема Как запустить Quasar RAT на виртуальной машине? :)

Teo

Member
08.07.2018
6
2
#1
Добрый день, друзья, очень прошу совета! :)

Уже больше недели бьюсь, не могу запустить серверную часть Quasar RAT на VitrualBox. :) Причем, на обычном компе всё работает, а на нём же, но под виртуалкой - нет! :)

- Есть домен на no-ip.com, указывающий на статический IP моего провайдера. Именно он и прописан в клиентской части, которую сгенерировал билдер
- Использую 80-ый порт, на роутере форвардинг открыт, всё ок
- Клиентом я заразил один из своих ноутов, что находится в моей домашней сети, за роутером

На основном компе всё работает отлично, причем, даже не запущен DUC клиент, но стоит запустится на виртуалке - сервер не видит зараженную машину. Пробовал настройки сети для VM в виде NAT и Bridge - не работает :) На гостевой машине пробовал с DUC клиентом и без, перебрал все возможные варианты IP - никакого эффекта :)

Может есть какие тонкости? Как вы запускаете RAT на виртуалке?
Перерыл весь инет на всех языках, но решения не нашел ...

Буду очень благодарен за помощь! :)
 

23.zaycev

New member
23.04.2018
3
3
#2
На основном компе всё работает отлично, причем, даже не запущен DUC клиент, но стоит запустится на виртуалке - сервер не видит зараженную машину.
Попробуйте пропинговать ваш сервер в виртуалке, чтобы понять доходят ваши пакеты или нет. Если нет, то меняйте тип подключения(желательно Bridge) и диапазон адресов в котором находится ваша зараженная машина.

Может Вам понадобится
Для просмотра контента необходимо: Войти или зарегистрироваться
, чтобы приблизительно понять как это настраивается. Правда это для VMware, но я думаю они не сильно отличаются. Ну а так хотелось бы побольше информации, что и где именно вы прописывали. :)
 

Langolier

Grey Team
05.05.2018
205
247
#3
Могу лишь подкинуть мысль об характере проблемы.
Источник проблемы - не в конфигураци сети. :devilish:
На виртуалках обычно не запускается софт, которому нужны драйвера видеокарты.
Точнее, сама видеокарта.
Ратнику она нужна - это объективно ))

А на виртуалках какие видеокарты ? Там эмуляторы видеокарт и один драйвер на все случаи.
Думаю, что твой ратник не запускается из-за того, что не может "договориться" с этим самым "видеодрайвером на все случаи".

Если тебе принципиально запустить ратник на виртуалке, то попробуй другую виртуальную машину. Нужна виртуальная машина, в которую можно пробросить видеокарту. Виртуалбокс и vmware такими функциями не наделены.
 
Симпатии: Понравилось Teo

Teo

Member
08.07.2018
6
2
#5
Попробуйте пропинговать ваш сервер в виртуалке, чтобы понять доходят ваши пакеты или нет. Если нет, то меняйте тип подключения(желательно Bridge) и диапазон адресов в котором находится ваша зараженная машина.

Может Вам понадобится
Для просмотра контента необходимо: Войти или зарегистрироваться
, чтобы приблизительно понять как это настраивается. Правда это для VMware, но я думаю они не сильно отличаются. Ну а так хотелось бы побольше информации, что и где именно вы прописывали. :)
Спасибо, за реакцию, коллега :)

Домен на no-ip пингуется из виртуалки, все ок, подключение - Bridge. Но как только я запускаю на виртуалке сервер Quasar - ничего не происходит, зараженная машина не появляется. Однако, стоит перейти обратно в основную систему и запустить Quasar - всё работает, зараженная машина быстро появляется и всё работает чётко :) Вы пишите о том, что нужно что-то где-то прописывать? Может нужно менять настройки TCP/IP? на гостевой системе? :) Я признаться, ничего нигде не прописывал, инет на виртуальной машине работает ... Ip основной машины 192.168.0.10, а виртуальной - 192.168.0.24 ...

Могу лишь подкинуть мысль об характере проблемы.
Источник проблемы - не в конфигураци сети. :devilish:
На виртуалках обычно не запускается софт, которому нужны драйвера видеокарты.
Точнее, сама видеокарта.
Ратнику она нужна - это объективно ))

А на виртуалках какие видеокарты ? Там эмуляторы видеокарт и один драйвер на все случаи.
Думаю, что твой ратник не запускается из-за того, что не может "договориться" с этим самым "видеодрайвером на все случаи".

Если тебе принципиально запустить ратник на виртуалке, то попробуй другую виртуальную машину. Нужна виртуальная машина, в которую можно пробросить видеокарту. Виртуалбокс и vmware такими функциями не наделены.
Я немного неверно сформулировал, видимо ... :) Извините! :) Поправлюсь: серверная часть ратника отлично запускается в гостевой системе, но не принимает отстука от зараженного клиента ... В то время как на домашней системе всё чётко работает. Но мне очень нужно иметь возможность управлять своими клиентами из виртуальной системы, но пока тщетно ... :)
 
08.07.2018
6
2
#6
Teo, отпишись об решении проблемы, очень уж хочется знать в чем проблема была :)
Так и не разобрался, не могу понять, что не так :) Придется с обычной системы рулить сетью Ratов, на виртуалке Quasar не видит клиентов ...
 

Tom

Премиум
27.07.2018
69
30
#7
Использую 80-ый порт, на роутере форвардинг открыт, всё ок
Пробовал настройки сети для VM в виде NAT и Bridge - не работает
Стесьняюсь спросить: А на VM 80-ый порт пробросили?

Странное дело, но если перенаправлять с порта 80 на 80, то работать все это не будет. Нужно использовать 8080 на 80.

Для этого откройте контекстное меню для машины и нажмите «Настройки»:
Затем перейдите на вкладку «Сеть», а потом разверните строчку «Дополнительно»:

Тут вам нужно нажать кнопку «Проброс портов»:
Дальше нажмите кнопку с зеленым значком «+». Тут нужно заполнить несколько полей:


  • Имя — любое имя, по которому вы сможете понять с чем имеете дело;
  • Протокол — протокол, по которому работает сервис, например, tcp;
  • Адрес хоста — адрес на основной машине, подключения к которому будут направляться на виртуальную машину, можно написать 127.0.0.1 или ip в локальной сети;
  • Порт хоста — порт, подключения к которому нужно перенаправлять на гостя;
  • Адрес гостя — на который нужно направлять подключения, оставьте пустым;
  • Порт гостя — порт, на который будут перенаправлены подключения с этого порта.

Адрес хоста в локальной сети можно узнать так:
ifconfig

Еще один важный момент, что порт с которого вы перенаправляете и на который перенаправляете не должны совпадать. Повторю: если перенаправлять с порта 80 на 80, то работать все это не будет. Нужно использовать 8080 на 80. Тогда все в порядке. Если вы не любитель много кликать, что можно воспользоваться командной терминала:

VBoxManage modifyvm "Имя машины" --natpf1 "rulename,tcp,127.0.0.1,8080,,80"

В этом примере взяты данные из рассмотренного выше примера. Теперь на хосте и виртуальной машине откроется одна и та же страница.

Если что-то пойдет не так, как Вы хотели - есть еще один способ - использовать виртуальный адаптер хоста.

 

Вложения

Последнее редактирование:
Симпатии: Понравилось Teo
#8
Могу лишь подкинуть мысль об характере проблемы.
Источник проблемы - не в конфигураци сети. :devilish:
На виртуалках обычно не запускается софт, которому нужны драйвера видеокарты.
Точнее, сама видеокарта.
Ратнику она нужна - это объективно ))

А на виртуалках какие видеокарты ? Там эмуляторы видеокарт и один драйвер на все случаи.
Думаю, что твой ратник не запускается из-за того, что не может "договориться" с этим самым "видеодрайвером на все случаи".

Если тебе принципиально запустить ратник на виртуалке, то попробуй другую виртуальную машину. Нужна виртуальная машина, в которую можно пробросить видеокарту. Виртуалбокс и vmware такими функциями не наделены.
Не совсем так, у меня работает тестовая сеть зараженная именно тем ратником что у автора. Сеть построена на виртуалках Hyper-V, роль которой поднята на обычном сервере DELL , где и не пахло видяхами. Все работает на ура.
 
Симпатии: Понравилось Teo
08.07.2018
6
2
#9
Стесьняюсь спросить: А на VM 80-ый порт пробросили?

Странное дело, но если перенаправлять с порта 80 на 80, то работать все это не будет. Нужно использовать 8080 на 80.

Для этого откройте контекстное меню для машины и нажмите «Настройки»:
Затем перейдите на вкладку «Сеть», а потом разверните строчку «Дополнительно»:

Тут вам нужно нажать кнопку «Проброс портов»:
Дальше нажмите кнопку с зеленым значком «+». Тут нужно заполнить несколько полей:


  • Имя — любое имя, по которому вы сможете понять с чем имеете дело;
  • Протокол — протокол, по которому работает сервис, например, tcp;
  • Адрес хоста — адрес на основной машине, подключения к которому будут направляться на виртуальную машину, можно написать 127.0.0.1 или ip в локальной сети;
  • Порт хоста — порт, подключения к которому нужно перенаправлять на гостя;
  • Адрес гостя — на который нужно направлять подключения, оставьте пустым;
  • Порт гостя — порт, на который будут перенаправлены подключения с этого порта.

Адрес хоста в локальной сети можно узнать так:
ifconfig

Еще один важный момент, что порт с которого вы перенаправляете и на который перенаправляете не должны совпадать. Повторю: если перенаправлять с порта 80 на 80, то работать все это не будет. Нужно использовать 8080 на 80. Тогда все в порядке. Если вы не любитель много кликать, что можно воспользоваться командной терминала:

VBoxManage modifyvm "Имя машины" --natpf1 "rulename,tcp,127.0.0.1,8080,,80"

В этом примере взяты данные из рассмотренного выше примера. Теперь на хосте и виртуальной машине откроется одна и та же страница.

Если что-то пойдет не так, как Вы хотели - есть еще один способ - использовать виртуальный адаптер хоста.

Tom, спасибо гигантское! :) Всё получилось! Всё работает в режиме сети NAT с пробросом портов, как на скринах! :) Причем пробросилось с 80 на 80 :) 8080 использовать не пришлось :) Еще раз - СПАСИБО !!! :)
 
Симпатии: Понравилось Tom
Вверх Снизу