Каким событием воспользоваться для поля ввода?

Тема в разделе "1C и всё что с ней связано", создана пользователем anivaler, 16 сен 2008.

Статус темы:
Закрыта.
  1. anivaler

    anivaler Гость

    У меня есть поле ввода табличного поля. В нём имеется кнопка выбора. Я вешаю на него событие "Обработка выбора". Я обрабатываю два значения: текущее значение и выбранное значение поля ввода. Но это событие действует только когда я мышью нажимаю на кнопку выбора и выбираю значение из какого-нибудь списка.
    Мне же нужно обрабатывать текущие и выбранные значения при вводе значения вручную. Возможно ли это и какие события мне подойдут?

    PS:Смотрел события АвтоПодборТекста и ПриИзменении, но не знаю как вытянуть с их помощью текущие значения.
     
  2. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    Что-то я не врубаюсь!!! Тебе надо редактировать ТаблицуЗначений???? Тогда на нее вешай процедурку ПриВыбореЗначенийВТаблице().
    Код (Text):
    Процедура ПриВыбореЗначенийВТаблице()
    Если ТаблицаДанных.КоличествоСтрок()>0 Тогда
    ЗначениеРедактирования=ТаблицаДанных.ПолучитьЗначение(Таблицаданных.ТекущаяСтрока(),"ЗначениеДляРедактирования");
    ВвестиЗначение(ЗначениеРедактирования,"Редактируем значениев таблице");
    ТаблицаДанных.УстановитьЗначение(Таблицаданных.ТекущаяСтрока(),"ЗначениеДляРедактирования",ЗначениеРедактирования);
    КонецЕсли;
    КонецПроцедуры
    Если же ты решил редактировать значение в таблице через поле на форме то тебе пригодится Предопределенная процедура "ПриНачалеВыбораЗначения(Идентификаторо,флаг)"
    где идентификатор - это идентификатор реквизита элемента на форме с кем ты работаешь ... а флаг это обработка стандартног диалога ....
    тоесть допустим:
    есть таблицаДанных, есть поле (например которое будет отвечать за один столбец в ТаблицеДанных) с идентификатором Элемент -
    делаем:
    Код (Text):
    Процедура ПриНачалеВыбораЗначения(Идентификаторо,флаг)
    Если Идентификаторо="Элемент" Тогда
    Флаг=0; //ставим что будем сами редакт....
    Если Таблицаданных.КоличествоСтрок()>0 Тогда
    ЗначениеРедактирования=ТаблицаДанных.ПолучитьЗначение(Таблицаданных.ТекущаяСтрока(),"Элемент"); // где "Элемент" - это идентификатор столбца
    ВвестиЗначение(ЗначениеРедактирования,"Редактируем значение".......);
    Таблицаданных.УстановитьЗначение(Таблицаданных.ТекущаяСтрока(),"Элемент",ЗначениеРедактирования);
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    Да вот еще что можешь повесить на форме функцию для отображения в поля соответствующие данне (зависящее от строки в таблицеДанных)....

    если что то я тут
    Да пример писал для 7 ....
    :)
     
  3. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    Молчишь как в танке!!! Что такое???
     
  4. anivaler

    anivaler Гость

    Забыл сказать, что я в восьмерке программирую... Замолчал, потому что разобрался...Повесил Событие ПриИзменении()...Подошло...


    Спасибо тебе за помощь!
     
Загрузка...
Похожие Темы - Каким событием воспользоваться
  1. Анастасия
    Ответов:
    3
    Просмотров:
    1.044
  2. legzzi
    Ответов:
    1
    Просмотров:
    1.124
  3. dzheyzhi
    Ответов:
    8
    Просмотров:
    2.205
  4. nestadima
    Ответов:
    0
    Просмотров:
    2.760
  5. Истребитель
    Ответов:
    6
    Просмотров:
    2.199
Статус темы:
Закрыта.

Поделиться этой страницей