Классификатор адресов

SeverBap

Well-known member
18.09.2007
451
0
#1
:) возникла ситуация создать простенькую конфигурацию по учету продукции ...
все как всегда (у меня была выризка справочника контрагентов со всеми зависимыми обработками и справочниками), вот это без проблем работает с этим справочником....
Потом возникла ситуация на днях, надо вводить адреспрописка и место жительства в справочнике сотрудник; все как всегда кинул привезал ниодной ошибки ... с диска ИТС поставил классификатор (спомощью обработки - стандартной импорт классификаторов ...) загрузилось нормально ....

ПРОБЛЕМА:

При вводе в обработке (стандартной ВводАдреса) выбираем Регион - нормально, потом город все правильно ставит ... жму на кнопку ок и на тебе чистит все и регион и город остается только индекс ..., я уже думал что кто-то прикалолся написал принажатии очищать неаааа ...
все поперерыл непомогает ...

народ че делать ????? в чем причина ведь всегда как только второе значение начинаю выбирать и соглашаюсь все чистится!!!!???
:) :) все поперепроверил по несколько раз!!!!
 
K
#2
на закладке Классификаторы поставте тип класификатора что-то там 2003
 

SeverBap

Well-known member
18.09.2007
451
0
#4
Суть проблемы: есть справочник, у справочника есть реквизит ЮридическийАдрес (тип - строка 240). Для удобства ввода на форме вешается реквизит диалога ЮридическийАдресСтр с типом строка 240, и кнопкой выбора, запрещается редактирование.
В модуле форме пишится процедура:
Код:
Процедура ПриНачалеВыбораЗначения(ЭлементДиалога,Флаг) 
Если ЭлементДиалога="ЮридическийАдресСтр" Тогда
Флаг=0;
глВводАдреса(ЮридическийАдрес);
КонецЕсли;
КонецПроцедуры
Так же на форму кидается реквизит "Текст" с формулой (тоесть когда пообходу дойдет до этого текста выполнит функцию), листинг функции:
Код:
Функция ОбработатьАдреса()
ЮридическийАдресСтр=глПредставлениеАдреса(ЮридическийАдрес);
КонецФункции
Все как положено вводит, выводит. Косяк в том что у меня почему-то после повторного редактирования адреса - адрес пихает в произвольный формат, а не как надо через менюшки в обработке ввода адреса с помощью классификатора!!!
Не могу понять в чем дело!!! Подскажите чем нибудь! :blink: