книга продаж

  • Автор темы milok183
  • Дата начала
M

milok183

#1
проблема в следующем-при просчете за полгода и более в графе всего продаж -вылезает 9999999999,99 -ели делаешь за меньший период то нормально-если сумма меньше миллиарда-где что посмотреть-все пересмотрел и длину менял и ширину в таблице все равно такая фигня вылазит
заранее спасибо
 
G

GRblSHA

#2
Твоя проблема из серии: "У меня не работает, а почему...." Тут не многие могут читать мысли и имеют доступ к твоей базе, для того, чтобы лицезреть проблему!
сделай это полугодие помесячно и посмотри может, кто-то при вводе счет фактуры на клавиатуру книжку положил и получилась заоблачная сумма вот она и вылазиет??!!
Найдешь месяц где миллЬЯрды показывает и просмотри все счет фактуры (если надо скинь в Excel и там суммируй)
 
M

milok183

#3
У МЕНЯ ДЕЙСТВИТЕЛЬНО СУММА ДОЛЖНА БЫТЬ БОЛЬШЕ 1 МЛРД ПРОСТО ОНА НЕ ОТРАЖАЕТСЯ КОРРЕКТНО ВОТ В ЧЕМ ПРОБЛЕМА !!!
СЧЕТА ПРОСМОТРЕЛ ОБОРОТ ЗА 1,3 ГДЕ ТО ДОЛЖЕН БЫТЬ
 

puh14

Well-known member
11.07.2008
1 412
0
#4
Энто тебе надо посмотреть в отчете КнигаПродаж по строке Формат - у тебя сумма округляются до 15-ти знаков. попробуй увеличить до 20.

типа Таб.ИспользоватьФормат("Ч-20.2-");
 
M

milok183

#5
у меня сделана внешняя обработка все там выставил вот кусочек ТаблицаЗаписейДока=СоздатьОбъект("ТаблицаЗначений");
ТаблицаЗаписейДока.НоваяКолонка("Приоритет","Число","1","0");
ТаблицаЗаписейДока.НоваяКолонка("ДопНадпись","Строка","25");// Аванс, Част. оплата и т.п.
ТаблицаЗаписейДока.НоваяКолонка("Комментарий","Строка","50");
ТаблицаЗаписейДока.НоваяКолонка("СчетФактура","Документ");
ТаблицаЗаписейДока.НоваяКолонка("ДокОплаты","Документ");
ТаблицаЗаписейДока.НоваяКолонка("ДокОтгрузки","Документ");

ТаблицаЗаписейДока.НоваяКолонка("СуммаВсего","Число","20","2");
ТаблицаЗаписейДока.НоваяКолонка("СуммаБезНДС20","Число","20","2");
ТаблицаЗаписейДока.НоваяКолонка("НДС20","Число","20","2");
ТаблицаЗаписейДока.НоваяКолонка("СуммаБезНДС18","Число","20","2");
ТаблицаЗаписейДока.НоваяКолонка("НДС18","Число","20","2");
ТаблицаЗаписейДока.НоваяКолонка("СуммаБезНДС10","Число","20","2");
ТаблицаЗаписейДока.НоваяКолонка("НДС10","Число","20","2");
ТаблицаЗаписейДока.НоваяКолонка("НДС0","Число","20","2");
ТаблицаЗаписейДока.НоваяКолонка("СуммаСовсемБезНДС","Число","20","2");
ТаблицаЗаписейДока.НоваяКолонка("СуммаНП","Число","20","2");
ТаблицаЗаписейДока.НоваяКолонка("ТипЗаписи","Число","2","0");
.... не помогает :)
 

puh14

Well-known member
11.07.2008
1 412
0
#6
А Формат вообще нет? такая ситуация обычно бывает что у тебя десятисимвольное значение, а округляет или форматирует до меньшего количества символов. Ну он и забивает всё девятками. Так что ищи Формат и Окр. Ну и в таблице, да. и в печатной глянь - мож там #Ч10.2
 
M

milok183

#7
формат и окр не нашел может кто кинет в меня книгой продаж-хоть сравню может где накосячил предшественник-не я писал обработку -заранее благодарен -milok1997@mail.ru -буду искать причину
 

puh14

Well-known member
11.07.2008
1 412
0
#8
Лучше выгрузи и пошли на мыло puh14@mail.ru постараюсь помочь. Кинул свою из бухгалтерии.
 

puh14

Well-known member
11.07.2008
1 412
0
#10
Попробуй при создании книги продаж перед выводом таблицы написать Сообщить(ИтогВсего); что он скажет. а то у меня чувство ГлФРМ из глобалки тебе обрезает символы. у меня - то она не используется, сумма напрямую идет.

Функция глФРМ(ЧислЗнач, Валюта="", ВыводНулевого="0", РаздТриад="'") Экспорт
Перем РезСтрока, ФрмСтрока;

РезСтрока = СокрЛ(Формат(ЧислЗнач, "Ч" + ВыводНулевого + "15.2." + РаздТриад));

Если (ПустоеЗначение(РезСтрока) = 0) И (ПустоеЗначение(Валюта) = 0) Тогда
РезСтрока = РезСтрока + " " + СокрП(Валюта.Наименование);
КонецЕсли;

Возврат РезСтрока;

КонецФункции // глФРМ()

На складе нашел. Собственно интересно это

РезСтрока = СокрЛ(Формат(ЧислЗнач, "Ч" + ВыводНулевого + "15.2." + РаздТриад));


Надо

РезСтрока = СокрЛ(Формат(ЧислЗнач, "Ч" + ВыводНулевого + "20.2." + РаздТриад));
 
M

milok183

#11
Спасибо-помогло :) вроде нормально стало отражаться-еще все проверю ...:)
 
M

milok183

#12
вдогонку-сегодня еще нашел в глобальном модуле-поменял 15 на 22 и "страя" книга продаж стала корректно отражаться :)
Функция глФРМ(ЧислЗнач,Вал,Реж) Экспорт
// Это процедура нашего стандартного форматирования цен и сумм:
// Для рублей не печатаем дроби, для других валют 3 знака после запятой
// Триады отделяем символом (')
Стр=?(Вал=Константа.СтараяБазоваяВалюта,СокрЛ(Формат(ЧислЗнач,"Ч022.0.'")),СокрЛ(Формат(ЧислЗнач,"Ч022.2.'")));
Если (Реж=0) ИЛИ (ПустаяСтрока(Стр)=1) Тогда
Возврат Стр;
Иначе
Возврат Стр+" "+СокрП(Вал.Наименование);
КонецЕсли;
КонецФункции

//******************************************************************************
Функция глФРМТ(ЧислЗнач,Вал,Реж) Экспорт
// Это процедура нашего стандартного форматирования цен и сумм:
// Для рублей не печатаем дроби, для других валют 3 знака после запятой
// Без разделения на Триады
Стр=?(Вал=Константа.СтараяБазоваяВалюта,СокрЛ(Формат(ЧислЗнач,"Ч022.0")),СокрЛ(Формат(ЧислЗнач,"Ч022.2")));
Если (Реж=0) ИЛИ (ПустаяСтрока(Стр)=1) Тогда
Возврат Стр;
Иначе
Возврат Стр+" "+СокрП(Вал.Наименование);
КонецЕсли;
КонецФункции