книга продаж

Тема в разделе "1C и всё что с ней связано", создана пользователем milok183, 14 авг 2008.

  1. milok183

    milok183 Гость

    проблема в следующем-при просчете за полгода и более в графе всего продаж -вылезает 9999999999,99 -ели делаешь за меньший период то нормально-если сумма меньше миллиарда-где что посмотреть-все пересмотрел и длину менял и ширину в таблице все равно такая фигня вылазит
    заранее спасибо
     
  2. GRblSHA

    GRblSHA Гость

    Твоя проблема из серии: "У меня не работает, а почему...." Тут не многие могут читать мысли и имеют доступ к твоей базе, для того, чтобы лицезреть проблему!
    сделай это полугодие помесячно и посмотри может, кто-то при вводе счет фактуры на клавиатуру книжку положил и получилась заоблачная сумма вот она и вылазиет??!!
    Найдешь месяц где миллЬЯрды показывает и просмотри все счет фактуры (если надо скинь в Excel и там суммируй)
     
  3. milok183

    milok183 Гость

    У МЕНЯ ДЕЙСТВИТЕЛЬНО СУММА ДОЛЖНА БЫТЬ БОЛЬШЕ 1 МЛРД ПРОСТО ОНА НЕ ОТРАЖАЕТСЯ КОРРЕКТНО ВОТ В ЧЕМ ПРОБЛЕМА !!!
    СЧЕТА ПРОСМОТРЕЛ ОБОРОТ ЗА 1,3 ГДЕ ТО ДОЛЖЕН БЫТЬ
     
  4. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    Энто тебе надо посмотреть в отчете КнигаПродаж по строке Формат - у тебя сумма округляются до 15-ти знаков. попробуй увеличить до 20.

    типа Таб.ИспользоватьФормат("Ч-20.2-");
     
  5. milok183

    milok183 Гость

    у меня сделана внешняя обработка все там выставил вот кусочек ТаблицаЗаписейДока=СоздатьОбъект("ТаблицаЗначений");
    ТаблицаЗаписейДока.НоваяКолонка("Приоритет","Число","1","0");
    ТаблицаЗаписейДока.НоваяКолонка("ДопНадпись","Строка","25");// Аванс, Част. оплата и т.п.
    ТаблицаЗаписейДока.НоваяКолонка("Комментарий","Строка","50");
    ТаблицаЗаписейДока.НоваяКолонка("СчетФактура","Документ");
    ТаблицаЗаписейДока.НоваяКолонка("ДокОплаты","Документ");
    ТаблицаЗаписейДока.НоваяКолонка("ДокОтгрузки","Документ");

    ТаблицаЗаписейДока.НоваяКолонка("СуммаВсего","Число","20","2");
    ТаблицаЗаписейДока.НоваяКолонка("СуммаБезНДС20","Число","20","2");
    ТаблицаЗаписейДока.НоваяКолонка("НДС20","Число","20","2");
    ТаблицаЗаписейДока.НоваяКолонка("СуммаБезНДС18","Число","20","2");
    ТаблицаЗаписейДока.НоваяКолонка("НДС18","Число","20","2");
    ТаблицаЗаписейДока.НоваяКолонка("СуммаБезНДС10","Число","20","2");
    ТаблицаЗаписейДока.НоваяКолонка("НДС10","Число","20","2");
    ТаблицаЗаписейДока.НоваяКолонка("НДС0","Число","20","2");
    ТаблицаЗаписейДока.НоваяКолонка("СуммаСовсемБезНДС","Число","20","2");
    ТаблицаЗаписейДока.НоваяКолонка("СуммаНП","Число","20","2");
    ТаблицаЗаписейДока.НоваяКолонка("ТипЗаписи","Число","2","0");
    .... не помогает :)
     
  6. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    А Формат вообще нет? такая ситуация обычно бывает что у тебя десятисимвольное значение, а округляет или форматирует до меньшего количества символов. Ну он и забивает всё девятками. Так что ищи Формат и Окр. Ну и в таблице, да. и в печатной глянь - мож там #Ч10.2
     
  7. milok183

    milok183 Гость

    формат и окр не нашел может кто кинет в меня книгой продаж-хоть сравню может где накосячил предшественник-не я писал обработку -заранее благодарен -milok1997@mail.ru -буду искать причину
     
  8. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    Лучше выгрузи и пошли на мыло puh14@mail.ru постараюсь помочь. Кинул свою из бухгалтерии.
     
  9. milok183

    milok183 Гость

    обработка ушла -лови :)
     
  10. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    Попробуй при создании книги продаж перед выводом таблицы написать Сообщить(ИтогВсего); что он скажет. а то у меня чувство ГлФРМ из глобалки тебе обрезает символы. у меня - то она не используется, сумма напрямую идет.

    Функция глФРМ(ЧислЗнач, Валюта="", ВыводНулевого="0", РаздТриад="'") Экспорт
    Перем РезСтрока, ФрмСтрока;

    РезСтрока = СокрЛ(Формат(ЧислЗнач, "Ч" + ВыводНулевого + "15.2." + РаздТриад));

    Если (ПустоеЗначение(РезСтрока) = 0) И (ПустоеЗначение(Валюта) = 0) Тогда
    РезСтрока = РезСтрока + " " + СокрП(Валюта.Наименование);
    КонецЕсли;

    Возврат РезСтрока;

    КонецФункции // глФРМ()

    На складе нашел. Собственно интересно это

    РезСтрока = СокрЛ(Формат(ЧислЗнач, "Ч" + ВыводНулевого + "15.2." + РаздТриад));


    Надо

    РезСтрока = СокрЛ(Формат(ЧислЗнач, "Ч" + ВыводНулевого + "20.2." + РаздТриад));
     
  11. milok183

    milok183 Гость

    Спасибо-помогло :) вроде нормально стало отражаться-еще все проверю ...:)
     
  12. milok183

    milok183 Гость

    вдогонку-сегодня еще нашел в глобальном модуле-поменял 15 на 22 и "страя" книга продаж стала корректно отражаться :)
    Функция глФРМ(ЧислЗнач,Вал,Реж) Экспорт
    // Это процедура нашего стандартного форматирования цен и сумм:
    // Для рублей не печатаем дроби, для других валют 3 знака после запятой
    // Триады отделяем символом (')
    Стр=?(Вал=Константа.СтараяБазоваяВалюта,СокрЛ(Формат(ЧислЗнач,"Ч022.0.'")),СокрЛ(Формат(ЧислЗнач,"Ч022.2.'")));
    Если (Реж=0) ИЛИ (ПустаяСтрока(Стр)=1) Тогда
    Возврат Стр;
    Иначе
    Возврат Стр+" "+СокрП(Вал.Наименование);
    КонецЕсли;
    КонецФункции

    //******************************************************************************
    Функция глФРМТ(ЧислЗнач,Вал,Реж) Экспорт
    // Это процедура нашего стандартного форматирования цен и сумм:
    // Для рублей не печатаем дроби, для других валют 3 знака после запятой
    // Без разделения на Триады
    Стр=?(Вал=Константа.СтараяБазоваяВалюта,СокрЛ(Формат(ЧислЗнач,"Ч022.0")),СокрЛ(Формат(ЧислЗнач,"Ч022.2")));
    Если (Реж=0) ИЛИ (ПустаяСтрока(Стр)=1) Тогда
    Возврат Стр;
    Иначе
    Возврат Стр+" "+СокрП(Вал.Наименование);
    КонецЕсли;
    КонецФункции
     
Загрузка...

Поделиться этой страницей