Количество строк с нулевым значением

Тема в разделе "1C и всё что с ней связано", создана пользователем Doubleagent, 30 апр 2010.

  1. Doubleagent

    Doubleagent Гость

    Здравствуйте Уважаемые!
    Вопрос такого плана, в ТЧ1 есть две колонки (а,б – значение число). В колонку «б» забиваем (не все строки) оценки и делим на количество заполненных. Подскажите пожалуйста как получить сумму не заполненных(1) строк в колонке «б» .
    КолП = Табличнаячасть1.Количество();
    срд = Табличнаячасть1.Итог("Экзамены");
    Дис3С = срд /(КолП - сумманезаполненых(1)) ;
     
  2. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Код ( (Unknown Language)):
    Функиця КолНезаполненных(Табличнаячасть)
    Перем Кол;
    Кол = 0;
    Для каждого СтрокаТаблицы Из Табличнаячасть Цикл
    Если НЕ(СтрокаТаблицы.Б = 0) Тогда
    Кол = Кол + 1;
    КонецЕсли;
    КонецЦикла;
    Возврат Кол;
    КонецФункции;
     
  3. Darlock

    Darlock Well-Known Member
    1C Team

    Регистрация:
    4 янв 2008
    Сообщения:
    558
    Симпатии:
    0
    Как вариант можно в цикле обойти всю таблицу. Можно попробовать следующий вариант:

    Код ( (Unknown Language)):
    ПараметрыОтбора = Новый Структура;
    ПараметрыОтбора.Вставить("Номенклатура", ТекТовар);
    НайденныеСтроки = Состав.НайтиСтроки(ПараметрыОтбора);
     
  4. Doubleagent

    Doubleagent Гость

    Большое Спасибо. Все работает=)
     
  5. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Я вот думаю, а чем запрос не прокатывает?
    что-то типа такого
    select count() from ТабличнаяЧасть where Количество = 0
     
  6. Darlock

    Darlock Well-Known Member
    1C Team

    Регистрация:
    4 янв 2008
    Сообщения:
    558
    Симпатии:
    0
    Можно и запросом, все уперается в здравый смысл. Только запрос в том виде в котором предложили не сработает в 1С.
     
  7. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Darlock, а я разве сказал, что это готовый кусок кода? Я вообще противник предоставления готовых примеров при обучении - исключительно указание направления поисков. А четкие выверенные примеры должны находиться в документации. Но это все - всего лишь мое ИМХО, правда, основанное на определенном опыте.
     
  8. Buster

    Buster Гость

    Чтоб не городить код обхода цикла было бы проще мне кажется след. образом
    Код ( (Unknown Language)):
    КоличествоНеЗаполненных = ТабличнаяЧасть.НайтиСтроки(Новый Структура("Количество", 0)).Количество();
    И отсюда можно очень легко узнать что нам надо
     
Загрузка...

Поделиться этой страницей