Копирование документа

  • Автор темы Galina
  • Дата начала
G

Galina

Гость
#1
Можно ли запретить копировать выбранный в журнале документ ?
Если да, то можно ли это сделать для документов, имеющих конктретное значение реквизита?
 

Zab

Well-Known Member
07.08.2006
583
0
Менск
#2
Для 7.7. в синтакс помошнике читаем:
Код:
Процедура ВводНового(<?>,)
КонецПроцедуры
Синтаксис:
ВводНового(<ПризнКопирования>,<ОбъектКопирования>)
Назначение:
Предопределенная процедура при интерактивном вводе нового документа.
Параметры:
<ПризнКопирования> - признак того, что объект введен копированием
достаточно?
 
J

jj_mail

Гость
#3
В процедуре "ВводНового()" Есть признак копирования документа. Им и нужно воспользоваться
 
G

Galina

Гость
#4
Для 7.7. в синтакс помошнике читаем:
Код:
Процедура ВводНового(<?>,)
КонецПроцедуры
Синтаксис:
ВводНового(<ПризнКопирования>,<ОбъектКопирования>)
Назначение:
Предопределенная процедура при интерактивном вводе нового документа.
Параметры:
<ПризнКопирования> - признак того, что объект введен копированием
достаточно?
Я пыталась воспользоваться данной процедурой, но добилась только обнуления полей нового документа, а если документ содержит много полей и вкладок?
Мне же нужно, чтобы пользователь вообще не мог открыть нового документа, если он нажимает на кнопку "копировать строку".
Если с помощью этой процедуры можно так сделать, то подскажите, пожалуйста, как?
 

puh14

Well-Known Member
11.07.2008
1 412
0
НеРезиновая
#5
Процедура ВводНового(Признак,Объект)
Если (ПустоеЗначение(Признак)= 0) или (ПустоеЗначение(Объект)= 0) Тогда
Предупреждение("ВВод документа копированием запрещен!");
СтатусВозврата(0);
Возврат;
КонецЕсли;
КонецПроцедуры
 
L

LSH

Гость
#6
Код:
Процедура ВводНового(Копир)
Если Копир = 1 Тогда
СтатусВозврата(0);
Возврат;
КонецЕсли;
КонецПроцедуры
puh14
Вай, зачэм усложняешь, да? :blink:
 
G

Galina

Гость
#9
Всем спасибо.

Про СтатусВозврата я почему-то в документации не нашла.
 

puh14

Well-Known Member
11.07.2008
1 412
0
НеРезиновая
#10
СтатусВозврата(<?>)
Синтаксис:
СтатусВозврата(<Статус>)
Назначение:
Определение или установка статуса возврата предопределенной процедуры.
Возвращает:
1, если статус возврата - Выполнить Действие;
0, если статус возврата - Отменить Действие.
Параметры:
<Статус> - необязательный параметр:
если опущен, то установка статуса возврата предопределенной процедуры не меняется;
если задано 1, то устанавливается статус возврата - Выполнить Действие;
если задано 0, то устанавливается статус возврата - Отменить Действие.
Замечание:
Функция/процедура СтатусВозврата применяется в теле предопределенных процедур.
Начальное значение статуса возврата предопределенной процедуры равно 1 - Выполнить Действие, устанавливается системой при вызове предопределенной процедуры.