1. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление

Копирование документа

Тема в разделе "Базы данных и администрирование", создана пользователем Galina, 13 авг 2008.

  1. Galina

    Galina Гость

    Репутация:
    0
    Можно ли запретить копировать выбранный в журнале документ ?
    Если да, то можно ли это сделать для документов, имеющих конктретное значение реквизита?
     
  2. Zab

    Zab Well-Known Member

    Репутация:
    0
    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    Для 7.7. в синтакс помошнике читаем:
    Код:
    Процедура ВводНового(<?>,)
    КонецПроцедуры
    Синтаксис:
    ВводНового(<ПризнКопирования>,<ОбъектКопирования>)
    Назначение:
    Предопределенная процедура при интерактивном вводе нового документа.
    Параметры:
    <ПризнКопирования> - признак того, что объект введен копированием
    достаточно?
     
  3. jj_mail

    jj_mail Гость

    Репутация:
    0
    В процедуре "ВводНового()" Есть признак копирования документа. Им и нужно воспользоваться
     
  4. Galina

    Galina Гость

    Репутация:
    0
    Я пыталась воспользоваться данной процедурой, но добилась только обнуления полей нового документа, а если документ содержит много полей и вкладок?
    Мне же нужно, чтобы пользователь вообще не мог открыть нового документа, если он нажимает на кнопку "копировать строку".
    Если с помощью этой процедуры можно так сделать, то подскажите, пожалуйста, как?
     
  5. puh14

    puh14 Well-Known Member

    Репутация:
    0
    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    Процедура ВводНового(Признак,Объект)
    Если (ПустоеЗначение(Признак)= 0) или (ПустоеЗначение(Объект)= 0) Тогда
    Предупреждение("ВВод документа копированием запрещен!");
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    КонецПроцедуры
     
  6. LSH

    LSH Гость

    Репутация:
    0
    Код:
    Процедура ВводНового(Копир)
    Если Копир = 1 Тогда
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    КонецПроцедуры
    puh14
    Вай, зачэм усложняешь, да? :blink:
     
  7. puh14

    puh14 Well-Known Member

    Репутация:
    0
    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    А я не знаю как этот признак выглядит. :blink:
     
  8. LSH

    LSH Гость

    Репутация:
    0
    Зато Ctrl+F1 знает :blink:
    1/0
     
  9. Galina

    Galina Гость

    Репутация:
    0
    Всем спасибо.

    Про СтатусВозврата я почему-то в документации не нашла.
     
  10. puh14

    puh14 Well-Known Member

    Репутация:
    0
    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    СтатусВозврата(<?>)
    Синтаксис:
    СтатусВозврата(<Статус>)
    Назначение:
    Определение или установка статуса возврата предопределенной процедуры.
    Возвращает:
    1, если статус возврата - Выполнить Действие;
    0, если статус возврата - Отменить Действие.
    Параметры:
    <Статус> - необязательный параметр:
    если опущен, то установка статуса возврата предопределенной процедуры не меняется;
    если задано 1, то устанавливается статус возврата - Выполнить Действие;
    если задано 0, то устанавливается статус возврата - Отменить Действие.
    Замечание:
    Функция/процедура СтатусВозврата применяется в теле предопределенных процедур.
    Начальное значение статуса возврата предопределенной процедуры равно 1 - Выполнить Действие, устанавливается системой при вызове предопределенной процедуры.
     
Загрузка...

Поделиться этой страницей