Кривые Url ссылки в браузере

Тема в разделе "Lotus - Администрирование", создана пользователем puks, 29 май 2007.

  1. puks

    puks Lotus team
    Lotus team

    Регистрация:
    3 фев 2007
    Сообщения:
    1.967
    Симпатии:
    16
    Сервер 7.0.2 FP2 Eng, Win2K SP4. Браузеры разные.

    Обнаружил интересную проблему. Точнее, видел ее и раньше, только не сопоставлял работу разных клиентов.

    Короче, приходит по почте документ с url ссылками (http, mailto и тп). В Лотусовом клиенте все тип-том: в свойствах hotspot все нормально и, соответственно, страница тоже открывается без проблем. Но вот тот же самый документ в браузере через WebMail на этих ссылках выдает херню: в конце строки добавляет пару символов (разных, но чаще всего первым стоит %22). Соответственно, страница не открывается.

    Самое удивительное, что это не на всех ссылках происходит (даже в пределах одного документа).
    Проверял на разных компах в разных сетях и конторах (вирусы и подобное - отсекаются), что наводит на мысль о серверной проблеме в вэб части: либо http сервер, либо дизайн базы. Второе, конечно, можно быстро проверить. С первым немного сложнее, так как на сервере еще стоят ST 7.5 и Mobile Access.

    Просто интересно, сталкивался ли кто-нибудь с подобным?
     
  2. Domino6

    Domino6 Гость

  3. puks

    puks Lotus team
    Lotus team

    Регистрация:
    3 фев 2007
    Сообщения:
    1.967
    Симпатии:
    16
    Не совсем понял к чему это? И причем тут кодирование процента, если его вообще нет в оригинальном URL.

    Если ссылки в документе http://www.abc.com/blablabla.html или mailto:user@hotmail.com , и они нормально открываются из лотусового клиента, то почему сервер, формируя страницу с этими ссылками, добавляет им что-то в конце? Причем это не со всеми ссылками происходит. Но закономерность я отследить не могу.
     
  4. Domino6

    Domino6 Гость

    <!--QuoteBegin-puks+16:06:2007, 17:37 -->
    <span class="vbquote">(puks @ 16:06:2007, 17:37 )</span><!--QuoteEBegin-->Но закономерность я отследить не могу.
    [snapback]69606" rel="nofollow" target="_blank[/snapback]​
    [/quote]

    закономерность одна в урл символы, которые не соответствуют спецификации
    - пробелы
    - кавычки
    - слеши
    - русские
     
  5. puks

    puks Lotus team
    Lotus team

    Регистрация:
    3 фев 2007
    Сообщения:
    1.967
    Симпатии:
    16
    Для: Domino6

    Я, конечно, тебе благодарен, что ты отвечаешь на мой вопрос. Но такое впечатление, что ты не совсем внимательно читаешь, что пишу.

    Ссылки абсолютно нормальные и простые. Ничего из того, что ты там написал, - нет. Открываются без проблем из лотусового клиента или при копировании их в браузер из свойство линка.
     
  6. Domino6

    Domino6 Гость

    <!--QuoteBegin-puks+29:05:2007, 18:31 -->
    <span class="vbquote">(puks @ 29:05:2007, 18:31 )</span><!--QuoteEBegin-->Но вот тот же самый документ в браузере через WebMail на этих ссылках выдает херню: в конце строки добавляет пару символов (разных, но чаще всего первым стоит %22
    [snapback]67517" rel="nofollow" target="_blank[/snapback]​
    [/quote]

    я тебе и пишу про кодировки
    - письма могут иметь MIME формат
    - для веба идет трансляция в соответсвтии с настройками сервера

    Нотес все данный хранит в LMBCS

    проверка
    - открой в вебе и посмотри исходный html код, смотри на
    заголовок там указана кодировка страницы
    что содержит href в ссылке
     
Загрузка...
Похожие Темы - Кривые Url ссылки
  1. vladius
    Ответов:
    0
    Просмотров:
    1.431
  2. Triton
    Ответов:
    0
    Просмотров:
    221
  3. deeeman
    Ответов:
    9
    Просмотров:
    361
  4. puks
    Ответов:
    5
    Просмотров:
    546
  5. proteam
    Ответов:
    7
    Просмотров:
    792

Поделиться этой страницей