1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

Начисление зарплаты

Тема в разделе "Базы данных и администрирование", создана пользователем Temych, 15 июл 2009.

  1. Temych

    Temych Гость

    Репутация:
    0
    У меня такая задача разработать конфигурацию по начислению зарплаты по часовой оплате, по тарифу. Основанием для начисления зарплаты у меня является Карточка учёта отработанного времени преподавателя. В той карточке у меня есть столбики Часы и Тариф, часы должны насчитываться каждый день конкретному преподавателю и в конце месяца должен выводиться итог отработаннго времени за месяц, и все эти отработанные часы должны переводиться в расчётную ведомость в которой будут проводиться дальнейшие рассчёты и отчисления по налогам. Все справочники и документы которые нужны для работы по зарплате у меня сделаны.

    И у меня вопрос по реализации даной конфигурации точнее структуры которую я описал выше, незнаю как сделать чтобы выводился общий итог отработанных часов за месяц, и как провести те отработанные часы в документ рассчётной ведомости и как осуществляются рассчёты ,каким образом мне это реализовать за период - месяц и как провести потом в платёжную ведомость, в техническом плане незнаю как написать и куда вставить нужные процедуры обработки этих операций.
    Помогите, нуждаюсь в вашей помощи, я в этом новичок, и это моя дипломная работа.
     

    Вложения:

    • Начисление зарплаты
      10.jpg
      Размер файла:
      142,2 КБ
      Просмотров:
      21
    • Начисление зарплаты
      9.jpg
      Размер файла:
      153,5 КБ
      Просмотров:
      18
    • Начисление зарплаты
      12.jpg
      Размер файла:
      115,4 КБ
      Просмотров:
      16
  2. Hryv

    Hryv Гость

    Репутация:
    0
    Вам за это заплатят или оценку поставят?

    В любом случае - читайте литературу
     
  3. Temych

    Temych Гость

    Репутация:
    0
    в литературе я ненашёл то что меня интересует.
    Да оценку поставят.
     
  4. KiR

    KiR НЕ шибка опытный програмер)

    Репутация:
    0
    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    ты знаешь что дипломная работа стоит одного из двух:
    1. усилий и времени чтобы выучить и потом быть специалистом, а не просто дипломированным лаптем
    2. денег
     
  5. Temych

    Temych Гость

    Репутация:
    0
    То что в моих силах и то в чём я разобрался я сделал, и если можешь помочь помоги а если нет то зачем эти ненужные обсуждения.
     
  6. Hryv

    Hryv Гость

    Репутация:
    0
    "Карточка учёта отработанного времени преподавателя" - это документ? (как я понял - это документ)
    Тогда сумму по колонке можно узнать с помощью
    А полученный результат можно отобразить в текстовом поле на форме
    Ну и так далее...

    Вообще, такая халявная дипломная тянет отсилы на курсач
    Человек, который знает об 1С хоть что-то, с книжкой сделает его за 2-3 дня
    А опытный программист за 2-3 часа

    А это вообще смешно: если это все что в ваших силах, то маловато значит сил, чтобы диплом получить

    Вы хотите чтобы вам помогли, но как вы это представляете. Вас преподы не научили, а здесь на форуме значит научат, да?
    Лично мне проще это задание взять и сделать, чем объяснять фактически с нуля как программировать для 1С 7.7
     
  7. Temych

    Temych Гость

    Репутация:
    0
    спасиба буду разбираться
     
  8. Hryv

    Hryv Гость

    Репутация:
    0
    незачто

    а если походу возникнут конкретные вопросы, тогда задавай

    Например: написал "такой-то" код, чтобы получить "вот это", но "вот это" не получается. Что в моем коде неверно?

    Тогда тебе помогут
     
  9. Temych

    Temych Гость

    Репутация:
    0
    На этой платформе мы даже не работали не то что программировали

    Мне нужно чтобы итог выводился за указанный мною период, за месяц по столбику Часы
    Итог(Часы)
     
  10. Hryv

    Hryv Гость

    Репутация:
    0
    Если в пределах одного документа

    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    //В цикле проверять подходит ли строка под период и суммировать Часы в переменную
    КонецЦикла;

    Если из нескольких документов то
    Док=СоздатьОбъект("Документ.НужныйДокумент");
    Док.ВыбратьДокументы();
    Пока Док.ПолучитьДокумент()=1 Цикл
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку()=1 Цикл
    //В цикле проверять подходит ли строка под период и суммировать Док.Часы в переменную
    КонецЦикла;
    КонецЦикла;
     
  11. Temych

    Temych Гость

    Репутация:
    0
    Если я скину тебе конфигурацию с елементами и формами что у меня есть, ты сможешь её доработать и сколько это будет по времени и стоить?
     
Загрузка...

Поделиться этой страницей