НайтиСсылки()

  • Автор темы Larin
  • Дата начала
Статус
Закрыто для дальнейших ответов.
L

Larin

Гость
#1
нужно перебирать элементы в справочнике Товары, если нет ссылки, то удалять. Я делал так, но удаляет не все элементы, а некоторую часть. И теперь ваще не находит элементов без ссылок

Код:
Процедура УдалениеЭлементовСправочника()
   МояТаблица=СоздатьОбъект("ТаблицаЗначений");
   МойСписок=СоздатьОбъект("СписокЗначений");
    Спр=СоздатьОбъект("Справочник.Товары");
Спр.ВыбратьЭлементы();
      
Пока Спр.ПолучитьЭлемент()>1 Цикл
      
      МойСписок=Спр.ТекущийЭлемент;
       
   НайтиСсылки(МойСписок,МояТаблица);
   УдалитьОбъекты(МойСписок, 1, МояТаблица);
   

КонецЦикла;

КонецПроцедуры
 
P

Pro

Гость
#2
<!--QuoteBegin-Larin+5:08:2005, 23:09 -->
<span class="vbquote">(Larin @ 5:08:2005, 23:09 )</span><!--QuoteEBegin-->нужно перебирать элементы в справочнике Товары, если нет ссылки, то удалять. Я делал так, но удаляет не все элементы, а некоторую часть. И теперь ваще не находит элементов без ссылок

Код:
Процедура УдалениеЭлементовСправочника()
       МояТаблица=СоздатьОбъект("ТаблицаЗначений");
       МойСписок=СоздатьОбъект("СписокЗначений");
        Спр=СоздатьОбъект("Справочник.Товары");
Спр.ВыбратьЭлементы();
            
Пока Спр.ПолучитьЭлемент()>1 Цикл
            
             МойСписок=Спр.ТекущийЭлемент;
              
       НайтиСсылки(МойСписок,МояТаблица);
       УдалитьОбъекты(МойСписок, 1, МояТаблица);
      

КонецЦикла;

 КонецПроцедуры
[snapback]23040" rel="nofollow" target="_blank[/snapback]​
[/quote]

Правельней наверно будет так, но я не проверял...
Код:
Процедура УдалениеЭлементовСправочника()
   МояТаблица=СоздатьОбъект("ТаблицаЗначений");
   МойСписок="";
   Спр=СоздатьОбъект("Справочник.Товары");
   Спр.ВыбратьЭлементы();
   Пока Спр.ПолучитьЭлемент()=1 Цикл
      МойСписок=Спр.ТекущийЭлемент;
      НайтиСсылки(МойСписок,МояТаблица);
      Если МояТаблица.КоличествоСтрок()>0 Тогда
         Спр.ТекущийЭлемент().Удалить(1);
      КонецЕсли;
   КонецЦикла;
КонецПроцедуры
 
L

Larin

Гость
#3
да нет так не работает. но я уже сам сделал :)
 
Статус
Закрыто для дальнейших ответов.