1. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление

НайтиСсылки()

Тема в разделе "Базы данных и администрирование", создана пользователем Larin, 6 авг 2005.

Статус темы:
Закрыта.
  1. Larin

    Larin Гость

    Репутация:
    0
    нужно перебирать элементы в справочнике Товары, если нет ссылки, то удалять. Я делал так, но удаляет не все элементы, а некоторую часть. И теперь ваще не находит элементов без ссылок

    Код:
    Процедура УдалениеЭлементовСправочника()
       МояТаблица=СоздатьОбъект("ТаблицаЗначений");
       МойСписок=СоздатьОбъект("СписокЗначений");
        Спр=СоздатьОбъект("Справочник.Товары");
    Спр.ВыбратьЭлементы();
          
    Пока Спр.ПолучитьЭлемент()>1 Цикл
          
          МойСписок=Спр.ТекущийЭлемент;
           
       НайтиСсылки(МойСписок,МояТаблица);
       УдалитьОбъекты(МойСписок, 1, МояТаблица);
       
    
    КонецЦикла;
    
    КонецПроцедуры
     
  2. Pro

    Pro Гость

    Репутация:
    0
    <!--QuoteBegin-Larin+5:08:2005, 23:09 -->
    <span class="vbquote">(Larin @ 5:08:2005, 23:09 )</span><!--QuoteEBegin-->нужно перебирать элементы в справочнике Товары, если нет ссылки, то удалять. Я делал так, но удаляет не все элементы, а некоторую часть. И теперь ваще не находит элементов без ссылок

    Код:
    Процедура УдалениеЭлементовСправочника()
           МояТаблица=СоздатьОбъект("ТаблицаЗначений");
           МойСписок=СоздатьОбъект("СписокЗначений");
            Спр=СоздатьОбъект("Справочник.Товары");
    Спр.ВыбратьЭлементы();
                
    Пока Спр.ПолучитьЭлемент()>1 Цикл
                
                 МойСписок=Спр.ТекущийЭлемент;
                  
           НайтиСсылки(МойСписок,МояТаблица);
           УдалитьОбъекты(МойСписок, 1, МояТаблица);
          
    
    КонецЦикла;
    
     КонецПроцедуры
    [snapback]23040" rel="nofollow" target="_blank[/snapback]​
    [/quote]

    Правельней наверно будет так, но я не проверял...
    Код:
    Процедура УдалениеЭлементовСправочника()
       МояТаблица=СоздатьОбъект("ТаблицаЗначений");
       МойСписок="";
       Спр=СоздатьОбъект("Справочник.Товары");
       Спр.ВыбратьЭлементы();
       Пока Спр.ПолучитьЭлемент()=1 Цикл
          МойСписок=Спр.ТекущийЭлемент;
          НайтиСсылки(МойСписок,МояТаблица);
          Если МояТаблица.КоличествоСтрок()>0 Тогда
             Спр.ТекущийЭлемент().Удалить(1);
          КонецЕсли;
       КонецЦикла;
    КонецПроцедуры
     
  3. Larin

    Larin Гость

    Репутация:
    0
    да нет так не работает. но я уже сам сделал :)
     
Статус темы:
Закрыта.

Поделиться этой страницей