Настройка Apache

Тема в разделе "PHP программирование", создана пользователем sasha465, 31 мар 2011.

  1. sasha465

    sasha465 Well-Known Member

    Регистрация:
    29 мар 2009
    Сообщения:
    69
    Симпатии:
    0
    Люди добрые, подскажите как мне настроить сервер Апачи нормально, долго уже парюсь, ничего не получается. Устанавливал LAMP многими способами, но ничего не получилось, вот последний:
    sudo apt-get install mysql-server
    sudo apt-get install mysql-admin
    sudo apt-get install apache2
    sudo /etc/init.d/apache2 restart
    Вообщем ставлю все это и пытаюсь проверить работу апачи: захожу на http://localhost/ а меня спрашивают с помощью какой программы открыть файл, являющийся PHTML файлом, вообщем спрашивают как firefox обработать этот файл. Отсюда вопрос как нормально настроить апачи??? Только прошу подробно, интернет весь перерыл уже ничего не помогло.
     
  2. typak

    typak Гость

    [А ты шо LAMP устанавливаеш ? Если да то незнаю как?
    Если поотдельности неможеш настроить то лутше денвер скачай, там все уже настроено установил с настройками по умолчанию, и мож сразу запусткать все работает (в своё время 2 дня провазился пака к апачу пхп пристроил)

    А лутше 2 сервера установи а то и 3. У меня отдельно апачь и пхп с мускулом стоит и денвер еще
    чота када на свой сервер шо сам настраивал смски некоторые скидываеш нихотят работать, а када на денвере так всё норм работает
    крыво настроилось както БД.
    Денвер ничем не хуже чем поотдельности настраивать, а даже лутше всё включено и настроено апачь, пхп, мускл, муадмин да еще и письма отправляет можна тестировать, а так всё это качать надо та еще и настраивать.
    Я за денвер головняка никакого
     
  3. Kauperwood

    Kauperwood Гость

  4. sasha465

    sasha465 Well-Known Member

    Регистрация:
    29 мар 2009
    Сообщения:
    69
    Симпатии:
    0
    Так я так понял денвер это под винду, а я под линухой пытаюсь все поставить. Ну вот щас скачал по идее готовый LAMP, с помощью команды sudo tasksel install lamp-server, все вроде поставилось, сервер апачи запускается, но страницу localhost как не мог открыть так и не могу. Такое чувство что я что-то в конфигах попортил...
     
  5. sasha465

    sasha465 Well-Known Member

    Регистрация:
    29 мар 2009
    Сообщения:
    69
    Симпатии:
    0
    Удивительно, но у меня все заработало, причем после того как я перед переустановкой все подчистил и удалил /var/www.
     
Загрузка...

Поделиться этой страницей