Настройка Cgi

sasha465

Well-known member
29.03.2009
69
0
#1
Опять я разбираюсь с Апачи) Теперь мне не удается запустить cgi скрипт, написанный и скомпилированный на Си. Перечитал кучу советов, все попробовал сделать, но вместо того чтобы запуститься браузер выдает сообщение что мол надо сохранить бинарный файл, но сценарий не выполняет. Вот например конфигурационный файл site-available/defaul:
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www
<Directory />
Options All
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /var/www/cgi-bin/ "/usr/lib/cgi-bin/"
<Directory "/usr/lib/cgi-bin">
AllowOverride All
SetHandler cgi-script
AddHandler cgi-script .cgi
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>

Чего не хватает не пойму...
 

sasha465

Well-known member
29.03.2009
69
0
#2
Извиняюсь что спамлю тут вам, но уже нашел решение проблемы, если у кого будут вопросы, пишите сюда или мне на мыло sasha465@yandex.ru