НазначитьТип() во внешнем отчете

Тема в разделе "1C и всё что с ней связано", создана пользователем Azrael, 2 ноя 2007.

  1. Azrael

    Azrael Гость

    Делаю самостоятельную работу к лабораторной, из задания:
    с выбором вида субконто справился (на вкладке "дополнительно" в поле "Связан с" указал счет). Дальше вставляю поле "субконто" неопределенного типа, в поле выбора субконто указываю формулу, в которой прописываю
    Код (Text):
    НазначитьТип("Субконто", ВыбВидСубконто);
    В ответ оно недобро ругается, что
    Как здесь быть?
     
  2. Zab

    Zab Well-Known Member
    1C Team

    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    Чуть порезанный код, для простоты понимания, из отчета АнализсчетаПоСубконто:
    Код (Text):
    Процедура ПриВыбореСчета()
    Если Счет.КоличествоСубконто() > 0 Тогда
    НазначитьСчет(ВыбВидСубконто1, Счет, 1);
    Форма.Субконто1.НазначитьТип(ВыбВидСубконто1);
    Доступность = 1;
    Иначе
    ВыбВидСубконто1 = "";
    Субконто1 = "";
    Доступность = 0;
    КонецЕсли;
    Форма.Субконто1.Доступность(Доступность);
    Если Счет.КоличествоСубконто() > 1 Тогда
    НазначитьСчет(ВыбВидСубконто2, Счет, 2);
    Форма.Субконто2.НазначитьТип(ВыбВидСубконто2);
    Доступность = 1;
    Иначе
    ВыбВидСубконто2 = "";
    Субконто2 = "";
    Доступность = 0;
    КонецЕсли;
    Форма.Субконто2.Доступность(Доступность);
    Форма.ВыбВидСубконто2.Доступность(Доступность);
    Если Счет.КоличествоСубконто() > 2 Тогда
    НазначитьСчет(ВыбВидСубконто3, Счет, 3);
    Форма.Субконто3.НазначитьТип(ВыбВидСубконто3);
    Доступность = 1;
    Иначе
    ВыбВидСубконто3 = "";
    Субконто3 = "";
    ОтборСубконто3.ТекущаяСтрока(3);
    Доступность = 0;
    КонецЕсли;
    Форма.Субконто3.Доступность(Доступность);
    Форма.ВыбВидСубконто3.Доступность(Доступность);
    КонецПроцедуры
    И цитата из синтакс-помошника, удачи.
     
  3. Azrael

    Azrael Гость

    Спасибо, плюс сча нажму :blink: Ещё вопросик вдогонку: как сделать, чтобы при выборе счета пользователь видел в списке счетов только те, корреспонденции с которыми по д*цензура*у счета кассы считаются корректными.

    Видел в синтакс-помошнике объект "Корректная проводка", но где их создавать не понял :(
     
  4. Zab

    Zab Well-Known Member
    1C Team

    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    Бушь смеяться, но более чем за 7 лет активной работы с 7.7. ни разу не столкнулся с этим объектом в работе.
    Я так понял, что вопрос в том, где найти список корректных проводок? Тогда: Режим "Предприятие" - Меню Операции->Корректные проводки.
     
Загрузка...
Похожие Темы - НазначитьТип() во внешнем
  1. cyber23
    Ответов:
    2
    Просмотров:
    27
  2. XackerBlack
    Ответов:
    2
    Просмотров:
    81
  3. ~~DarkNode~~
    Ответов:
    7
    Просмотров:
    724
  4. artem4486
    Ответов:
    1
    Просмотров:
    43
  5. Escaper
    Ответов:
    2
    Просмотров:
    24

Поделиться этой страницей