НазначитьТип() во внешнем отчете

  • Автор темы Azrael
  • Дата начала
A

Azrael

Гость
#1
Делаю самостоятельную работу к лабораторной, из задания:
....
Пользователь может выбрать:
....
□ Счет
□ Вид субконто1 (из тех, которые прикреплены к выбранному счету) и Субконто1
....
с выбором вида субконто справился (на вкладке "дополнительно" в поле "Связан с" указал счет). Дальше вставляю поле "субконто" неопределенного типа, в поле выбора субконто указываю формулу, в которой прописываю
Код:
НазначитьТип("Субконто", ВыбВидСубконто);
В ответ оно недобро ругается, что
Процедура не обнаружена (НазначитьТип)
Как здесь быть?
 

Zab

Well-Known Member
07.08.2006
583
0
Менск
#2
Чуть порезанный код, для простоты понимания, из отчета АнализсчетаПоСубконто:
Код:
Процедура ПриВыбореСчета()
Если Счет.КоличествоСубконто() > 0 Тогда
НазначитьСчет(ВыбВидСубконто1, Счет, 1);
Форма.Субконто1.НазначитьТип(ВыбВидСубконто1);
Доступность = 1;
Иначе
ВыбВидСубконто1 = "";
Субконто1 = "";
Доступность = 0;
КонецЕсли;
Форма.Субконто1.Доступность(Доступность);
Если Счет.КоличествоСубконто() > 1 Тогда
НазначитьСчет(ВыбВидСубконто2, Счет, 2);
Форма.Субконто2.НазначитьТип(ВыбВидСубконто2);
Доступность = 1;
Иначе
ВыбВидСубконто2 = "";
Субконто2 = "";
Доступность = 0;
КонецЕсли;
Форма.Субконто2.Доступность(Доступность);
Форма.ВыбВидСубконто2.Доступность(Доступность);
Если Счет.КоличествоСубконто() > 2 Тогда
НазначитьСчет(ВыбВидСубконто3, Счет, 3);
Форма.Субконто3.НазначитьТип(ВыбВидСубконто3);
Доступность = 1;
Иначе
ВыбВидСубконто3 = "";
Субконто3 = "";
ОтборСубконто3.ТекущаяСтрока(3);
Доступность = 0;
КонецЕсли;
Форма.Субконто3.Доступность(Доступность);
Форма.ВыбВидСубконто3.Доступность(Доступность);
КонецПроцедуры
И цитата из синтакс-помошника, удачи.
НазначитьТип(<?>,,);
SetType(<?>,,);
Синтаксис:
НазначитьТип(<ИмяТипа>,<Длина>,<Точность>)
Назначение:
Назначить тип для элемента диалога, которому в конфигураторе назначен тип 'Неопределенный'.
Параметры:
<ИмяТипа> - строковое выражение - название типа данных, которое назначается элементу диалога. Например, 'Строка', 'Число', 'Справочник.Товары', 'Документ.РасходнаяНакладная' и т.п.
<Длина> - необязательный параметр. Числовое выражение - длина поля представления числа. Имеет смысл только при задании числового типа.
<Точность> - необязательный параметр. Числовое выражение - число знаков числа после десятичной точки. Имеет смысл только при задании числового типа.
Замечание:
Доступ к методу возможен только в контексте Модуля формы через атрибут Форма.
Подробнее см. в документации, глава 'Атрибуты и методы контекста Модуля формы'
 
A

Azrael

Гость
#3
Спасибо, плюс сча нажму :blink: Ещё вопросик вдогонку: как сделать, чтобы при выборе счета пользователь видел в списке счетов только те, корреспонденции с которыми по д*цензура*у счета кассы считаются корректными.

Видел в синтакс-помошнике объект "Корректная проводка", но где их создавать не понял :(
 

Zab

Well-Known Member
07.08.2006
583
0
Менск
#4
Бушь смеяться, но более чем за 7 лет активной работы с 7.7. ни разу не столкнулся с этим объектом в работе.
Я так понял, что вопрос в том, где найти список корректных проводок? Тогда: Режим "Предприятие" - Меню Операции->Корректные проводки.