Не ищется в справочнике

  • Автор темы roddik
  • Дата начала
Статус
Закрыто для дальнейших ответов.
R

roddik

#1
Привет! Такой код:
Код:
	Спр=СоздатьОбъект("Справочник");
Спр.Вид(Тип);
Сообщить("Ищу в справочнике типа "+Тип+" значение "+Описание);
Если Спр.НайтиПоНаименованию(Описание, 1, 0) = 1 Тогда
Сообщить("Нашел")
Выводит
Ищу в справочнике типа Контрагенты значение (тут один из контрагентов - достал для пробы из справочника)
Ищу в справочнике типа Контрагенты значение (тут один из контрагентов - достал для пробы из справочника),
то есть не находит ничего. Может проблема в том, что в справочнике наименование агента начинается с большой буквы, а в описании - с маленькой?

UPD: попробовал буквы сделать одного регистра - не ищет все равно
 
G

GRblSHA

#2
хм... интернесно а чему равен Тип и открывает ли он вообще справочник?
Попробуй так:
Спр=СоздатьОбъект("Справочник");
Спр.Вид(Тип);
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент()>0 цикл
Сообщить("Имя "+ Спр.Наименование);
КонецЦикла;

Ежели справочник существует и ты правильно задал Вид, то в окне сообщения будут выведены все элементы справочника.

а потом можно так:
Спр=СоздатьОбъект("Справочник");
Спр.Вид(Тип);
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент()>0 цикл
Если СокрЛП(Спр.Описание)=СокрЛП(Описание) тогда
Сообщить("Нашел!!");
КонецЕсли;
КонецЦикла;

Хотя код не оптимизированый
 
R

roddik

#3
Спасибо, оказалось, что нужно было использовать НайтиПоНаименованию(Описание, 0, 0) ^_^
 
Статус
Закрыто для дальнейших ответов.