1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

Не ищется в справочнике

Тема в разделе "Базы данных и администрирование", создана пользователем roddik, 7 авг 2008.

Статус темы:
Закрыта.
  1. roddik

    roddik Гость

    Репутация:
    0
    Привет! Такой код:
    Код:
    	Спр=СоздатьОбъект("Справочник");
    Спр.Вид(Тип);
    Сообщить("Ищу в справочнике типа "+Тип+" значение "+Описание);
    Если Спр.НайтиПоНаименованию(Описание, 1, 0) = 1 Тогда
    Сообщить("Нашел")
    Выводит
    Ищу в справочнике типа Контрагенты значение (тут один из контрагентов - достал для пробы из справочника)
    Ищу в справочнике типа Контрагенты значение (тут один из контрагентов - достал для пробы из справочника),
    то есть не находит ничего. Может проблема в том, что в справочнике наименование агента начинается с большой буквы, а в описании - с маленькой?

    UPD: попробовал буквы сделать одного регистра - не ищет все равно
     
  2. GRblSHA

    GRblSHA Гость

    Репутация:
    0
    хм... интернесно а чему равен Тип и открывает ли он вообще справочник?
    Попробуй так:
    Спр=СоздатьОбъект("Справочник");
    Спр.Вид(Тип);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()>0 цикл
    Сообщить("Имя "+ Спр.Наименование);
    КонецЦикла;

    Ежели справочник существует и ты правильно задал Вид, то в окне сообщения будут выведены все элементы справочника.

    а потом можно так:
    Спр=СоздатьОбъект("Справочник");
    Спр.Вид(Тип);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()>0 цикл
    Если СокрЛП(Спр.Описание)=СокрЛП(Описание) тогда
    Сообщить("Нашел!!");
    КонецЕсли;
    КонецЦикла;

    Хотя код не оптимизированый
     
  3. roddik

    roddik Гость

    Репутация:
    0
    Спасибо, оказалось, что нужно было использовать НайтиПоНаименованию(Описание, 0, 0) ^_^
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей