Не ищется в справочнике

Тема в разделе "1C и всё что с ней связано", создана пользователем roddik, 7 авг 2008.

Статус темы:
Закрыта.
  1. roddik

    roddik Гость

    Привет! Такой код:
    Код (Text):
        Спр=СоздатьОбъект("Справочник");
    Спр.Вид(Тип);
    Сообщить("Ищу в справочнике типа "+Тип+" значение "+Описание);
    Если Спр.НайтиПоНаименованию(Описание, 1, 0) = 1 Тогда
    Сообщить("Нашел")
    Выводит
    Ищу в справочнике типа Контрагенты значение (тут один из контрагентов - достал для пробы из справочника)
    Ищу в справочнике типа Контрагенты значение (тут один из контрагентов - достал для пробы из справочника),
    то есть не находит ничего. Может проблема в том, что в справочнике наименование агента начинается с большой буквы, а в описании - с маленькой?

    UPD: попробовал буквы сделать одного регистра - не ищет все равно
     
  2. GRblSHA

    GRblSHA Гость

    хм... интернесно а чему равен Тип и открывает ли он вообще справочник?
    Попробуй так:
    Спр=СоздатьОбъект("Справочник");
    Спр.Вид(Тип);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()>0 цикл
    Сообщить("Имя "+ Спр.Наименование);
    КонецЦикла;

    Ежели справочник существует и ты правильно задал Вид, то в окне сообщения будут выведены все элементы справочника.

    а потом можно так:
    Спр=СоздатьОбъект("Справочник");
    Спр.Вид(Тип);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()>0 цикл
    Если СокрЛП(Спр.Описание)=СокрЛП(Описание) тогда
    Сообщить("Нашел!!");
    КонецЕсли;
    КонецЦикла;

    Хотя код не оптимизированый
     
  3. roddik

    roddik Гость

    Спасибо, оказалось, что нужно было использовать НайтиПоНаименованию(Описание, 0, 0) ^_^
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей