Не Могу Разобратся С Кодировкой

SeverBap

Well-Known Member
18.09.2007
451
0
34
г. Брянск
#1
Код:
	ИмяВременногоФайла = ПолучитьИмяВременногоФайла();	
Соединение = Новый HTTPСоединение("www.nbrb.by");
Попытка
Соединение.Получить("statistics/Rates/RatesPrint.asp?fromDate="+Формат(ТекущаяДата(),"ДФ=yyyy-MM-dd"),ИмяВременногоФайла);
Соединение=Неопределено;
Исключение
Соединение=Неопределено;
КонецПопытки;
НоваяТаб=Новый ТаблицаЗначений();
НоваяТаб.Колонки.Добавить("Код");
НоваяТаб.Колонки.Добавить("Наименование");
НоваяТаб.Колонки.Добавить("Курс");
ЧтениеHTML = Новый ЧтениеHTML;
ЧтениеHTML.ОткрытьФайл(ИмяВременногоФайла);
ПостроительDOM = Новый ПостроительDOM;
ДокументDOM = ПостроительDOM.Прочитать(ЧтениеHTML);	
СписокTr=ДокументDOM.ПолучитьЭлементыПоИмени("tr");
Для Каждого Tr Из СписокTr Цикл
Попытка
НоваяСтрока=НоваяТаб.Добавить();
НоваяСтрока.Код=СокрЛП(Tr.ДочерниеУзлы[0].ТекстовоеСодержимое);
НоваяСтрока.Наименование=СокрЛП(Tr.ДочерниеУзлы[1].ТекстовоеСодержимое);
НоваяСтрока.Курс=СокрЛП(Tr.ДочерниеУзлы[2].ТекстовоеСодержимое);
Исключение

КонецПопытки;	
КонецЦикла;
Результат таблица с абро кадабра хотя в файле стоит UTF-8
что там с кодировкой не так?
 

SeverBap

Well-Known Member
18.09.2007
451
0
34
г. Брянск
#2
:O_0:
Код:
	ИмяВременногоФайла = ПолучитьИмяВременногоФайла();	
Соединение = Новый HTTPСоединение("www.nbrb.by");
Попытка
Соединение.Получить("statistics/Rates/RatesPrint.asp?fromDate="+Формат(ТекущаяДата(),"ДФ=yyyy-MM-dd"),ИмяВременногоФайла);
Соединение=Неопределено;
Исключение
Соединение=Неопределено;
КонецПопытки;
ТаблицаДанных.Очистить();
ЧтениеHTML = Новый ЧтениеHTML;
ЧтениеHTML.ОткрытьФайл(ИмяВременногоФайла,"UTF-8");
ПостроительDOM = Новый ПостроительDOM;
ДокументDOM = ПостроительDOM.Прочитать(ЧтениеHTML);	
СписокTr=ДокументDOM.ПолучитьЭлементыПоИмени("tr");
Для Каждого Tr Из СписокTr Цикл
Попытка
Если СокрЛП(Tr.ДочерниеУзлы[0].ТекстовоеСодержимое)="Код" Тогда 
Продолжить;
КонецЕсли;
НоваяСтрока=ТаблицаДанных.Добавить();
НоваяСтрока.Код=СокрЛП(Tr.ДочерниеУзлы[0].ТекстовоеСодержимое);
НоваяСтрока.Наименование=СокрЛП(Tr.ДочерниеУзлы[1].ТекстовоеСодержимое);
НоваяСтрока.Курс=СтрЗаменить(СокрЛП(Tr.ДочерниеУзлы[2].ТекстовоеСодержимое)," ","");
Исключение

КонецПопытки;	
КонецЦикла;
После явного указания прокатило
 

Дайнеко

Well-Known Member
19.11.2009
951
0
53
Минск
#3
Занимался этим вопросам раньше. http://codeby.net/forum/threads/50307.html
Честно говоря так и не добился толка с кодировкой. Переделал на другой вариант запроса - xml - файл.
И кодировкой все ладно, и читается надежнее.

Код:
ДатаДляФайла = Формат(ДатаГод(ДатаВвода), "Ч4") + "-"+ Формат(ДатаМесяц(ДатаВвода), "Ч2") +"-"+ Формат(ДатаЧисло(ДатаВвода), "Ч2");
СтрокаЗапрос = "http://www.nbrb.by/Services/XmlExRates.aspx?ondate="+ ДатаДляФайла;
НТТР.ПолучитьКакФайл(СтрокаЗапрос, "Курсы.xml");
 
01.05.2013
15
1
#5
Советую обратится на специлизированнный портал по фрилансу 1С, там думаю должны решить вашу проблему. Например неоднократно используемая мною в качестве площадки для поиска специалистов, биржа фриланса. Либо получите квалифицированный совет по вашей проблеме.
 

SeverBap

Well-Known Member
18.09.2007
451
0
34
г. Брянск
#6
Советую обратится на специлизированнный портал по фрилансу 1С, там думаю должны решить вашу проблему. Например неоднократно используемая мною в качестве площадки для поиска специалистов, биржа фриланса. Либо получите квалифицированный совет по вашей проблеме.
Чет я не понял к чему это?