Не Могу Разобратся С Кодировкой

Тема в разделе "1C и всё что с ней связано", создана пользователем SeverBap, 26 апр 2013.

  1. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    Код (Text):
        ИмяВременногоФайла = ПолучитьИмяВременногоФайла(); 
    Соединение = Новый HTTPСоединение("www.nbrb.by");
    Попытка
    Соединение.Получить("statistics/Rates/RatesPrint.asp?fromDate="+Формат(ТекущаяДата(),"ДФ=yyyy-MM-dd"),ИмяВременногоФайла);
    Соединение=Неопределено;
    Исключение
    Соединение=Неопределено;
    КонецПопытки;
    НоваяТаб=Новый ТаблицаЗначений();
    НоваяТаб.Колонки.Добавить("Код");
    НоваяТаб.Колонки.Добавить("Наименование");
    НоваяТаб.Колонки.Добавить("Курс");
    ЧтениеHTML = Новый ЧтениеHTML;
    ЧтениеHTML.ОткрытьФайл(ИмяВременногоФайла);
    ПостроительDOM = Новый ПостроительDOM;
    ДокументDOM = ПостроительDOM.Прочитать(ЧтениеHTML);  
    СписокTr=ДокументDOM.ПолучитьЭлементыПоИмени("tr");
    Для Каждого Tr Из СписокTr Цикл
    Попытка
    НоваяСтрока=НоваяТаб.Добавить();
    НоваяСтрока.Код=СокрЛП(Tr.ДочерниеУзлы[0].ТекстовоеСодержимое);
    НоваяСтрока.Наименование=СокрЛП(Tr.ДочерниеУзлы[1].ТекстовоеСодержимое);
    НоваяСтрока.Курс=СокрЛП(Tr.ДочерниеУзлы[2].ТекстовоеСодержимое);
    Исключение

    КонецПопытки;  
    КонецЦикла;
    Результат таблица с абро кадабра хотя в файле стоит UTF-8
    что там с кодировкой не так?
     
  2. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    :O_0:
    Код (Text):
        ИмяВременногоФайла = ПолучитьИмяВременногоФайла(); 
    Соединение = Новый HTTPСоединение("www.nbrb.by");
    Попытка
    Соединение.Получить("statistics/Rates/RatesPrint.asp?fromDate="+Формат(ТекущаяДата(),"ДФ=yyyy-MM-dd"),ИмяВременногоФайла);
    Соединение=Неопределено;
    Исключение
    Соединение=Неопределено;
    КонецПопытки;
    ТаблицаДанных.Очистить();
    ЧтениеHTML = Новый ЧтениеHTML;
    ЧтениеHTML.ОткрытьФайл(ИмяВременногоФайла,"UTF-8");
    ПостроительDOM = Новый ПостроительDOM;
    ДокументDOM = ПостроительDOM.Прочитать(ЧтениеHTML);  
    СписокTr=ДокументDOM.ПолучитьЭлементыПоИмени("tr");
    Для Каждого Tr Из СписокTr Цикл
    Попытка
    Если СокрЛП(Tr.ДочерниеУзлы[0].ТекстовоеСодержимое)="Код" Тогда
    Продолжить;
    КонецЕсли;
    НоваяСтрока=ТаблицаДанных.Добавить();
    НоваяСтрока.Код=СокрЛП(Tr.ДочерниеУзлы[0].ТекстовоеСодержимое);
    НоваяСтрока.Наименование=СокрЛП(Tr.ДочерниеУзлы[1].ТекстовоеСодержимое);
    НоваяСтрока.Курс=СтрЗаменить(СокрЛП(Tr.ДочерниеУзлы[2].ТекстовоеСодержимое)," ","");
    Исключение

    КонецПопытки;  
    КонецЦикла;
    После явного указания прокатило
     
  3. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Занимался этим вопросам раньше. http://codeby.net/forum/threads/50307.html
    Честно говоря так и не добился толка с кодировкой. Переделал на другой вариант запроса - xml - файл.
    И кодировкой все ладно, и читается надежнее.

    Код ( (Unknown Language)):
    ДатаДляФайла = Формат(ДатаГод(ДатаВвода), "Ч4") + "-"+ Формат(ДатаМесяц(ДатаВвода), "Ч2") +"-"+ Формат(ДатаЧисло(ДатаВвода), "Ч2");
    СтрокаЗапрос = "http://www.nbrb.by/Services/XmlExRates.aspx?ondate="+ ДатаДляФайла;
    НТТР.ПолучитьКакФайл(СтрокаЗапрос, "Курсы.xml");
     
  4. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    :) а я этот добил!
     
  5. Alekseyyy

    Alekseyyy Member

    Регистрация:
    1 май 2013
    Сообщения:
    15
    Симпатии:
    0
    Советую обратится на специлизированнный портал по фрилансу 1С, там думаю должны решить вашу проблему. Например неоднократно используемая мною в качестве площадки для поиска специалистов, биржа фриланса. Либо получите квалифицированный совет по вашей проблеме.
     
  6. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    Чет я не понял к чему это?
     
  7. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    СЕОшники, штоб их....
     
  8. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    Вот черт и тут они!
     
Загрузка...

Поделиться этой страницей