1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

Не Могу Разобратся С Кодировкой

Тема в разделе "Базы данных и администрирование", создана пользователем SeverBap, 26 апр 2013.

  1. SeverBap

    SeverBap Well-Known Member

    Репутация:
    0
    Регистрация:
    18 сен 2007
    Сообщения:
    451
    Симпатии:
    0
    Код:
    	ИмяВременногоФайла = ПолучитьИмяВременногоФайла();	
    Соединение = Новый HTTPСоединение("www.nbrb.by");
    Попытка
    Соединение.Получить("statistics/Rates/RatesPrint.asp?fromDate="+Формат(ТекущаяДата(),"ДФ=yyyy-MM-dd"),ИмяВременногоФайла);
    Соединение=Неопределено;
    Исключение
    Соединение=Неопределено;
    КонецПопытки;
    НоваяТаб=Новый ТаблицаЗначений();
    НоваяТаб.Колонки.Добавить("Код");
    НоваяТаб.Колонки.Добавить("Наименование");
    НоваяТаб.Колонки.Добавить("Курс");
    ЧтениеHTML = Новый ЧтениеHTML;
    ЧтениеHTML.ОткрытьФайл(ИмяВременногоФайла);
    ПостроительDOM = Новый ПостроительDOM;
    ДокументDOM = ПостроительDOM.Прочитать(ЧтениеHTML);	
    СписокTr=ДокументDOM.ПолучитьЭлементыПоИмени("tr");
    Для Каждого Tr Из СписокTr Цикл
    Попытка
    НоваяСтрока=НоваяТаб.Добавить();
    НоваяСтрока.Код=СокрЛП(Tr.ДочерниеУзлы[0].ТекстовоеСодержимое);
    НоваяСтрока.Наименование=СокрЛП(Tr.ДочерниеУзлы[1].ТекстовоеСодержимое);
    НоваяСтрока.Курс=СокрЛП(Tr.ДочерниеУзлы[2].ТекстовоеСодержимое);
    Исключение
    
    КонецПопытки;	
    КонецЦикла;
    Результат таблица с абро кадабра хотя в файле стоит UTF-8
    что там с кодировкой не так?
     
  2. SeverBap

    SeverBap Well-Known Member

    Репутация:
    0
    Регистрация:
    18 сен 2007
    Сообщения:
    451
    Симпатии:
    0
    :O_0:
    Код:
    	ИмяВременногоФайла = ПолучитьИмяВременногоФайла();	
    Соединение = Новый HTTPСоединение("www.nbrb.by");
    Попытка
    Соединение.Получить("statistics/Rates/RatesPrint.asp?fromDate="+Формат(ТекущаяДата(),"ДФ=yyyy-MM-dd"),ИмяВременногоФайла);
    Соединение=Неопределено;
    Исключение
    Соединение=Неопределено;
    КонецПопытки;
    ТаблицаДанных.Очистить();
    ЧтениеHTML = Новый ЧтениеHTML;
    ЧтениеHTML.ОткрытьФайл(ИмяВременногоФайла,"UTF-8");
    ПостроительDOM = Новый ПостроительDOM;
    ДокументDOM = ПостроительDOM.Прочитать(ЧтениеHTML);	
    СписокTr=ДокументDOM.ПолучитьЭлементыПоИмени("tr");
    Для Каждого Tr Из СписокTr Цикл
    Попытка
    Если СокрЛП(Tr.ДочерниеУзлы[0].ТекстовоеСодержимое)="Код" Тогда 
    Продолжить;
    КонецЕсли;
    НоваяСтрока=ТаблицаДанных.Добавить();
    НоваяСтрока.Код=СокрЛП(Tr.ДочерниеУзлы[0].ТекстовоеСодержимое);
    НоваяСтрока.Наименование=СокрЛП(Tr.ДочерниеУзлы[1].ТекстовоеСодержимое);
    НоваяСтрока.Курс=СтрЗаменить(СокрЛП(Tr.ДочерниеУзлы[2].ТекстовоеСодержимое)," ","");
    Исключение
    
    КонецПопытки;	
    КонецЦикла;
    После явного указания прокатило
     
  3. Дайнеко

    Дайнеко Well-Known Member

    Репутация:
    0
    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Занимался этим вопросам раньше. http://codeby.net/forum/threads/50307.html
    Честно говоря так и не добился толка с кодировкой. Переделал на другой вариант запроса - xml - файл.
    И кодировкой все ладно, и читается надежнее.

    Код:
    ДатаДляФайла = Формат(ДатаГод(ДатаВвода), "Ч4") + "-"+ Формат(ДатаМесяц(ДатаВвода), "Ч2") +"-"+ Формат(ДатаЧисло(ДатаВвода), "Ч2");
    СтрокаЗапрос = "http://www.nbrb.by/Services/XmlExRates.aspx?ondate="+ ДатаДляФайла;
    НТТР.ПолучитьКакФайл(СтрокаЗапрос, "Курсы.xml");
     
  4. SeverBap

    SeverBap Well-Known Member

    Репутация:
    0
    Регистрация:
    18 сен 2007
    Сообщения:
    451
    Симпатии:
    0
    :) а я этот добил!
     
  5. Alekseyyy

    Alekseyyy Member

    Репутация:
    0
    Регистрация:
    1 май 2013
    Сообщения:
    15
    Симпатии:
    1
    Советую обратится на специлизированнный портал по фрилансу 1С, там думаю должны решить вашу проблему. Например неоднократно используемая мною в качестве площадки для поиска специалистов, биржа фриланса. Либо получите квалифицированный совет по вашей проблеме.
     
  6. SeverBap

    SeverBap Well-Known Member

    Репутация:
    0
    Регистрация:
    18 сен 2007
    Сообщения:
    451
    Симпатии:
    0
    Чет я не понял к чему это?
     
  7. puh14

    puh14 Well-Known Member

    Репутация:
    0
    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    СЕОшники, штоб их....
     
  8. SeverBap

    SeverBap Well-Known Member

    Репутация:
    0
    Регистрация:
    18 сен 2007
    Сообщения:
    451
    Симпатии:
    0
    Вот черт и тут они!
     
Загрузка...
Похожие Темы - Не Могу Разобратся
  1. evgeniy1377
    Ответов:
    1
    Просмотров:
    1.388
  2. Mister robot
    Ответов:
    15
    Просмотров:
    133
  3. Lustrator
    Ответов:
    21
    Просмотров:
    147
  4. marraty
    Ответов:
    45
    Просмотров:
    423
  5. TechOn
    Ответов:
    0
    Просмотров:
    31

Поделиться этой страницей