Не Могу Запустить App На Ruby. Подскажите Что Не Так

Тема в разделе "Web 2.0, AJAX, Ruby, RSS технологии", создана пользователем Xima, 6 фев 2012.

Статус темы:
Закрыта.
  1. Xima

    Xima Тестируем

    Регистрация:
    29 сен 2005
    Сообщения:
    229
    Симпатии:
    0
    Привет господа и дамы,

    С Ryby я не знаком совсем и, поэтому, сам вряд ли без изучения языка пойму что и как.

    Пытаюсь запустить Ec2Main - это UI для Eucalyptus. Решил поиграться с облаками, а поставляемые с ним command line tools просто убивают.

    Вот адрес сайта с этой программой http://ec2dream.blogspot.com/search/label/Tools

    Делаю всё по инструкции, как описано в readme, но при запуске получаю ошибку следующего вида:
    C:\Users\pedro>C:\EC2Dream\system\EC2_Main.rb
    C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original
    _require': no such file to load -- fox16 (LoadError)
    from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
    `require'
    from C:/EC2Dream/system/EC2_Main.rb:4


    Custom_require.rb содежит в 31 строчке лишь это:
    gem_original_require path

    Ec2Main d 4-ой это:
    require 'fox16'

    На некоторых форумах советовали дописать require rubygems в начало файла, но там уже это дописано. Также менял required на load (тоже с форумов) - изменений ноль.

    Помогите пожалуйста разобраться. Это последний шанс получить нормальный UI.

    Спасибо :)
     
  2. Xima

    Xima Тестируем

    Регистрация:
    29 сен 2005
    Сообщения:
    229
    Симпатии:
    0
    Решил проблему установкой fxruby и корректировкой файла запуска (выпилил Ec2_Reqired)
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей