Не отображаетса цена

Тема в разделе "1C и всё что с ней связано", создана пользователем Roma, 27 дек 2007.

  1. Roma

    Roma Гость

    Стандартная база для Украины, в табличную часть документов Счет и Росходная нужно добавить колонку с "Ценой с НДС". Делаю копию бази и вношу нужные изменения. Все роботает, все нормально отображаетса. Утром, до прихода бухгалтерии делаю изменения в робочей базе, проверяю - цена не отображаетса. Не могу понять почему. Может кто подскажет. Сбасибо.

    Код (Text):
    Процедура УстЦенаСНДС()
    Если ТМЦ.Вид()="ТМЦ" Тогда
    ЦенаСНДС = глПересчет(ТМЦ.Цена_Розн,ТМЦ.Валюта_Прод,Валюта,ДатаДок,Курс);
    Сообщить("Цена с НДС"+ЦенаСНДС,"!!!");
    Иначе
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьРазделительУчета(Фирма);
    Ит.ИспользоватьСубконто(ВидыСубконто.НеоборотныеАктивы, ТМЦ, 2);
    Ит.ВыполнитьЗапрос(?(Выбран()=1,ТекущийДокумент(),ДатаДок),,ТМЦ.Счет);
    СумПерв = глПересчет(Ит.СНД(),Гривня,Валюта,Курс,ДатаДок);
    //Сообщить("Цена с НДС"+ЦенаСНДС,"!!!");
    Если СумПерв = 0 Тогда
    ЦенаСНДС = глПересчет(ТМЦ.Цена_Прих,Гривня,Валюта,ДатаДок,Курс);
    //Сообщить("Цена с НДС"+ЦенаСНДС,"!!!");
    Иначе
    ЦенаСНДС = СумПерв;
    //Сообщить("Цена с НДС"+ЦенаСНДС,"!!!");
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    untitled.JPG untitled2.JPG
     
  2. Roma

    Roma Гость

    В ТМЦ есть реквизиты Цена_Прод и Цена_Розн.
    Код:
    Если ТМЦ.Вид()="ТМЦ" Тогда
    ЦенаБезНДС = глПересчет(ТМЦ.Цена_Прод,ТМЦ.Валюта_Прод,Валюта,ДатаДок,Курс);

    отображает Цена_Прод, а:
    Если ТМЦ.Вид()="ТМЦ" Тогда
    ЦенаСНДС = глПересчет(ТМЦ.Цена_Розн,ТМЦ.Валюта_Прод,Валюта,ДатаДок,Курс);
    выводит, что Цена_Розн равно 0, что есть неправильным.

    в чем проблема??? ;)
     
  3. Jina

    Jina Гость

    В отсутствии знающего программиста. Я в 1С без них вообще ничего не меняю.
     
Загрузка...

Поделиться этой страницей