Не отображаются документы после редактирования.

Химик

New member
09.10.2015
3
0
#1
День добрый!
Вылезла следующая проблема: в нескольких вьюхах не отображаются документы (вообще не выводит никаких значений, но счетчиком видно. что они есть). Появилось после редактирования документа. Shift + F9 помогает, но после следующего редактирования документы опять не отображаются. В notes.ini. поставили MAX_PERMUTE_RECURSE=100000 и fix pack тоже ставили. Пользователи в панике. говорят документы исчезают. Что посоветуете?
 

garrick

Lotus team
26.10.2009
898
61
#2
Из вашего сообщения не совсем понятно. У вас что-то справами доступа или с обновлением индекса представления?
 

garrick

Lotus team
26.10.2009
898
61
#4
После изменения документа в нём что-то меняется, влияющее на его положение в представлении (ключ, индекс, сортировка, группировка и пр.), или что-то участвующее в формуле отбора представления (SELECT)?
 

lmike

нет, пердело совершенство
Lotus team
27.08.2008
6 583
269
#5
я наблюдал в категоризированной вьюшке "исчезновени" (на самом деле - попадание в категорию выше или ниже)
дока, в кот. поле для категоризации было с кавычками !угловыми
закономерность не заметил (в 7-ке такого не было)
вьюшка в ТЛ включена
есть еще фича Optimize tabl map не знаю её влияние на глюки (я её только недавно установил и был обруган в логах)
 

Химик

New member
09.10.2015
3
0
#6
После изменения документа в нём что-то меняется, влияющее на его положение в представлении (ключ, индекс, сортировка, группировка и пр.), или что-то участвующее в формуле отбора представления (SELECT)?
Изменяется значение 1 поля. Положение в представлении меняется (группировка).
 

garrick

Lotus team
26.10.2009
898
61
#7
Значит пользователям после изменения документа надо жмакать F9 во вьюхе. Или как-то программно обновлять view после сохранения документа, но при большом количестве документов можно базу "подвесить", если индекс очень часто обновляться будет.
 

Lariel

Active member
11.09.2009
41
2
#8
Я бы наверно попробовал бы создать новое представление с другим названием
но с такой же формулой отбора и таким же составом столбцов и посмотрел лбы там проблема повторяется ?
Причем, не копирование исходного представления и именно создать новое представление с аналогичными столбцами.
Возможно это проблема не обновления индекса а проблема самого представления, которая сказывается на индексе.
 
Симпатии: Понравилось Мыш

lmike

нет, пердело совершенство
Lotus team
27.08.2008
6 583
269
#9
проблема самого представления
бывает, при копировании колонок из др. вьюшек...
еще бывают глюки - если разработка ведется на той же БД, что и работа (вместо разрабоки шаблона)
 
Симпатии: Понравилось Мыш