Не появляются новые письма в traveler через активсинк, но уходят исправно

hellsq

Active member
18.02.2014
29
0
#1
После аварии по питанию и перезагрузки всего и вся, всплыла следующая проблема.

Есть два сервера, все под 2008r2, один используется как основной почтовый, второй - под traveler. После включения после аварии наблюдаем следующую картину: письма на мобильных устройствах (яблочные и андроидные стандартные почтовые клиенты) не появляются, но отправка идёт успешно.

При этом через веб-интерфейс для тех пользователей, у кого размещены реплики баз на тревелере - всё замечательно работает.

К /servlet/traveler с мобильных доступ есть через веб, авторизация проходит успешно.

Есть пара бэкапов сервера тревелер, за день до аварии и за месяц до неё, были попытки поднятия каждого из них - с теми же самыми результатами.

Логи вывел уровня fine - ничего интересного не увидел. Попытки синхронизации в случае моей личной учетки заканчиваются FINE или FINER, в логах ошибок она не фигурирует постоянно (изредка встречаются ошибки ActiveSyncWorker.handleRequestSettings#1265 Unexpected tag in Settings: Policies, но они встречаются в разы реже, чем должны были бы, если бы это был ответ на неудачную синхронизацию.

Единственное, что попалось на глаза: в логах время отстаёт от реального на 6 часов. В notes.ini временные зоны указаны для явы в явном, пардон за каламбур, виде NTS_Java_Parms=-Duser.timezone=GMT+3, в консоли время правильное, при отправке сообщений в них тоже проставляется правильное время. В логах - нет.

UPDATE: внезапно помог tell traveler reset для отдельных юзеров. Вопрос - а что это, блин, было? И как сделать tell traveler reset для всех?
 
Последнее редактирование модератором:

puks

Lotus team
03.02.2007
1 971
8
#2
Скорее всего, полетел syncid счетчик. Reset команда сбрасывает sync счетчик и заставляет синхронизироваться опять.
 

apatic

Active member
11.08.2015
26
1
#3
можно tell traveler reset * username - для всех девайсов пользователя, а вот как для всех пользователей сделать, не знаю.
 

swyatogor

Lotus team
24.02.2014
478
10
#4
Доброго всем..
У мну почти аналогичная бяда.. у нескольких пользователей перестает работать синхронизация..
в консоле сервера ошибка:
[1958:000C-1314] 04.09.2015 14:22:48 Traveler: WARNING User No usage info available for the logout on session b137aab014f976eb7ab6ca1aaeda5a71b55. Session may not be closed properly.
и еще есть вот такого типа
Traveler: WARNING User [Android_6554f11f1c28e604] Server has sent 21 busy responses in a row, so sending back HttpServletResponse.SC_SERVICE_UNAVAILABLE (503). Please retry later.
еще вот такие нашел от того же пользователя
Traveler: WARNING User Request is empty and command SendMail is expected to have a body.
и как эту бяду победить.. причем работало всё корректно довольно длительное время.. потом без видимых причин начало сваливаться((

На устройстве на самом вот такой лог
Безымянный.png
 
Последнее редактирование модератором:

swyatogor

Lotus team
24.02.2014
478
10
#6
@apatic, календарь пуст( вообще пуст..
После reset какое-то время работает, потом опять сваливается.. проверял(
 

apatic

Active member
11.08.2015
26
1
#7
@swyatogor, а сколько работает после резета?
мож есть что поинтереснее в папке IBM_TECHNICAL_SUPPORT\traveler\logs в NTSErrors?
Версия тревелера?
Подключение HTTP или HTTPS?
Может есть что-то общее между сбойными пользователями? общее письмо, рассылка, группа или что-нибудь такое?
Что в этот момент сбоя сервер возвращает по команде tell traveler status?
на самом деле ошибки гуглятся, но я сходу не нашел путных советов.
 

swyatogor

Lotus team
24.02.2014
478
10
#9
[0A6C:0008-23D8] IBM Domino (r) Server (64 Bit) (Release 9.0.1FP4 for Windows/64) 04.09.2015 16:09:35
[1958:01D5-0C98] 04.09.2015 16:12:34 Traveler: IBM Traveler 9.0.1.7 Build 201508211840_20
HTTPS
Общего у пользователей - IPhone и IBM Verse на них.. стандартная схема (с созданием профиля) вроде работает..
Самое интересное, что статус сервера вообще ошибок не видит.. у мну грит всё хорошо всё работает(
[1958:01D3-14D8] 04.09.2015 16:25:16 Traveler: The IBM Traveler task has been running since Thu Sep 03 23:48:30 YEKT 2015.
[1958:01D3-14D8] 04.09.2015 16:25:16 Traveler: The IBM Traveler availability index is currently 100 while servicing 237 users.
[1958:01D3-14D8] 04.09.2015 16:25:16 Traveler: The last successful device sync was on Fri Sep 04 16:25:10 YEKT 2015.
[1958:01D3-14D8] 04.09.2015 16:25:16 Traveler:
[1958:01D3-14D8] 04.09.2015 16:25:16 Traveler: Yellow Status Messages
[1958:01D3-14D8] 04.09.2015 16:25:16 Traveler: Disk space for d:\Domino\Data has 9 percent free that is less than the threshold of 15.
[1958:01D3-14D8] 04.09.2015 16:25:16 Traveler:
[1958:01D3-14D8] 04.09.2015 16:25:16 Traveler: The overall status of IBM Traveler is Yellow.
 

swyatogor

Lotus team
24.02.2014
478
10
#10
поступила новая инфа только что: один из пользователей сказал, что у него некоторые письма задвоились.. и при этом половина двойников открывается, половина нет..
 

apatic

Active member
11.08.2015
26
1
#11
@swyatogor, я не гуру, но может он действительно 20 раз вернул честную 503 ошибку из-за загрузки сервера?
ну и плюс это
Disk space for d:\Domino\Data has 9 percent free that is less than the threshold of 15.
в общем, я бы сначала из желтой зоны вышел, так сказать.

по производительности я читал неплохую памятку тут в принципе, если сервер мощный - можно подкрутить немного http threads и всякие boof_size. но только по чуть-чуть.
 

lmike

нет, пердело совершенство
Lotus team
27.08.2008
6 583
269
#15
при заходе винды в режим с пределом по пространству диска - можно вполне получить "повреждения" в MFT
а это может приводить к разным глюкам