Не получается увидеть количество из БИ

Тема в разделе "1C и всё что с ней связано", создана пользователем Paume, 6 янв 2011.

  1. Paume

    Paume Well-Known Member

    Регистрация:
    15 дек 2010
    Сообщения:
    110
    Симпатии:
    0
    Добрый день!

    Почему БИ.ДО("К") - ноль?
    И как увидеть количество товара, которое пришло из производства?

    Код ( (Unknown Language)):
        БИ=СоздатьОбъект("БухгалтерскиеИтоги");
    БИ.ИспользоватьСубконто(ВидыСубконто.Номенклатура);
    БИ.ВыполнитьЗапрос(КонДата,КонДата,"43","20",,,,5);
    БИ.ВыбратьСубконто();
    Пока БИ.получитьСубконто()=1 Цикл
    Товар=БИ.Субконто();
    Если БИ.ДО("К")<>0 Тогда
    Количество=БИ.ДО("К");
    КонецЕсли;
    КонецЦикла;
     
  2. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    БИ=СоздатьОбъект("БухгалтерскиеИтоги");
    БИ.ИспользоватьСубконто(ВидыСубконто.Номенклатура);
    БИ.ВыполнитьЗапрос(КонДата,КонДата,"43","20",,2,,5);
    БИ.ВыбратьСубконто();
    Пока БИ.получитьСубконто()=1 Цикл
    Товар=БИ.Субконто();
    Если БИ.ДО("К")<>0 Тогда
    Количество=БИ.ДО("К");
    КонецЕсли;
    КонецЦикла;
     
  3. Paume

    Paume Well-Known Member

    Регистрация:
    15 дек 2010
    Сообщения:
    110
    Симпатии:
    0
    спасибо!
    Получилось.
     
Загрузка...

Поделиться этой страницей