Не получается увидеть количество из БИ

Paume

Well-known member
15.12.2010
107
0
#1
Добрый день!

Почему БИ.ДО("К") - ноль?
И как увидеть количество товара, которое пришло из производства?

Код:
	БИ=СоздатьОбъект("БухгалтерскиеИтоги");
БИ.ИспользоватьСубконто(ВидыСубконто.Номенклатура); 
БИ.ВыполнитьЗапрос(КонДата,КонДата,"43","20",,,,5);
БИ.ВыбратьСубконто();
Пока БИ.получитьСубконто()=1 Цикл
Товар=БИ.Субконто();
Если БИ.ДО("К")<>0 Тогда
Количество=БИ.ДО("К");
КонецЕсли;	
КонецЦикла;
 

unknown181538

НеГуру
28.12.2008
1 417
0
#2
БИ=СоздатьОбъект("БухгалтерскиеИтоги");
БИ.ИспользоватьСубконто(ВидыСубконто.Номенклатура);
БИ.ВыполнитьЗапрос(КонДата,КонДата,"43","20",,2,,5);
БИ.ВыбратьСубконто();
Пока БИ.получитьСубконто()=1 Цикл
Товар=БИ.Субконто();
Если БИ.ДО("К")<>0 Тогда
Количество=БИ.ДО("К");
КонецЕсли;
КонецЦикла;