Не Правильное Отображение Латинских Букв С Тильдами

swet

New member
20.03.2012
0
0
#1
Здравствуйте.
Проблема такая:
У меня Windows XP Professional

Я использую одновременно FineRider, PROMT и WORD. Перевожу тексты с испанского, итальянского языков с помощью PROMTa. В этих языках имеются буквы с тильдами и апострофами (e, а, u …). До некоторого времени отображение этих символов этими программами было правильным.

Но однажды, вдруг (примерно лето 2011 года ) эти символы стали отображаться неправильно, а именно эти символы с тильдами стали отображаться как русские й, ф, а . Представляете текст на латинице с вкраплениями русских букв. Понятно, что PROMT перестал такие тексты адекватно переводить.

Путем изучения вопроса, выяснила, что дело не в WORDe , PROMTе или Fine Ridere, а в системе. Потому что проблема появилась одновременно в этих продуктах. Тексты, созданные раньше распознаны и переведены правильно, но иностранные тексты сейчас отображаются неверно. Т.е. они закодированы верно, но отображаются не верно.

Поэтому делаю вывод, что что-то произошло либо в шрифтах системы, либо в кодировке.

Проблема появилась где-то летом 2011 года. Но поняла это только сейчас.

Проверила шрифты. Все шрифты 2009 года и старше.

Что делать? Как исправлять проблему?

В интернете нашла такое письмо от Microsoft http://support.microsoft.com/kb/332134


Там как будто решение моей проблемы, но есть сомнения. Например, я не понимаю, что такое «шрифты EDUC» и «код PUA». В интернете не смогла найти ответа на этот вопрос. Ссылок много, но они все не о смысле этих терминов.

Поэтому прошу помощи. Тот, кто понял в чем проблема и понимает смысл письма ссылки, ответьте, пожалуйста: Действительно ли в этом письме идет речь о решении моей проблемы?


Добавлено: извините,за дубли, но система выдавала ошибки и случайно продублировалсь темы.
 

swet

New member
20.03.2012
0
0
#2
Вот сама нашла решение.
Может быть кому-то еще поможет.
http://24.at.ua/publ/46-1-0-13


решение Проблемы
Пуск-выполнить
набираем там regedit
откроется редактор реестра. Там находите HKEY_LOCAL_MACHINE - SYSTEM - CurrentControlSet - Control - Nls - CodePage

Далее находим там строчку "1252"="c_1251.nls"
меняем значение с_1251.nls на с_1252.nls
перезагружаем компьютер.
Ну вот и всё ;)
это помогло