Не разпознается Http пароль пользователя

Тема в разделе "Lotus - Администрирование", создана пользователем Eugenus, 21 окт 2010.

  1. Eugenus

    Eugenus Гость

    Добрый день, уважаемые коллеги!
    Собственно ситуация - настраиваю веб-интерфейс, запустил http task, запретил SSL, запретил анонимный доступ....В браузере - форма авторизации, ввожу логин (пробовал и в обычном, и в иерархическом виде), и пароль - не авторизует (не знаю, должно ли выскакивать окно, уведомляющее о неправильных логин-пароле, в моем случае оно просто перегружается с пустой строкой пароля). В документе Person несколько раз внимательно менял пароль - все равно не авторизует (. Никаких Policy Documents не предусмотрено вообще. Кто-нибудь может подсказать варианты ?
     
  2. hosm

    hosm * so what *

    Регистрация:
    18 май 2009
    Сообщения:
    2.450
    Симпатии:
    7
    Лог сервера не смотрели? ничего интересного нет?
     
  3. Eugenus

    Eugenus Гость

    Неа, ничего нет...Сервер вообще на попытки авторизации никак не реагирует - я специально в консоль смотрю.
     
  4. ToxaRat

    ToxaRat Чёрный маг
    Lotus team

    Регистрация:
    6 ноя 2007
    Сообщения:
    3.046
    Симпатии:
    18
    не все браузеры одинаково сьедобны
    в ИЕ пробывали после смены пароля подождать 15 минут и попробывать?
     
  5. Eugenus

    Eugenus Гость

    Вы имеете в виду, что могло закэшировать ? Кэш я чистил. Ждать пробовал даже больше пятнадцати минут, пробовал и ИЕ, и Оперой, и Firefox - один черт...И еще странно - в окошке авторизации светится сообщение сервера - "/" (просто слэш в кавычках). Непонятно, что сервер пытается этим сказать...
     
  6. puks

    puks Lotus team
    Lotus team

    Регистрация:
    3 фев 2007
    Сообщения:
    1.967
    Симпатии:
    16
    Проверьте еще раз, что все настроено правильно.
     
  7. MAZ

    MAZ Гость

    Попробуйте вместо логина написать ShortName или самый нижний UserName.
     
  8. Eugenus

    Eugenus Гость

    Разобрался. Дело было в кодировке по умолчанию. Значения Default character set group установил в Cyrillic, а для группы Cyrillic установил конкретно Windows-1251. Кстати, веб-сервер домино хранит логи не в стандартном log.nsf, а в собственной базе domlog.nsf, и ее использование еще нужно указать. Собственно там я и зафиксировал неудачные попытки авторизации некоего неизвестного пользователя, чье имя состоит из кракозябр:rolleyes:
     
  9. puks

    puks Lotus team
    Lotus team

    Регистрация:
    3 фев 2007
    Сообщения:
    1.967
    Симпатии:
    16
    Не понял, а причем тут кодировка?

    У тебя имя пользователя что-ли было по-русский?
     
  10. Eugenus

    Eugenus Гость

    ) Ну в общем-то у нас все пользователи записываются по-русски)
     
  11. puks

    puks Lotus team
    Lotus team

    Регистрация:
    3 фев 2007
    Сообщения:
    1.967
    Симпатии:
    16
    Я так понимаю, что первый пост был для телепатов?
     
  12. Eugenus

    Eugenus Гость

    Нет, всего лишь для профессионалов...
     
  13. vital

    vital Больной Компом Детектед

    Регистрация:
    29 янв 2006
    Сообщения:
    2.468
    Симпатии:
    27
    А винамп удалили?
     
  14. Eugenus

    Eugenus Гость

    :) Винамп ? Вы о чем ?) Вообще-то проблема решена уже, читайте выше :)
     
  15. NetWood

    NetWood Lotus team
    Lotus team

    Регистрация:
    17 апр 2008
    Сообщения:
    308
    Симпатии:
    0
    UTF-8 - это наше все. Поставьте для документов и для форм и будет вам счастье навсегда :)
     
Загрузка...

Поделиться этой страницей