не реагирует на ВнешнееСобытие

  • Автор темы DimanYa
  • Дата начала
D

DimanYa

#1
Подскажите пожалуйста. Я уже неделю мучаюсь ничего не выходит.
Я разрабатываю небольшую конфигурацию (просто учусь на этом примере), мне нужен там сканер штрих кодов. Я попытался перенести из УТ эти обработки. Подключение сканера вроде получилось (написано, что сканер подключён),использовал стандартную 1с-кую обработку
Но не срабатывает Процедура ВнешнееСобытие.
В обычной УТ всё на ура. Что необходимо, чтобы запустилась обработка ВнешнееСобытие?
 

evgenyatam

Well-known member
07.09.2007
175
0
#2
Если Процедура ВнешнееСобытие была скопирована, то скорее всего она не подключена к форме (в восьмерке нет предопределенных процедур). Кроме того при использовании стандартной программной оснастки из УТ необходимо в ПередОткрытием или в ПриОткрытии вызвать ПодключитьКлиентаТО. Кроме того форма должна содержать экспортные процедуры с зарезервированными именами. Хороший пример - документ Чек ККМ.
 
D

DimanYa

#3
evgenyatam точно я не подключил его как Внешнее событие! Спасибо.
Это решилось, всё работает. Но я что то не понисаю как сделать, чтобы мой штрих код записался в определённое поле ввода.То есть я открываю свою форму сканирую штрих код и у меня в поле ввода "ПолеВводвШтрихКод" записалось значение считываемого штрих кода.
 

evgenyatam

Well-known member
07.09.2007
175
0
#4
например так:
Процедура ВнешнееСобытие(Источник, Событие, Данные)
Если Не ВводДоступен() Тогда
Возврат; // если не в фокусе = игнорируем все
КонецЕсли;
Если Источник<>"Сканер штрихкода" Тогда
Возврат ; // игнорируем
КонецЕсли;
Если Событие <> "ПолученШтрихкод" тогда
Возврат ;
КонецЕсли;
Штрихкод = Данные;
Если Лев(Штрихкод,1)=Символы.ПС Тогда
Штрихкод=Сред(Штрихкод,2);
КонецЕсли;
СерийныйНомер = Штрихкод;
КонецПроцедуры // ВнешнееСобытие()

СерийныйНомер - атрибут формы.
 
D

DimanYa

#5
evgenyatam спасибо ещё раз. Всё разобрался, всё работает. В регистр сведений заносится =)
И вот вопросит немного не по теме ТО.
В документе есть табличное поле. Первая колонка - ОТДЕЛ. Выбираем. И в зависимости от того, что выбрали, у нас в колонке ФАМИЛИЯ открывается соответствующая часть справочника сотрудники из уже выбранного нами группы в первой колонке...


Добавлено: Извиняюсь. Уже сам написал =)