1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

Не запускается Script Debuger

Тема в разделе "Lotus - Программирование", создана пользователем shaggyone, 10 июн 2009.

  1. shaggyone

    shaggyone Гость

    Репутация:
    0
    Доброго времени суток, уважаемые коллеги Лотусисты.

    Пытаюсь отладить агент, но, отладчик отказывается работать: Запускается, но не показывает код, кнопки Continue, Step(Into|Over|Out) погашены.

    Установили скрипты на новый сервер. Подписали всё административной id'шкой этого сервера.

    Собственно вопрос: Какие есть версии, о том в чём может быть причина и как это можно исправить?

    p.s. возможно размещаю тему не в том разделе, модераторы, не обесутьте.

    Да, дизайн никто не скрывал. Код нормально редактируется и компилируется.

    Ещё одно дополнение. Залез сейчас в домино-администратора. Со включённым дебагером. То и дело включается отладка. Код домино-администратора отображается нормально, кнопки включены и работают.

    Ещё одно дополнение, в других перенесённых базах отладка работает. ACL идентичный, распространялся копипастом.

    Создал новый агент, в той же базе. На нём отладка работает ;) .
     
  2. azat20

    azat20 Well-Known Member

    Репутация:
    0
    Регистрация:
    22 июл 2008
    Сообщения:
    244
    Симпатии:
    0
    Видимо там что-то вылезло типа окна, в котором надо что-то выбрать. Вот и кнопки неактивны. как правило, дебаггер надо включать за одно действие до начала просматриваемого
     
  3. shaggyone

    shaggyone Гость

    Репутация:
    0
    Ничего не вылазит. Активны кнопки "Закрыть дебагер" и "Стоп"

    Всё, разобрался. Возникала ошибка в коде инициализации библиотек...

    **** Много мата ****
    Блин, ну неужто так трудно было сделать так, чтобы дебагер сразу стартовал. 2 часа, блин, убил.
    **** Ещё много мата ****
     
  4. Akupaka

    Akupaka А че я?.. О.о

    Репутация:
    0
    Регистрация:
    4 окт 2007
    Сообщения:
    3.360
    Симпатии:
    2
    тю... это еще фигня... у меня вон когда-то дивный глюк был... тоже много времени убил, не помню как полечилось, видимо, голова плохое забывает ))
    короче, обычный док, все права были на него, скрипт меняет значение поля. так вот, в дебагере работает, меняет, а в нормальном исполнении не меняет ;)
     
  5. shaggyone

    shaggyone Гость

    Репутация:
    0
    Агент, случаем, не серверный был?
     
  6. Akupaka

    Akupaka А че я?.. О.о

    Репутация:
    0
    Регистрация:
    4 окт 2007
    Сообщения:
    3.360
    Симпатии:
    2
    это мне вопрос? о,О
    а где был агент? был скрыпт на кнопке формы ))
     
  7. medin84

    medin84 Well-Known Member

    Репутация:
    0
    Регистрация:
    27 июн 2007
    Сообщения:
    106
    Симпатии:
    0
    тоже было такое дело, не понял от чего так
    правда потом как то решилось толи рекомпилил толи другое делал не помню
     
Загрузка...
Похожие Темы - Не запускается Script
  1. Lustrator
    Ответов:
    16
    Просмотров:
    141
  2. erlan1749
    Ответов:
    0
    Просмотров:
    42
  3. Avldokuchaev
    Ответов:
    4
    Просмотров:
    312
  4. Cryfier
    Ответов:
    2
    Просмотров:
    236
  5. t0ss1
    Ответов:
    11
    Просмотров:
    541

Поделиться этой страницей