Ненулевые сальдо на конец по 2 счетам

Тема в разделе "1C и всё что с ней связано", создана пользователем Elle, 30 мар 2010.

Статус темы:
Закрыта.
  1. Elle

    Elle Гость

    Код (Text):
        Ит.ВыбратьСубконто(ВидыСубконто.Контрагенты);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Контрагенты) = 1 Цикл
    Контрагент=Ит.Субконто(ВидыСубконто.Контрагенты);
    Ит.ВыбратьСчета();
    к_скд="";
    к_скк="";
    к_скд_к="";
    к_скк_к="";
    Пока Ит.ПолучитьСчет()=1 Цикл

    Если Ит.Счет.Код=сч_1 Тогда
    к_скд=Формат(Ит.СКД(),"Ч014.2.,");
    к_скк=Формат(Ит.СКК(),"Ч014.2.,");
    Иначе
    к_скд_к=Формат(Ит.СКД(),"Ч014.2.,");
    к_скк_к=Формат(Ит.СКК(),"Ч014.2.,");
    КонецЕсли;
    КонецЦикла;
    Если (к_скд<>0) И (к_скк_к<>0) Тогда

    Т.ВывестиСекцию("Секция_2");
    Иначе
    Продолжить;
    КонецЕсли;
    Ит.ВыбратьСубконто(ВидыСубконто.Договора);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Договора) = 1 Цикл
    Договор=Ит.Субконто(ВидыСубконто.Договора);
    Ит.ВыбратьСчета();
    д_скд="";
    д_скк="";
    д_скд_к="";
    д_скк_к="";

    Пока Ит.ПолучитьСчет()=1 Цикл
    Если Ит.Счет.Код=сч_1 Тогда
    д_скд=Формат(Ит.СКД(),"Ч014.2.,");
    д_скк=Формат(Ит.СКК(),"Ч014.2.,");
    Иначе
    д_скд_к=Формат(Ит.СКД(),"Ч014.2.,");
    д_скк_к=Формат(Ит.СКК(),"Ч014.2.,");
    КонецЕсли;
    КонецЦикла;
    Т.ВывестиСекцию("Секция_5")

    КонецЦикла;
    КонецЦикла;
    Нужно выводить только тех контрагентов в которых есть по двум счетам сальдо на конец. А выводит всех контрагентов. На что сменить условие отбора?
     
  2. Hryv

    Hryv Гость

    Попробуйте вместо
    ="";
    везде написать
    =0;

    А вообще алгоритм какой-то мутный
    Хотя может это только кажется, потому-что не видно, что осталось за кадром
     
  3. Elle

    Elle Гость

    я уже так пробовала - отображает всех контрагентов!!!
     
  4. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Ну, вот такое условие точно не работает
    уж тогда надо
    Если (ПустоеЗначение(к_скд) =0) И (ПустоеЗначение(к_скк_к) = 0) Тогда
     
  5. Elle

    Elle Гость

    Таки Вы правы)))) спасибо - работает)))
     
  6. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Правильно Vitfil ругает неявное объявление типов в 1С.
    Вот отсюда и сравнение непустой строки с числом 0 :discard:
    Конечно, она никогда не будет равна 0 :bequiet:
     
Загрузка...
Похожие Темы - Ненулевые сальдо на
  1. Дайнеко
    Ответов:
    0
    Просмотров:
    1.115
  2. Natalya
    Ответов:
    6
    Просмотров:
    3.549
Статус темы:
Закрыта.

Поделиться этой страницей