непонятное сообщение НННН<<?>>()

Тема в разделе "1C и всё что с ней связано", создана пользователем binx, 12 мар 2008.

  1. binx

    binx Гость

    Запрос1 = СоздатьОбъект("Запрос");
    ТекстЗапроса1 =
    "
    |Период С НачДата По КонДата;
    |Обрабатывать НеПомеченныеНаУдаление;
    |ОбрабатыватьДокументы Все;
    |Контр = Документ.РеализацияПродукции.Контрагент;
    |Отгружен = Документ.РеализацияПродукции.Отгружен;
    |Товар = Документ.РеализацияПродукции.Товар;
    |Количество = Документ.РеализацияПродукции.Количество;
    |Вес = Документ.РеализацияПродукции.Товар.ВесИзделия;
    |ВсегоСумма = Документ.РеализацияПродукции.Всего;
    |Функция КолРеализация = Сумма(Количество*Вес/1000);
    |Функция СумРеализация = Сумма(ВсегоСумма);
    |Группировка Товар;
    |Условие(Отгружен = 1);
    |"//}}Запрос
    ;
    Если Запрос1.Выполнить(ТекстЗапроса1) = 0 Тогда

    Возврат;

    КонецЕсли;
    Сум=0;
    Кол=0;
    СумДр=0;
    КолДр=0;
    Пока Запрос1.Группировка("Товар")=1 Цикл
    Если СокрЛП(Запрос1.Товар.Родитель.Наименование)=СокрЛП("Хлебобулочные изделия") Тогда
    Если (Найти(СокрЛП(Запрос1.Товар.Наименование),СокрЛП("Хлеб пшеничный Кишиневский 0,65 кг")))>0 Тогда
    Сум=Запрос1.СумРеализация;
    Кол=Запрос1.КолРеализация;
    Иначе
    СумДр=СумДр+Запрос1.СумРеализация;
    КолДр=КолДр+Запрос1.КолРеализация;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;

    /////////////////////////////////////////////////////////////////////////////////////////////////////////////
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "
    |Период С НачДата По КонДата;
    |Обрабатывать НеПомеченныеНаУдаление;
    |ОбрабатыватьДокументы Все;
    |Контр = Документ.РеализацияПродукции.Контрагент;
    |Отгружен = Документ.РеализацияПродукции.Отгружен;
    |Товар = Документ.РеализацияПродукции.Товар;
    |Количество = Документ.РеализацияПродукции.Количество;
    |Вес = Документ.РеализацияПродукции.Товар.ВесИзделия;
    |ВсегоСумма = Документ.РеализацияПродукции.Всего;
    |Функция КолРеализация = Сумма(Количество*Вес/1000);
    |Функция СумРеализация = Сумма(ВсегоСумма);
    |Группировка Товар;
    |Условие(Отгружен = 1);
    |"//}}Запрос
    ;
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    // Возврат;
    КонецЕсли;

    Пока Запрос.Группировка("Товар") = 1 Цикл
    Товар = Запрос.Товар;
    Если Товар.ЭтоГруппа() = 1 Тогда
    Если СокрЛП(Запрос.Товар.Наименование)=СокрЛП("Хлебобулочные изделия") Тогда
    //ТЗ.НоваяСтрока();
    //ТЗ.Группа = Товар;
    //ТЗ.КолРеализация = Запрос.КолРеализация;
    //ТЗ.СумРеализация = Запрос.СумРеализация;
    ТЗ.НоваяСтрока();
    ТЗ.Группа= "Хлеб пшеничный Кишиневский 0,65 кг";
    ТЗ.СумРеализация = Сум;
    ТЗ.КолРеализация=Кол;
    ТЗ.НоваяСтрока();
    ТЗ.Группа="Другие хлебобулочные изделия";
    ТЗ.СумРеализация = СумДр;
    ТЗ.КолРеализация=КолДр;
    Иначе
    ТЗ.НоваяСтрока();
    ТЗ.Группа = Товар;
    ТЗ.КолРеализация = Запрос.КолРеализация;
    ТЗ.СумРеализация = Запрос.СумРеализация;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    ///////////////////////////////////////////////////////
    //Отчет
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Заголовок");
    ай=1;
    Тз.ВыбратьСтроки();
    Пока Тз.ПолучитьСтроку()=1 Цикл
    Таб.ВывестиСекцию("Строка");
    //Ошибка возникает здесь для каждой строки
    ай=ай+1;
    КонецЦикла;
    Таб.ВывестиСекцию("Итого");
    Таб.ТолькоПросмотр();
    Таб.Показать("Выпуск продукции");
    КонецПроцедуры
    Выводится 2 колонки ТЗ.КолРеализация и ТЗ.СумРеализация как Выражение
    Полный текст ошибки
    Функция не обнаружена (НННН) НННН<<?>>()
    НННН<<?>>()
     
  2. LSH

    LSH Гость

    Покопайтесь в ячейках таблицы. Где-то там зашита эта функция.
     
  3. binx

    binx Гость

    Свами согласен на все 100, но в этом то и вопрос, что в колонках всего две выражения и я их выше указал, но почему он матерится??????
     
  4. LSH

    LSH Гость

    Неее, смотрите в поле "Расшифровка" в свойствах ячейки таблицы.
     
Загрузка...

Поделиться этой страницей