Неправильное Отображение Русских Букв

Мыш

Премиум
12.02.2008
1 097
10
#1
Всем привет. Обновил на свою голову клиента у пользователя (до 9.0.1 англ. стандартного). Сервер - 8.5.3.
Юзер открывает старую базу (делалась в 4.х - 5.х) и видит в заголовке одной колонки русские буквы, в другой - сплошные квадратики.
Надписи на кнопках действий и само содержание вида отображаются норм.
В самих документах - сплошные квадратики.
В дизайнере в обоих заголовках вида указан шрифт Helv. Выгрузил в DXL - все нормально, все читается по-русски. Св-ва колонок практически идентичны.
Поставил по старой памяти Unicode_Display=1, не помогло.
Подскажите, пожалуйста, это мне одному так крупно повезло? :eek:oo: С клиентами 8.5 подобных проблем не было.
ЗЫ. Виды и формы я, конечно, переделаю, но их фигова туча...
ЗЗЫ. Web-плагин тоже криво отображает....
 

lmike

нет, пердело совершенство
Lotus team
27.08.2008
6 586
272
#2
это попытка виндозного клиента отображать UTF-8 в вин1251, как я это понимаю
у меня есть и виндовые клиенты 9.0.1 и сервант 8.5.3 и язык русский на формах (разрабатывались в 6.5+ версиях), единственно - никогда не приходило в голову менять шрифт на отличный от системного (для нотусни - default sans serif), отображают нормально
 

Мыш

Премиум
12.02.2008
1 097
10
#3
lmike, наскока я помню (могу ошибаться), Default Sans Serif - как шрифт по умолчанию в Дизайнере - появился как раз в 6.x. Моя база 146% делалась раньше. Простой телефонный справочник, для работы только из клиента, никаких изысков - виды и формы. Как грицца - "слюшай, абыдна, да?!" (с) ;)
ЗЫ. С такими делами мне стремно уже и дизайн править из 9-ки. Допустим, поправлю я шрифты - а если старые клиенты (6.х, 7.х) перестанут отображать? У мну их есть, и апргрейдить всех срочно - ну нереально. Люди-то работают, ни на что не жалуются... пока еще :)