Статья Nettacker - Auto Pentest Framework

Vander

CodebyTeam
Администратор
16.01.2016
1 103
2 883
#1
Привет! Хочу сделать небольшой обзор на инструмент, целью которого является автоматизация процесса получения доступа к выбранному вами ресурсу, посредством проведения брутфорс-атаки, сканирования доменов и подсетей.

upload_2017-5-18_21-37-20.png

Собственно, Nettacker:

Установка: (Kali Linux 2017.1)

> git clone
Для просмотра контента необходимо: Войти или зарегистрироваться


upload_2017-5-18_21-38-6.png

> cd Nettacker

> pip install –r requirements.txt

upload_2017-5-18_21-38-25.png

> chmod +x nettacker.py

> ./nettacker.py

Справка:

> ./nettacker.py –h

upload_2017-5-18_21-38-53.png

Пример запуска
(
с опцией брутфорс-атаки):

> ./nettacker.py –targets=example.com –method=ssh_brute –ports=22 –usernames=admin –passwords=admin


upload_2017-5-18_21-39-32.png

Возможно, кому-то пригодится. Спасибо.
 

tabacci

New member
17.09.2017
2
0
#2
в "обзоре" мало того что с синтаксической ошибкой пример запуска написан, так еще и внушается мысль, что это еще одна брутилка. на самом деле фишка nettacker, что он для интернета вещей сканер и если уж писать пример то хотя бы про метод scada_scan, который на скриншоте виднеется.
 

WebWare Team

Администратор
30.12.2015
1 678
2 080
#3
в "обзоре" мало того что с синтаксической ошибкой пример запуска написан
Было бы здорово увидеть в чем ошибка и как надо правильно написать. А вот о чем писать - решать автору.
 
02.03.2018
12
2
#4
заного установил вчера кали свежую, как это решить?
Код:
~/pentest/Nettacker# pip install –r requirements.txt
Invalid requirement: '–r'
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/req/req_install.py", line 82, in __init__
    req = Requirement(req)
  File "/usr/share/python-wheels/packaging-17.1-py2.py3-none-any.whl/packaging/requirements.py", line 97, in __init__
    requirement_string[e.loc:e.loc + 8]))
InvalidRequirement: Invalid requirement, parse error at "'\xe2\x80\x93r'"
 
10.03.2018
6
2
#5
заного установил вчера кали свежую, как это решить?
Код:
~/pentest/Nettacker# pip install –r requirements.txt
Invalid requirement: '–r'
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/req/req_install.py", line 82, in __init__
    req = Requirement(req)
  File "/usr/share/python-wheels/packaging-17.1-py2.py3-none-any.whl/packaging/requirements.py", line 97, in __init__
    requirement_string[e.loc:e.loc + 8]))
InvalidRequirement: Invalid requirement, parse error at "'\xe2\x80\x93r'"
перед аргументом r самому прописать дефис, а не просто копировать команду...