Номер документа

Тема в разделе "1C и всё что с ней связано", создана пользователем Abi, 20 мар 2008.

  1. Abi

    Abi Гость

    Всем доброго времени суток!
    Если не сложно - помогите разобраться с механизмом работы метода "найти"
    В целом модуль присваивает номер документу (ном).
    Что конкретно она делает в данном фрагменте?

    Документ=СоздатьОбъект("Документ.Приход");
    Ном=0;
    Док.ВыбратьДокументы(ДатаДок,ДатаДок);
    Пока Док.ПолучитьДокумент()=1 Цикл
    Ф=Найти(Док.НомерДок,"/");
    Если Ф<>0 Тогда
    Ном1=Число(Прав(Док.НомерДок,СтрДлина(Док.НомерДок)-Ф));
    Если Ном1>Ном Тогда
    Ном=Ном1;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    Ном=Ном+1;

    Номера документов имеют вид: 123/1, 123/2, 123/3, ... 123/12 и т.д.

    Остальное вроде поняла....
     
  2. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Не сложно:
    Код (Text):
    Найти(<?>,)
    Синтаксис:
    Найти(<Строка1>,<Строка2>)
    Назначение:
    Возвращает позицию первого вхождения в строку поиска заданной подстроки.
    Параметры:
    <Строка1> - строка в которой ищем (место поиска);
    <Строка2> - строка которую ищем (шаблон поиска).
    Замечание:
    Если не находит - возвращает число 0.
    Первая позиция имеет индекс 1.
    Конкретно - "она" - в данном фрагменте ищет символ "/". Если находит, выполняет определенные действия.
     
  3. Abi

    Abi Гость

    бОЛЬШОЕ СПАСИБО!
     
Загрузка...

Поделиться этой страницей