Новичок: ошибка при работе с таблицой значений

  • Автор темы Sergenaro
  • Дата начала
S

Sergenaro

Гость
#1
Не пойму, почему ошибку выдает...

Процедура ОсновныеДействияФормыДействие(Кнопка)
Количество_Строк = ЭлементыФормы.ЧислоСтрок.Значение;
Если Количество_Строк<=0 Тогда
Сообщить("Количество строк должно быть положительным числом")
КонецЕсли;
тз_Превая_Таблица=ЭлементыФормы.ПерваяТаблица.Данные;
Для Ъ_Строки=1 По Количество_Строк Цикл
Новая_Строка = тз_Превая_Таблица.Добавить(); // вот здесь ошибка
КонецЦикла;
КонецПроцедуры
 
M

Mirage

Гость
#2
Новая_Строка = тз_Превая_Таблица.Добавить(); // вот здесь ошибка

Текст ошибки можно?
 
T

thinkfast

Гость
#3
Если это 8ка и ПерваяТаблица это ТЧ документа то:
вместо
тз_Превая_Таблица=ЭлементыФормы.ПерваяТаблица.Данные;
сделай
тз_Превая_Таблица=ЭлементыФормы.ПерваяТаблица.Выгрузить();

Или проверь какой тип данных будет у тз_Превая_Таблица, думаю не таблицаЗначений, поэтому *.Добавить() не применимо.
Новая_Строка = тз_Превая_Таблица.Добавить(); // вот здесь ошибка

Напишите платформу и текст ошибки.
 
S

Sergenaro

Гость
#4
ПерваяТаблица - это табличное поле

Вот что выдает:

{Обработка.Задача1.Форма.Форма(13)}: Значение не является значением объектного типа (Добавить)
Новая_Строка = тз_Превая_Таблица.Добавить();
 
S

Sergenaro

Гость
#6
Да...Ошибся...Грамматическая ошибка)
 
S

Sergenaro

Гость
#10
Платформа 1С 8, версия для обучения программированию...И все таки не пойму в чем ошибка?
 
K

kaa

Гость
#11
тз_Превая_Таблица=ЭлементыФормы.ПерваяТаблица.Значение;
Для Ъ_Строки=1 По Количество_Строк Цикл
Новая_Строка = тз_Превая_Таблица.Добавить(); // вот здесь ошибка
КонецЦикла;


А если так
 

Гость
#12
ПОМОГИТЕ ПОЖАЛУЙСТА РАЗОБРАТЬ ОШИБКУ , ЧТО НУЖНО ЗДЕЛАТЬ ПОДСКАЖИТЕ ???


{Справочник.ИностранныеСпециалисты.Форма.ФормаЭлемента(83,33)}: Переменная не определена
(НастройкаПравДоступа)
ФормаРегистра.Период = Макс(<<?>>НастройкаПравДоступа.ПолучитьПервуюДатуДоступногоПериода(), '19000101');
 
S

Sergenaro

Гость
#13
тз_Превая_Таблица=ЭлементыФормы.ПерваяТаблица.Значение;
Для Ъ_Строки=1 По Количество_Строк Цикл
Новая_Строка = тз_Превая_Таблица.Добавить();
КонецЦикла;

Хорошо...Вроде работает без ошибок. Но почему в табличном поле не отображаются добавленные строки?
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#14
Справочник.ИностранныеСпециалисты.Форма.ФормаЭлемента(83,33)}: Переменная не определена
(НастройкаПравДоступа)
ФормаРегистра.Период = Макс(<<?>>НастройкаПравДоступа.ПолучитьПервуюДатуДоступногоПериода(), '19000101');
по моему и так понятно написанно - Переменная не определена
 
K

kaa

Гость
#15
тз_Превая_Таблица=ЭлементыФормы.ПерваяТаблица.Значение;
Для Ъ_Строки=1 По Количество_Строк Цикл
Новая_Строка = тз_Превая_Таблица.Добавить();
КонецЦикла;
ЭлементыФормы.ПерваяТаблица.Значение = тз_Превая_Таблица;
 
S

Sergenaro

Гость
#16
Все равно не отбражаются строки в табличном поле...
 
S

Sergenaro

Гость
#18
Да, цикл работает...

Добавлено: Вообще, табличные поля должны работать в 1С 8 Версия для изучения программирования? Может в этом проблема?