нужна помощ

Тема в разделе "1C и всё что с ней связано", создана пользователем grifon, 14 фев 2008.

Статус темы:
Закрыта.
  1. grifon

    grifon Гость

    раз в месяц формирует книга продаж и книга покупок (Журналы---регламентируемые документы)
    за январь месяц немогу корректно сформировать книгу продаж в нее попадают не все "выданные счет-фактуры" а точнее почемуто только по 19 января (счет-фактуры имеются еще и за 31 января)
    при попытки заполнить книгу продаж высвечивает ошибку: "ИначеЕсли (ДатаДок >= НачалоГода2006) и ((СФ.СчетНДС = 1) или (СФ.ДатаДок >= НачалоГода2006)) Тогда
    {Документ.ЗаписиКнигиПродаж.Форма.Модуль(1134)}: Операции сравнения на больше-меньше допустимы только над значениями совпадающих базовых типов (число, строка, дата)

    " помогите что нужно сделать и вобще в чем корень ошибки и как ее исправить
     
  2. Zab

    Zab Well-Known Member
    1C Team

    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    Проверь отладчиком, что у тебя в переменных. СФ.СчетНДС - типа чило? ДатаДок - заполнена?
    Я в таких случаях, сначала анализирую в какой части условия возникает ошибка. Просто раздожи его на 3 Если-КонецЕсли; с пустым телом, чтобы знать, какое именно сравнение выбрасывает ошибку:
    т.е.
    Если (ДатаДок >= НачалоГода2006) Тогда
    КонецЕсли;
    Если (СФ.СчетНДС = 1) Тогда
    КонецЕсли;
    Если (СФ.ДатаДок >= НачалоГода2006) Тогда
    КонецЕсли;
    Посмотри, на какую строку ругнется, и изучай внимательно тип переменной в этом условии
     
  3. Isabela

    Isabela Гость

    Мне с этим доводилось сталкиваться не один раз, впервые еще в версии 474. Отчего это фуфло вылезает - непонятно, не заморачиваясь, переделываешь ДатаДок в Дата(ДатаДок) и т.п. и все живет.
    Кстати, периодически не работают сравнения типа Если к = 1... В отладчике смотришь - все совпадает, но не сравнивается. Однажды прищлось только так обойти :
    Число(к) = Число(1). Бред, конечно, но как иначе справиться ?
     
  4. grifon

    grifon Гость

    спасибо всем за инфу!!!
     
  5. grifon

    grifon Гость

    вобщем наконецто разобрался с этой проблемой но теперь появилось другая если есть возможность поделитесь опытом как из нее выкручиваться:
    вопрос касается ЗиК 7,70,275 конфа открывая карточку сотрудника жму на ввод данных и выбираю сформировать карточку 1 НДФЛ высвечивается надпись что за 2008 год формирование карточек неподдерживается!
    как от этого избавится? исчезнет ли эта проблема после обновления до 7,70,281 (последнее обновление)?
    где достать чистую конфу 275 чтобы сравнить и узнать где менялся код чтоб его перенести в новую(коментарии в коде не оставлялись)?
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей