Нужна помощь

Тема в разделе "1C и всё что с ней связано", создана пользователем Vilgelm, 31 июл 2009.

  1. Vilgelm

    Vilgelm Гость

    Собственно я пока тока изучаю 1с... мне надо написать обработку на 1с которая: Берет Тхт файл и загружает его в справочник (Например:контрагенты)
    обработка для Бух 7.7... Если можно с пояснениями... чтоб я понял откуда там чего....
     
  2. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Вот тебе первый толчок :
    Строка текстового файла может выглядеть, например, так :
    Название контрагента/Адрес/Телефон/...
    Берешь первую строку, ищешь в справочнике "Контрагенты" название (НайтиПоНаименованию), если не нашел - создаешь новый элемент справочника и заполняешь его реквизиты.
    Потом аналогично обрабатываешь следующую строку и т.д.
    А значит, появляется повод почитать ЖКК.
     
  3. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Если надо - пиши, нет ничего сложного да и тут на форуме уже обсуждалась работа с файлами причем с примерами. а вот когда появится реальная проблема (делаю то-то то-то и у меня не получается такая штучка...) - тогда пиши и попробуем помочь...
     
  4. Vilgelm

    Vilgelm Гость

    Спс... за ответы.. сейчас погляжу...
     
  5. Allexei

    Allexei Well-Known Member

    Регистрация:
    2 май 2008
    Сообщения:
    322
    Симпатии:
    0
    Посмотри, может поможет:
    Код (Text):
    Функция ВозвратЗначения(стрЗначений)
    //К примеру имеет формат Код/Наименование/Адрес/..../Телефон   
    //Возвратит список значений в соответствии с которым будет заполнен справочник
    спс= СоздатьОбъект("СписокЗначений");
    Пока Найти(стрЗначений,"/")<>0 Цикл  
    спс.ДобавитьЗначение(Сред(стрЗначений,1, Найти(стрЗначений,"/")-1)); 
    стрЗначений= Прав(стрЗначений,СтрДлина(стрЗначений)-Найти(стрЗначений,"/"));
    КонецЦикла;
    Возврат спс;  
    КонецФункции

    Процедура Сформировать()
    Текст= СоздатьОбъект("Текст");
    спрКонт= СоздатьОбъект("Справочник.Контрагенты");
    Текст.Открыть("C:\Kontr.txt");  

    Для Й= 1 По Текст.КоличествоСтрок() Цикл
    спс= ВозвратЗначения(Текст.ПолучитьСтроку(Й));
    Если спрКонт.НайтиПоКоду(спс.ПолучитьЗначение(1))<>0 Тогда
    Продолжить;  
    КонецЕсли;

    спрКонт.Новый();
    спрКонт.Код        = спс.ПолучитьЗначение(1);
    спрКонт.Наименование = спс.ПолучитьЗначение(2);
    спрКонт.Адрес       = спс.ПолучитьЗначение(3);
    //.....................
    спрКонт.Телефон    = спс.ПолучитьЗначение(10);
    спрКонт.Записать();
    КонецЦикла;
    КонецПроцедуры
     
Загрузка...

Поделиться этой страницей