Nxrtf - проблема со спецсимволами

Omh

Well-Known Member
Lotus team
04.07.2007
2 210
1
#1
Гуру, привет!

Проблема возникла.
Используется ф-ия из nxrtf.dll, та которая ExportRTF.

Вот она гробит спецсимволы лат. языка: там всякие чёрточки/палочки под/над буквами.
Никто не сталкивался с такой проблемой и её решением?
Спасибо.

Проблемна наблюдается под 702, под восьмой веткой вроде всё в порядке.
В то время как у коллеги на соседнем компе и в 7-ой ветке всё неплохо.

Ф-ия для меня новая, поэтому пока не особо понимаю, что она делает.
Переводит RICHTEXT в RTF формат, как я понял.
 

hosm

* so what *
18.05.2009
2 442
9
#2
в качестве идеи - может, влияют настройки языка клиента User Preferences- International?
SETTING PREFERENCES

To change how Notes translates characters

When you import or export files, you can specify the character translation file Notes uses to translate characters, such as international currency symbols, in the files.
1. From the menu, choose File - Preferences - User Preferences.
Macintosh OS X users: Notes - Preferences - User Preferences.
2. Click International.
3. Click the Change button for "Import/Export characters."
4. Select a character set and click OK.
 

Omh

Well-Known Member
Lotus team
04.07.2007
2 210
1
#3
OKEN
Помогло, у меня там албанский стоял :)
Благодарствую!