Обмен данными с кристалл Setretail 5

SeverBap

Well-known member
18.09.2007
451
0
#1
Подскажите, как написать отчет по получению данных за один час (нужно получитть количество чеков и общую сумму продажи) из кристалла?
посмотрел примеры в руководстве по обмену данными меня просто запутало все!
как я понял там нужно получить неонлайновые отчеты через интерфейс IOperDay.
кто нибудь такое мутил?
 

SeverBap

Well-known member
18.09.2007
451
0
#2
Написал пока такое:
Код:
Сообщить("Получение данных из кристалл сет"); 
Если Не КристалСетЗагружен Тогда
Сообщить("Режим файловый! - продолжение не возможно!",СтатусСообщения.ОченьВажное);
Возврат;
КонецЕсли;
МоментаОтчета=НачалоДня(НачПериода);
Пока МоментаОтчета<=КонецДня(КонПериода) Цикл
Состояние(Строка(МоментаОтчета));
МоментаОтчета=МоментаОтчета+3600;
ОперацииДанными=КристалСет.Operday[МоментаОтчета];
Если Не ОперацииДанными.Ready Тогда
Прервать;
КонецЕсли;
Сообщить(Строка(ОперацииДанными.RepChequePos(Ложь) ));
КонецЦикла;
 

SeverBap

Well-known member
18.09.2007
451
0
#3
Нашел руководство которое может помочь в написании
Для просмотра контента необходимо: Войти или зарегистрироваться
с страницы 52 все расмотрено но почему то у меня выдает ошибку в строке:
Код:
ОперацииДанными=КристалСет.Operday[МоментаОтчета];