Обмен данными с кристалл Setretail 5

Тема в разделе "1C и всё что с ней связано", создана пользователем SeverBap, 26 окт 2009.

  1. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    Подскажите, как написать отчет по получению данных за один час (нужно получитть количество чеков и общую сумму продажи) из кристалла?
    посмотрел примеры в руководстве по обмену данными меня просто запутало все!
    как я понял там нужно получить неонлайновые отчеты через интерфейс IOperDay.
    кто нибудь такое мутил?
     
  2. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    Написал пока такое:
    Код (Text):
    Сообщить("Получение данных из кристалл сет");
    Если Не КристалСетЗагружен Тогда
    Сообщить("Режим файловый! - продолжение не возможно!",СтатусСообщения.ОченьВажное);
    Возврат;
    КонецЕсли;
    МоментаОтчета=НачалоДня(НачПериода);
    Пока МоментаОтчета<=КонецДня(КонПериода) Цикл
    Состояние(Строка(МоментаОтчета));
    МоментаОтчета=МоментаОтчета+3600;
    ОперацииДанными=КристалСет.Operday[МоментаОтчета];
    Если Не ОперацииДанными.Ready Тогда
    Прервать;
    КонецЕсли;
    Сообщить(Строка(ОперацииДанными.RepChequePos(Ложь) ));
    КонецЦикла;
     
  3. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    Нашел руководство которое может помочь в написании Руководство по обмену данными с страницы 52 все расмотрено но почему то у меня выдает ошибку в строке:
    Код (Text):
    ОперацииДанными=КристалСет.Operday[МоментаОтчета];
     
Загрузка...

Поделиться этой страницей