ОбработкаОжидания

Тема в разделе "1C и всё что с ней связано", создана пользователем Helena, 13 мар 2009.

  1. Helena

    Helena Гость

    Подскажите, пжл, почему не срабатывает ОбработкаОжидания() с указанным интервалом? Отрабатывается только в первый раз, потом нет.

    Функция глЗавершитьРаботу()
    КатИБ = КаталогИБ() + "\";

    Если ФС.СуществуетФайл(КатИБ + "ExitAll.txt") = 1 Тогда
    Текст = СоздатьОбъект("Текст");
    Текст.Открыть(КатИБ + "ExitAll.txt");

    Стр = "";
    Разделитель = "";

    Для Сч = 1 по Текст.КоличествоСтрок() Цикл
    Стр = Стр + Разделитель + СокрЛП(Текст.ПолучитьСтроку(Сч));
    Разделитель = РазделительСтрок;
    КонецЦикла;

    Сообщить(Стр, "i");

    ОбработкаОжидания("глОжидание",20);

    Иначе
    ОбработкаОжидания("глОжидание",60);
    КонецЕсли;

    Если ФС.СуществуетФайл(КатИБ + "ExitAll.dbf") = 1 Тогда
    Возврат 1;
    КонецЕсли;

    Возврат 0;
    КонецФункции // глЗавершитьРаботу

    //*************************************************************************
    //
    Процедура глОжидание()

    Если глЗавершитьРаботу() = 1 Тогда
    СохранитьЗначение("НеЗапрашиватьПодтверждениеПриВыходе", 1);
    ЗавершитьРаботуСистемы(0);
    Возврат;
    КонецЕсли;

    КонецПроцедуры //глОжидание

    Тема закрыта. Нашла ошибку :)
     
  2. kaa

    kaa Гость

    должно находится в теле глобального модуля
     
Загрузка...
Похожие Темы - ОбработкаОжидания
  1. Paume
    Ответов:
    7
    Просмотров:
    3.818

Поделиться этой страницей