1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

ОбработкаОжидания

Тема в разделе "Базы данных и администрирование", создана пользователем Helena, 13 мар 2009.

  1. Helena

    Helena Гость

    Репутация:
    0
    Подскажите, пжл, почему не срабатывает ОбработкаОжидания() с указанным интервалом? Отрабатывается только в первый раз, потом нет.

    Функция глЗавершитьРаботу()
    КатИБ = КаталогИБ() + "\";

    Если ФС.СуществуетФайл(КатИБ + "ExitAll.txt") = 1 Тогда
    Текст = СоздатьОбъект("Текст");
    Текст.Открыть(КатИБ + "ExitAll.txt");

    Стр = "";
    Разделитель = "";

    Для Сч = 1 по Текст.КоличествоСтрок() Цикл
    Стр = Стр + Разделитель + СокрЛП(Текст.ПолучитьСтроку(Сч));
    Разделитель = РазделительСтрок;
    КонецЦикла;

    Сообщить(Стр, "i");

    ОбработкаОжидания("глОжидание",20);

    Иначе
    ОбработкаОжидания("глОжидание",60);
    КонецЕсли;

    Если ФС.СуществуетФайл(КатИБ + "ExitAll.dbf") = 1 Тогда
    Возврат 1;
    КонецЕсли;

    Возврат 0;
    КонецФункции // глЗавершитьРаботу

    //*************************************************************************
    //
    Процедура глОжидание()

    Если глЗавершитьРаботу() = 1 Тогда
    СохранитьЗначение("НеЗапрашиватьПодтверждениеПриВыходе", 1);
    ЗавершитьРаботуСистемы(0);
    Возврат;
    КонецЕсли;

    КонецПроцедуры //глОжидание

    Тема закрыта. Нашла ошибку :)
     
  2. kaa

    kaa Гость

    Репутация:
    0
    должно находится в теле глобального модуля
     
Загрузка...
Похожие Темы - ОбработкаОжидания
  1. Paume
    Ответов:
    7
    Просмотров:
    3.923

Поделиться этой страницей