Обращение к БухИтогам

Тема в разделе "1C и всё что с ней связано", создана пользователем Helena, 20 фев 2008.

  1. Helena

    Helena Гость

    Почему когда передаю один счет, кол-во БИ_МЦ.СКД("К") считается
    БИ_МЦ.ВыполнитьЗапрос(,ВыбКонПериода, "МЦ.07",,,,, "К");

    а вот так не считается
    БИ_МЦ.ВыполнитьЗапрос(,ВыбКонПериода, "МЦ.01,МЦ.02,МЦ.04,МЦ.05,МЦ.06,МЦ.07",,,,, "К");
     
  2. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Все субсчета "МЦ" количественные?
    Может, перед запросом есть ИспользоватьСубконто?
     
  3. Helena

    Helena Гость

    Все количественные
    Вообще, дело обстоит так...

    БИ_МЦ = СоздатьОбъект("БухгалтерскиеИтоги");
    БИ_МЦ.ИспользоватьСубконто(ВидыСубконто.Материалы);
    БИ_МЦ.ИспользоватьСубконто(ВидыСубконто.Сотрудники);
    БИ_МЦ.ВыполнитьЗапрос(,ВыбКонПериода, "МЦ.01,МЦ.02,МЦ.04,МЦ.05,МЦ.06,МЦ.07",,,,, "К");

    БИ_МЦ.ВыбратьСубконто(1);
    Пока БИ_МЦ.ПолучитьСубконто(1)=1 Цикл
    ТЗ.НоваяСтрока();
    ТЗ.Материал = Строка(БИ_МЦ.Субконто(1));
    БИ_МЦ.ВыбратьСубконто(2);
    БИ_МЦ.ПолучитьСубконто(2);
    ТЗ.Сотр = Строка(БИ_МЦ.Субконто(2));
    ТЗ.Количество = Число(БИ_МЦ.СКД("К"));
    КонецЦикла;
     
  4. kaa

    kaa Гость

    <!--QuoteBegin-Helena+20:02:2008, 23:55 -->
    <span class="vbquote">(Helena @ 20:02:2008, 23:55 )</span><!--QuoteEBegin-->БИ_МЦ.ВыполнитьЗапрос(,ВыбКонПериода, "МЦ.01,МЦ.02,МЦ.04,МЦ.05,МЦ.06,МЦ.07",,,,, "К");
    [snapback]98943" rel="nofollow" target="_blank[/snapback]​
    [/quote]
    Попробуй так
    БИ_МЦ.ВыполнитьЗапрос(ВыбКонПериода,ВыбКонПериода, "МЦ.01,МЦ.02,МЦ.04,МЦ.05,МЦ.06,МЦ.07",,,,, "К");
     
  5. Helena

    Helena Гость

    не помогло ;)
     
  6. Akulina

    Akulina Гость

    Попробуйте сделать цикл по счетам и собрать количество по каждому счету отдельно.
     
  7. Helena

    Helena Гость

    Не пойму, как это сделать :(
    Мне нужно получать данные по всем счетам по каждому субконто...

    кстати, для сравнения вместо МЦ использовала субсчета 10, количество выводится :rolleyes: ... Значит дело в самих счетах? :blink:
     
  8. Akulina

    Akulina Гость

    БИ_МЦ = СоздатьОбъект("БухгалтерскиеИтоги");
    БИ_МЦ.ИспользоватьСубконто(ВидыСубконто.Материалы);
    БИ_МЦ.ИспользоватьСубконто(ВидыСубконто.Сотрудники);
    БИ_МЦ.ВыполнитьЗапрос(,ВыбКонПериода, "МЦ.01,МЦ.02,МЦ.04,МЦ.05,МЦ.06,МЦ.07",,,,, "К");

    БИ_МЦ.ВыбратьСчета();
    Пока БИ_МЦ.ПолучитьСчет()=1 Цикл

    БИ_МЦ.ВыбратьСубконто(1);
    Пока БИ_МЦ.ПолучитьСубконто(1)=1 Цикл
    ТЗ.НоваяСтрока();
    ТЗ.Материал = Строка(БИ_МЦ.Субконто(1));
    БИ_МЦ.ВыбратьСубконто(2);
    БИ_МЦ.ПолучитьСубконто(2);
    ТЗ.Сотр = Строка(БИ_МЦ.Субконто(2));
    ТЗ.Количество = Число(БИ_МЦ.СКД("К"));
    КонецЦикла;
    КонецЦикла;

    Посмотри, что там с количеством на каждом счете.
     
Загрузка...
Похожие Темы - Обращение БухИтогам
  1. Bafomet
    Ответов:
    18
    Просмотров:
    128
  2. Shouldercannon
    Ответов:
    1
    Просмотров:
    141
  3. proteam
    Ответов:
    7
    Просмотров:
    787
  4. Вовкин
    Ответов:
    0
    Просмотров:
    722
  5. Вовкин
    Ответов:
    0
    Просмотров:
    683

Поделиться этой страницей