Обращение к БухИтогам

  • Автор темы Helena
  • Дата начала
H

Helena

Гость
#1
Почему когда передаю один счет, кол-во БИ_МЦ.СКД("К") считается
БИ_МЦ.ВыполнитьЗапрос(,ВыбКонПериода, "МЦ.07",,,,, "К");

а вот так не считается
БИ_МЦ.ВыполнитьЗапрос(,ВыбКонПериода, "МЦ.01,МЦ.02,МЦ.04,МЦ.05,МЦ.06,МЦ.07",,,,, "К");
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#2
Все субсчета "МЦ" количественные?
Может, перед запросом есть ИспользоватьСубконто?
 
H

Helena

Гость
#3
Все количественные
Вообще, дело обстоит так...

БИ_МЦ = СоздатьОбъект("БухгалтерскиеИтоги");
БИ_МЦ.ИспользоватьСубконто(ВидыСубконто.Материалы);
БИ_МЦ.ИспользоватьСубконто(ВидыСубконто.Сотрудники);
БИ_МЦ.ВыполнитьЗапрос(,ВыбКонПериода, "МЦ.01,МЦ.02,МЦ.04,МЦ.05,МЦ.06,МЦ.07",,,,, "К");

БИ_МЦ.ВыбратьСубконто(1);
Пока БИ_МЦ.ПолучитьСубконто(1)=1 Цикл
ТЗ.НоваяСтрока();
ТЗ.Материал = Строка(БИ_МЦ.Субконто(1));
БИ_МЦ.ВыбратьСубконто(2);
БИ_МЦ.ПолучитьСубконто(2);
ТЗ.Сотр = Строка(БИ_МЦ.Субконто(2));
ТЗ.Количество = Число(БИ_МЦ.СКД("К"));
КонецЦикла;
 
K

kaa

Гость
#4
<!--QuoteBegin-Helena+20:02:2008, 23:55 -->
<span class="vbquote">(Helena @ 20:02:2008, 23:55 )</span><!--QuoteEBegin-->БИ_МЦ.ВыполнитьЗапрос(,ВыбКонПериода, "МЦ.01,МЦ.02,МЦ.04,МЦ.05,МЦ.06,МЦ.07",,,,, "К");
[snapback]98943" rel="nofollow" target="_blank[/snapback]​
[/quote]
Попробуй так
БИ_МЦ.ВыполнитьЗапрос(ВыбКонПериода,ВыбКонПериода, "МЦ.01,МЦ.02,МЦ.04,МЦ.05,МЦ.06,МЦ.07",,,,, "К");
 
A

Akulina

Гость
#6
Попробуйте сделать цикл по счетам и собрать количество по каждому счету отдельно.
 
H

Helena

Гость
#7
Не пойму, как это сделать :(
Мне нужно получать данные по всем счетам по каждому субконто...

кстати, для сравнения вместо МЦ использовала субсчета 10, количество выводится :rolleyes: ... Значит дело в самих счетах? :blink:
 
A

Akulina

Гость
#8
БИ_МЦ = СоздатьОбъект("БухгалтерскиеИтоги");
БИ_МЦ.ИспользоватьСубконто(ВидыСубконто.Материалы);
БИ_МЦ.ИспользоватьСубконто(ВидыСубконто.Сотрудники);
БИ_МЦ.ВыполнитьЗапрос(,ВыбКонПериода, "МЦ.01,МЦ.02,МЦ.04,МЦ.05,МЦ.06,МЦ.07",,,,, "К");

БИ_МЦ.ВыбратьСчета();
Пока БИ_МЦ.ПолучитьСчет()=1 Цикл

БИ_МЦ.ВыбратьСубконто(1);
Пока БИ_МЦ.ПолучитьСубконто(1)=1 Цикл
ТЗ.НоваяСтрока();
ТЗ.Материал = Строка(БИ_МЦ.Субконто(1));
БИ_МЦ.ВыбратьСубконто(2);
БИ_МЦ.ПолучитьСубконто(2);
ТЗ.Сотр = Строка(БИ_МЦ.Субконто(2));
ТЗ.Количество = Число(БИ_МЦ.СКД("К"));
КонецЦикла;
КонецЦикла;

Посмотри, что там с количеством на каждом счете.