Обыкновенное уравнение (в отчёте)

Тема в разделе "1C и всё что с ней связано", создана пользователем Nick888, 3 мар 2015.

  1. Nick888

    Nick888 Member

    Регистрация:
    10 ноя 2014
    Сообщения:
    9
    Симпатии:
    0
    Отчёт->макет->табличный документ насколько я понимаю...

    К примеру, в ячейке r1c1 задано значение x1, в r1c2 значение x2, а в r1c3 должна получиться сумма x1 и x2. Как это записать на встроенном языке?

    Процедура ПолеТабличногоДокументаПриИзмененииСодержимогоОбласти(Элемент, Область)

    P.S. Посоветуйте литературу по теме
     
  2. Darlock

    Darlock Well-Known Member
    1C Team

    Регистрация:
    4 янв 2008
    Сообщения:
    558
    Симпатии:
    0
    Доброго времени суток.

    Обработчик выбран, вроде, выбран правильно, используйте только еще рекурсию (вы же хотите чтоб сумма менялась).

    P.S. вам сюда
     
  3. Nick888

    Nick888 Member

    Регистрация:
    10 ноя 2014
    Сообщения:
    9
    Симпатии:
    0
    [DOUBLEPOST=1425823251,1425823176][/DOUBLEPOST]
    Код ( (Unknown Language)):
    &НаКлиенте
    Процедура ТабДокПриИзмененииСодержимогоОбласти(Элемент, Область)
    ПриИзмененииДанныхОбластиТабДока(Элемент, Область, ЭтаФорма);
    КонецПроцедуры
    &НаКлиенте
    Функция ПриИзмененииДанныхОбластиТабДока(Элемент, Область, Контекст) Экспорт
    ПозицияКолонки = Найти(Область.Имя,"C");
    Строка = Сред(Область.Имя, 1, ПозицияКолонки-1);
    Колонка = Сред(Область.Имя, ПозицияКолонки);
    Если Колонка = "C1" или Колонка = "C2" Тогда
    Попытка
    Контекст[Элемент.Имя].Область(Строка+"C3").Текст = Число(Контекст[Элемент.Имя].Область(Строка+"C2").Текст) + Число(Контекст[Элемент.Имя].Область(Строка+"C1").Текст);
    Исключение
    КонецПопытки;
    КонецЕсли;
    КонецФункции
    Это сложение двух чисел, а как реализовать решение системы уравнений? Хотя бы типа таких?
    [latex]\left\{x-y=-5\\\hspace{50}
    2x+y=-7[/latex]
     
    #3 Nick888, 8 мар 2015
    Последнее редактирование модератором: 8 мар 2015
  4. Darlock

    Darlock Well-Known Member
    1C Team

    Регистрация:
    4 янв 2008
    Сообщения:
    558
    Симпатии:
    0
    Написать алгоритм решения системы уравнений как в школе делали. И все.
     

Поделиться этой страницей