одна маленькая задачка =) не поленись ответить если знаешь

Тема в разделе "1C и всё что с ней связано", создана пользователем kykareky, 23 апр 2009.

  1. kykareky

    kykareky Гость

    ребята как правильно написать такую процедуру:
    нужно выбрать из справочника «физическиеЛица» значение и вывести его на «ПолеСписка»(с реквизитом-ПолеСпискаРеквизит)?
    Процедура пишется в обработке (которая в дереве метаданных)
     
  2. kykareky

    kykareky Гость

    вот один вариант решения этой проблемы =), но он мне не нравится, кто может попроще составить???

    Процедура Кнопка1Нажатие(Элемент)
    список=Справочники.ФизическиеЛица.ПолучитьФорму("формаСписка",ЭтаФорма,1);
    если список.Открыта()=0 тогда
    список.РежимВыбора=истина;
    список.Открыть();
    КонецЕсли;
    КонецПроцедуры

    Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
    если Источник.ЭтаФорма.ключУникальности=1 тогда
    ПолеСпискаРеквизит.Добавить(ЗначениеВыбора);
    КонецЕсли;
    КонецПроцедуры
     
Загрузка...

Поделиться этой страницей