одна маленькая задачка =) не поленись ответить если знаешь

  • Автор темы kykareky
  • Дата начала
K

kykareky

#1
ребята как правильно написать такую процедуру:
нужно выбрать из справочника «физическиеЛица» значение и вывести его на «ПолеСписка»(с реквизитом-ПолеСпискаРеквизит)?
Процедура пишется в обработке (которая в дереве метаданных)
 
K

kykareky

#2
вот один вариант решения этой проблемы =), но он мне не нравится, кто может попроще составить???

Процедура Кнопка1Нажатие(Элемент)
список=Справочники.ФизическиеЛица.ПолучитьФорму("формаСписка",ЭтаФорма,1);
если список.Открыта()=0 тогда
список.РежимВыбора=истина;
список.Открыть();
КонецЕсли;
КонецПроцедуры

Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
если Источник.ЭтаФорма.ключУникальности=1 тогда
ПолеСпискаРеквизит.Добавить(ЗначениеВыбора);
КонецЕсли;
КонецПроцедуры