Ограничение на показ периодических реквизитов

  • Автор темы Galina
  • Дата начала
G

Galina

Гость
#1
Платформа 7.7, Конф. ЗиК 283

Подскажите, пожалуйста, как отключить возможность просмотра периодич. реквизитов элемента справочника "Сотрудники" ?
Меня интересует показ период. реквизитов через меню "Действия" -- "История значения" (кн. F5). В этом случае вызывается форма выбора реквизита. Как можно "дотянуться" до этой формы?
 

puh14

Well-Known Member
11.07.2008
1 412
0
#2
ПросмотрИстории(<?>);
Синтаксис:
ПросмотрИстории(<СписокРеквизитов>)
Назначение:
Установить список периодических реквизитов, просмотр истории которых допускается. Возвращает - текущий (на момент до вызова метода) список реквизитов, просмотр истории которых допускается.
Параметры:
<СписокРеквизитов> - строка со списком идентификаторов (через запятую) тех реквизитов, просмотр истории которых допускается.
 
G

Galina

Гость
#3
Платформа 7.7, Конф. ЗиК 283

Подскажите, пожалуйста, как отключить возможность просмотра периодич. реквизитов элемента справочника "Сотрудники" ?
Меня интересует показ период. реквизитов через меню "Действия" -- "История значения" (кн. F5). В этом случае вызывается форма выбора реквизита. Как можно "дотянуться" до этой формы?
Уточнение вопроса:
Интересует просмотр реквизитов для элементов в списке (не открывая форму элемента). Можно отключить выбор реквизитов для просмотра (метод ПросмотрИстории), но для всех элементов в списке. Так вот вопрос: можно ли добиться, чтобы доступ к показу реквизитов был только для отдельных элементов справочника?
 

puh14

Well-Known Member
11.07.2008
1 412
0
#4
разве что задать в ПриВыбореСтроки значение строки списка реквизитов по условию. или по закладкам их раскидать - а при выборезакладки задавать видимость истории.
 
G

GRblSHA

Гость
#5
Галина, Вам абсолютно правильно подсказали. Действительно для ограничения просмотра истории действия--История значения используется команда
просмотрИстории(<список реквизитов>);
данную команду необходимо использовать в модуле списка справочника и в модуле элемента справочника в процедуре ПриОткрытии()

пример:
ПриОткрытии()
ПросмотрИстории("оклад, Подразделение"); //ограничение реквизитов по окладу и подразделению
КонецПроцедуры
 
G

Galina

Гость
#6
разве что задать в ПриВыбореСтроки значение строки списка реквизитов по условию. или по закладкам их раскидать - а при выборезакладки задавать видимость истории.
Не нашла я в описании такой предопределеной процедуры (или нечто похожего). Или речь идет о другом?
 
G

GRblSHA

Гость
#7
Описание встроенного языка часть 1 страница 209-210
 

puh14

Well-Known Member
11.07.2008
1 412
0
#8
Процедура ПриВыбореСтроки()
КонецПроцедуры
Синтаксис:
ПриВыбореСтроки()
Назначение:
Предопределенная процедура при выборе строки списка.
Замечание:
Режим обработки выбора строки (двойной щелчок мыши или клавиша Enter) предопределенной процедурой ПриВыбореСтроки включается в форме списка справочника, журнала документов, счетов, журнала операций, журнала проводок при помощи метода Форма.ОбработкаВыбораСтроки(1). Данная процедура может располагаться только в программном модуле формы.,
 
G

GRblSHA

Гость
#10
ПриВыбореСтроки() ч2 стр 710 Описание всроенного языка)
 
G

Galina

Гость
#11
ПриВыбореСтроки() ч2 стр 710 Описание всроенного языка)
Спасибо.

Процедура ПриВыбореСтроки()
КонецПроцедуры
Синтаксис:
ПриВыбореСтроки()
Назначение:
Предопределенная процедура при выборе строки списка.
Замечание:
Режим обработки выбора строки (двойной щелчок мыши или клавиша Enter) предопределенной процедурой ПриВыбореСтроки включается в форме списка справочника, журнала документов, счетов, журнала операций, журнала проводок при помощи метода Форма.ОбработкаВыбораСтроки(1). Данная процедура может располагаться только в программном модуле формы.,
Мне кажется, данная процедура не подходит, т.к. с ее помощью описываются действия в момент попытки пользователя обработать элемент справочника, т. е. пользователь выполняет "двойной щелчок мыши или клавиша Enter". А доступ к истории осуществляется через меню при выделенном элементе справочника, т.е. события "обработка строки" не наступает.
 

puh14

Well-Known Member
11.07.2008
1 412
0
#12
ТОгда наверно только во закладкам раскидать - одна общая - ничего не видно, одна - видно только то что можно. Либо на пользователя повесить.

Если редактирование в списке разрешено можно попробовать

Процедура ПриНачалеРедактированияСтроки()
КонецПроцедуры
Синтаксис:
ПриНачалеРедактированияСтроки()
Назначение:
Предопределенная процедура при начале интерактивного редактирования существующей строки списка справочника.
Замечание:
Данная процедура может располагаться только в модуле формы списка справочника.

а к строчке справочника обращаться как текщийЭлемент()
 
G

GRblSHA

Гость
#13
Спасибо.



Мне кажется, данная процедура не подходит, т.к. с ее помощью описываются действия в момент попытки пользователя обработать элемент справочника, т. е. пользователь выполняет "двойной щелчок мыши или клавиша Enter". А доступ к истории осуществляется через меню при выделенном элементе справочника, т.е. события "обработка строки" не наступает.
Тогда поставь в процедуру ПриОткрытии() даже если пользователь не выбрал и не выделил какой то документ все равно произойдет ограничение списка периодических реквизитов