определение конфигурации для внешнего отчета

Тема в разделе "1C и всё что с ней связано", создана пользователем Azrael, 3 май 2007.

Статус темы:
Закрыта.
  1. Azrael

    Azrael Гость

    Наверняка несложный вопрос, но все же :)
    Задача экспорта данных из 1С в текстовый файл. Пишу ert-отчет, в нем что-то типа:
    Код (Text):
    Если докИсходАкты=1 Тогда
    ИмяФайла="OSM\OutputActs.txt";
    док=СоздатьОбъект("Документ.ОказаниеУслуг");    
    ткст=СоздатьОбъект("Текст");
    док.ВыбратьДокументы();
    колво=0;
    Пока док.ПолучитьДокумент()=1 Цикл
    Если док.ПометкаУдаления()=0 Тогда
    ....
    КонецЕсли;
    КонецЦикла;
    ткст.КодоваяСтраница(0);
    ткст.Записать(рабочийКаталог+"\"+ИмяФайла);
    ....
    КонецЕсли;
    Проблема в следующем: этот отчет хотелось бы использовать для разных конфигураций (по-крайней мере для "Упрощенная система налогообложения, ред. 1.3 - 7.70.151" и для "Бухгалтерский учет, редакция 4.5 - 7.70.486", но в них существуют некоторые различия, например, название документа или какие-либо поля.
    Как программно узнать конфигурацию?
     
  2. LSH

    LSH Гость

    Метаданные.Идентификатор
    Метаданные.Синоним

    Что это такое - см. свойства конфигурации.

    А если конфиги должны быть ТОЧНО типовыми, то можно проверять значение, возвращаемое функцией глИдентификаторКонфигурации().

    Возможные возвращаемые значения типовых (!!!) конфигураций:

    "BUTK" или "BUBK" - Бухгалтерия
    "OUBV" - типовая Зарплата
    "OUTK" - ТиС

    Есть еще ряд типовых кфг, но они у нас почти не используются и поэтому приводить их тут смысла не вижу.
     
  3. Azrael

    Azrael Гость

    Для: LSH
    Спасибо большое, разобрался, очень помогло


    Для остальных не-продвинутых (вдруг кому пригодится): в синтакс-помошнике (по крайней мере, в v7.7) почему-то не все методы/свойства отображаются, полезную информацию дает меню "Конфигурация-Описание структуры метаданных"
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей