Options -indexes

  • Автор темы DRUGADDICT
  • Дата начала
Статус
Закрыто для дальнейших ответов.
D

DRUGADDICT

#1
ровно 2 часа гуглю, кручу (/etc/init.d/apache2 restart) мучю (vi /etc/apache2/httpd.conf)... и не че понять не магу!

История такова! при вписании строчки Options -Indexes в .htaccess мне вылазит ошибка Error 500, нооо при этом .htaccess работает 100% т.к. другии опции в нем есть (кому интересно всего одна и вот она: DirectoryIndex go.php) и она работаеть - да вообщем эт не важно .htaccess... в конфиге самого апача в своей директиве я прописал Options -Indexes!!! и не рабоатет!!! все равно не работает!!! помогите я уже запарился реально... не знаю что и думать... может весь сервак перезагрузить? я апачь рас 50 уже перезапускалл... :wacko

OC: SUSE 11.1, Apache2, :heart

Код:
DocumentRoot "/home/drug_addict/public_html"
<Directory "/home/drug_addict/public_html"> 
Options None
AllowOverride all
Order allow,deny
Allow from all
</Directory>
Alias /icons/ "/usr/share/apache2/icons/"
<Directory "/usr/share/apache2/icons">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ "/srv/www/cgi-bin/"
<Directory "/srv/www/cgi-bin">
AllowOverride None
Options +ExecCGI -Includes
Order allow,deny
Allow from all
</Directory>
<IfModule mod_userdir.c>
UserDir public_html
Include /etc/apache2/mod_userdir.conf
</IfModule>
Include /etc/apache2/conf.d/*.conf
Include /etc/apache2/conf.d/apache2-manual?conf
ServerName server
ServerAdmin drug_addict@angarskhome.ru
всяка всяка... :wizard разна уже переделывал то в .conf меняю как Options на None (как и щас) и в .htaccess пишу -Indexes так и в .conf делаю -Indexes... короче не аботает не как... помогите!
 
D

DRUGADDICT

#2
Мне ктонеть поможет или нет :rolleyes: :) ;) :(

вот кстати логи:

Код:
[Wed Apr 08 17:31:41 2009] [alert] [client 100.0.0.2] /home/drug_addict/public_html/.htaccess: Options not allowed here, 
referer: http://10.100.0.14/forum//blogs/entry.php?entry=76&userid=2
[Wed Apr 08 17:31:43 2009] [alert] [client 100.0.0.2] /home/drug_addict/public_html/.htaccess: Options not allowed here
[Wed Apr 08 17:31:46 2009] [alert] [client 100.0.0.2] /home/drug_addict/public_html/.htaccess: Options not allowed here
я ещё AllowOverride None везде переделал в AllowOverride all и в /etc/apache2/defaults-server.conf и в httpd.conf короче везде... везде сделал Options -Indexes, естественно после этого /etc/init.d/apache2 restart ииии не работает... все равно не работает! вот бред...
 
Статус
Закрыто для дальнейших ответов.