ошибка 203...

  • Автор темы Guest
  • Дата начала
G

Guest

#1
Уважаемые Программисты подскажите новичку..., пожалуйста
дописывал конфу 7.7. ТиС и вышла ошибка
Дописывал: создал новый слой на справоч. контрагенты ну и несколько дополн. справ. и кнопок на этом слое
и вышла такая ошибка, в чем же дело???

ИнфСтрока = СокрЛП(ТекЭлем.Наименование) +
{Справочник.Контрагенты.ФормаСписка.ФормаСписка.Модуль(203)}: Поле агрегатного объекта не обнаружено (Телефоны)

Зарание Большое СПАСИБО!!!
 
K
#2
Где-то обращаещься к реквизиту Телефоны, кого-то справочника или реквизит не так называется или справочник должен быть другой
 
H

Hryv

#3
У тебя ощибка в 203 строке
Если еще не разобрался, то дай фрагмент кода гдето со 190 по 205 строки
 
G

Guest

#4
Функция СформироватьИнформационнуюСтроку()
Перем ИнфСтрока;

Если ПустоеЗначение(ТекущийЭлемент()) = 1 Тогда
// не выбран элемент
ИнфСтрока = "";
Иначе

Если ТекущийЭлемент().ЭтоГруппа() = 1 Тогда
// текущий элемент - группа
ИнфСтрока = ТекущийЭлемент().ПолноеНаименование();
Иначе

ТекЭлем = ТекущийЭлемент();

// НА ЭТУ СТРОКУ РУГАЕТСЯ... ИнфСтрока = СокрЛП(ТекЭлем.Наименование) +
?(ПустоеЗначение(ТекЭлем.ЮрФизЛицо.Телефоны) = 0, " Телефоны: " + СокрЛП(ТекЭлем.ЮрФизЛицо.Телефоны), "") +
?(ПустоеЗначение(ТекЭлем.ЭлПочта) = 0, " Адрес эл.почты: " + СокрЛП(ТекЭлем.ЭлПочта), "") +
?(ПустоеЗначение(ТекЭлем.Комментарий) = 0, " Комментарий: " + СокрЛП(ТекЭлем.Комментарий), "");

Если ТипЗначения(ФормаТаблицыОстатков) = 100 Тогда

// если открыта форма с таблицей остатков, то обновим в ней текущий элемент
ФормаТаблицыОстатков.Форма.Обновить(0);

КонецЕсли;
КонецЕсли;

КонецЕсли;
 
K
#5
Сделай проверку на пустоеЗначение ЮрФизЛицо