1. Наш канал codeby в telegram. Пишем об информационной безопасности, методах защиты информации, о программировании. Не пропускай новости с кодебай, будь в тренде ! Подробнее ...

    Скрыть объявление

ошибка 203...

Тема в разделе "Базы данных и администрирование", создана пользователем -, 25 ноя 2008.

  1. Гость

    Репутация:
    0
    Уважаемые Программисты подскажите новичку..., пожалуйста
    дописывал конфу 7.7. ТиС и вышла ошибка
    Дописывал: создал новый слой на справоч. контрагенты ну и несколько дополн. справ. и кнопок на этом слое
    и вышла такая ошибка, в чем же дело???

    ИнфСтрока = СокрЛП(ТекЭлем.Наименование) +
    {Справочник.Контрагенты.ФормаСписка.ФормаСписка.Модуль(203)}: Поле агрегатного объекта не обнаружено (Телефоны)

    Зарание Большое СПАСИБО!!!
     
  2. kaa

    kaa Гость

    Репутация:
    0
    Где-то обращаещься к реквизиту Телефоны, кого-то справочника или реквизит не так называется или справочник должен быть другой
     
  3. Hryv

    Hryv Гость

    Репутация:
    0
    У тебя ощибка в 203 строке
    Если еще не разобрался, то дай фрагмент кода гдето со 190 по 205 строки
     
  4. Гость

    Репутация:
    0
    Функция СформироватьИнформационнуюСтроку()
    Перем ИнфСтрока;

    Если ПустоеЗначение(ТекущийЭлемент()) = 1 Тогда
    // не выбран элемент
    ИнфСтрока = "";
    Иначе

    Если ТекущийЭлемент().ЭтоГруппа() = 1 Тогда
    // текущий элемент - группа
    ИнфСтрока = ТекущийЭлемент().ПолноеНаименование();
    Иначе

    ТекЭлем = ТекущийЭлемент();

    // НА ЭТУ СТРОКУ РУГАЕТСЯ... ИнфСтрока = СокрЛП(ТекЭлем.Наименование) +
    ?(ПустоеЗначение(ТекЭлем.ЮрФизЛицо.Телефоны) = 0, " Телефоны: " + СокрЛП(ТекЭлем.ЮрФизЛицо.Телефоны), "") +
    ?(ПустоеЗначение(ТекЭлем.ЭлПочта) = 0, " Адрес эл.почты: " + СокрЛП(ТекЭлем.ЭлПочта), "") +
    ?(ПустоеЗначение(ТекЭлем.Комментарий) = 0, " Комментарий: " + СокрЛП(ТекЭлем.Комментарий), "");

    Если ТипЗначения(ФормаТаблицыОстатков) = 100 Тогда

    // если открыта форма с таблицей остатков, то обновим в ней текущий элемент
    ФормаТаблицыОстатков.Форма.Обновить(0);

    КонецЕсли;
    КонецЕсли;

    КонецЕсли;
     
  5. kaa

    kaa Гость

    Репутация:
    0
    Сделай проверку на пустоеЗначение ЮрФизЛицо
     
Загрузка...
Похожие Темы - ошибка 203
  1. bb-8
    Ответов:
    4
    Просмотров:
    64
  2. bb-8
    Ответов:
    3
    Просмотров:
    143
  3. recrut
    Ответов:
    13
    Просмотров:
    249
  4. Петручо
    Ответов:
    0
    Просмотров:
    64
  5. Tayrus
    Ответов:
    6
    Просмотров:
    153

Поделиться этой страницей