Ошибка: Много Параметров

Тема в разделе "1C и всё что с ней связано", создана пользователем waldem39, 11 ноя 2012.

Статус темы:
Закрыта.
  1. waldem39

    waldem39 Гость

    Здравствуйте вопрос от чайника не могу разобраться с подчиненными справочниками то ест с назначением владельца пишет ошибку:"Слишком много параметров передано при вызове функции/процедуры объекта"
    Процедура ОбработкаПроведения()
    СпрЗак=СоздатьОбъект("Справочник.Заказы");
    Спр=СоздатьОбъект("Справочник.ЗаказыТовар");
    Если СпрЗак.НайтиПоКоду(НомерДок,)=1 тогда
    Спр.ИспользоватьВладельца(Спрзак.ТекушийЭлемент(),);
    КонецЕсли;

    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Если Спр.НайтиПоРеквизиту("Товар",Товар,)=0 тогда
    Спр.Новый();
    Спр.Товар=товар;
    Спр.Записать();
    КонецЕсли;
    КонецЦикла;


    // ********************


    //Здесь следует написать алгоритм проведения документа

    КонецПроцедуры
    при запеси создается справочник заказы
    Вчем моя ошибка??
     
  2. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Сообщение "Слишком много параметров передано при вызове функции/процедуры объекта" должно указывать на конкретную строку кода
    Навскидку ошибок не видно
     
  3. waldem39

    waldem39 Гость

    Ссылка на Использовать Владельца я тоже не вижу ошибок могу написать суть замысла есть документ шапка и таблица, все дание из шапки записываются в один справочник а из тоблицы в другой справочник который подченен первому, и он выдает тукую ошибку может быть из-за того что у справочника владельца код соответствует номеру документа????
     
  4. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Попробуй так :
    Код ( (Unknown Language)):
    Если СпрЗак.НайтиПоКоду(НомерДок,)=1 тогда
    Вл = Спрзак.ТекушийЭлемент();
    Спр.ИспользоватьВладельца(Вл);
    КонецЕсли
     
  5. waldem39

    waldem39 Гость

    будет ругаться также но на строчку Вл=Спр.ТекущийЭлемент();
    пробовал через переменную такая же ошибка
     
  6. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Да черт же побери! Уберите слова "Нужна помощь" из названия темы!

    Добавлено:
    Попробуйте убрать запятую.
     
  7. waldem39

    waldem39 Гость

    Пробовал не что не меняется может можно какую нибудь другую идею реализовать чтоб при выборе документа в таблице значений появлялась табличная часть то есть в списке выделяя документ видно было табличную часть ну что то вроде того, хотел через журнал не получилось, да и походу через справочник тоже облом
     
  8. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Что-то я вам не верю. Да и вообще, у вас каша в голове. И тему перименуйте.
     
  9. waldem39

    waldem39 Гость

    могу скинуть базу и сам проверишь
     
  10. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Ошибка синтаксическая. Значит в самом сообщении есть номер ошибочной строки.
    А если кликнуть по красным буковкам "err", то и 1С переведет на эту строку.


    Добавлено: А еще при пустых параметрах можно в большинстве случаев убрать запятую. Например:
    Спр.ИспользоватьВладельца(Спрзак.ТекушийЭлемент() ,);


    Злополучное название темы переименовал. Ну бывают глухие и слепые.
     
  11. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    "будет ругаться также но на строчку Вл=Спр.ТекущийЭлемент();пробовал через переменную такая же ошибка"
    Т.е. в этой строке слишком много параметров? Изменения сохранил, отладчик закрывал?
     
  12. LuckyJoker

    LuckyJoker Гость



    Помогите решить задачку по 1С с олимпиады по программированию 2007 года... )))

    Условия и конфигурацию скину на почту...)))
     
  13. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    "Помогите решить задачку по 1С с олимпиады по программированию 2007 года... )))Условия и конфигурацию скину на почту...)))"
    Ну вы и хамло. В двух темах написали!
     
  14. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Минус. Только он реакции не увидит, т.к. в тему больше и не заглянет.
     
  15. LuckyJoker

    LuckyJoker Гость

    Что за паника ?????

    Тяжело помочь что ли ????
     
Загрузка...
Похожие Темы - Ошибка Много Параметров
  1. Lamerman
    Ответов:
    0
    Просмотров:
    23
  2. Enima
    Ответов:
    0
    Просмотров:
    51
  3. Baindt
    Ответов:
    1
    Просмотров:
    71
  4. anna
    Ответов:
    2
    Просмотров:
    79
  5. gramzer
    Ответов:
    1
    Просмотров:
    120
Статус темы:
Закрыта.

Поделиться этой страницей