Ошибка: Много Параметров

  • Автор темы waldem39
  • Дата начала
Статус
Закрыто для дальнейших ответов.
W

waldem39

#1
Здравствуйте вопрос от чайника не могу разобраться с подчиненными справочниками то ест с назначением владельца пишет ошибку:"Слишком много параметров передано при вызове функции/процедуры объекта"
Процедура ОбработкаПроведения()
СпрЗак=СоздатьОбъект("Справочник.Заказы");
Спр=СоздатьОбъект("Справочник.ЗаказыТовар");
Если СпрЗак.НайтиПоКоду(НомерДок,)=1 тогда
Спр.ИспользоватьВладельца(Спрзак.ТекушийЭлемент(),);
КонецЕсли;

ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Если Спр.НайтиПоРеквизиту("Товар",Товар,)=0 тогда
Спр.Новый();
Спр.Товар=товар;
Спр.Записать();
КонецЕсли;
КонецЦикла;


// ********************


//Здесь следует написать алгоритм проведения документа

КонецПроцедуры
при запеси создается справочник заказы
Вчем моя ошибка??
 

vbs

Well-known member
18.02.2007
1 708
1
#2
Сообщение "Слишком много параметров передано при вызове функции/процедуры объекта" должно указывать на конкретную строку кода
Навскидку ошибок не видно
 
W

waldem39

#3
Сообщение "Слишком много параметров передано при вызове функции/процедуры объекта" должно указывать на конкретную строку кода
Навскидку ошибок не видно
Ссылка на Использовать Владельца я тоже не вижу ошибок могу написать суть замысла есть документ шапка и таблица, все дание из шапки записываются в один справочник а из тоблицы в другой справочник который подченен первому, и он выдает тукую ошибку может быть из-за того что у справочника владельца код соответствует номеру документа????
 

vbs

Well-known member
18.02.2007
1 708
1
#4
Попробуй так :
Код:
Если СпрЗак.НайтиПоКоду(НомерДок,)=1 тогда
Вл = Спрзак.ТекушийЭлемент();
Спр.ИспользоватьВладельца(Вл);
КонецЕсли
 
W

waldem39

#5
Попробуй так :
Код:
Если СпрЗак.НайтиПоКоду(НомерДок,)=1 тогда
Вл = Спрзак.ТекушийЭлемент();
Спр.ИспользоватьВладельца(Вл);
КонецЕсли
будет ругаться также но на строчку Вл=Спр.ТекущийЭлемент();
пробовал через переменную такая же ошибка
 
W

waldem39

#7
Пробовал не что не меняется может можно какую нибудь другую идею реализовать чтоб при выборе документа в таблице значений появлялась табличная часть то есть в списке выделяя документ видно было табличную часть ну что то вроде того, хотел через журнал не получилось, да и походу через справочник тоже облом
 

unknown181538

НеГуру
28.12.2008
1 417
0
#8
Что-то я вам не верю. Да и вообще, у вас каша в голове. И тему перименуйте.
 

Дайнеко

Well-known member
19.11.2009
951
0
#10
Ошибка синтаксическая. Значит в самом сообщении есть номер ошибочной строки.
А если кликнуть по красным буковкам "err", то и 1С переведет на эту строку.


Добавлено: А еще при пустых параметрах можно в большинстве случаев убрать запятую. Например:
Спр.ИспользоватьВладельца(Спрзак.ТекушийЭлемент() ,);


Злополучное название темы переименовал. Ну бывают глухие и слепые.
 

unknown181538

НеГуру
28.12.2008
1 417
0
#11
"будет ругаться также но на строчку Вл=Спр.ТекущийЭлемент();пробовал через переменную такая же ошибка"
Т.е. в этой строке слишком много параметров? Изменения сохранил, отладчик закрывал?
 
L

LuckyJoker

#12
"будет ругаться также но на строчку Вл=Спр.ТекущийЭлемент();пробовал через переменную такая же ошибка"
Т.е. в этой строке слишком много параметров? Изменения сохранил, отладчик закрывал?


Помогите решить задачку по 1С с олимпиады по программированию 2007 года... )))

Условия и конфигурацию скину на почту...)))
 

unknown181538

НеГуру
28.12.2008
1 417
0
#13
"Помогите решить задачку по 1С с олимпиады по программированию 2007 года... )))Условия и конфигурацию скину на почту...)))"
Ну вы и хамло. В двух темах написали!
 

Дайнеко

Well-known member
19.11.2009
951
0
#14
Минус. Только он реакции не увидит, т.к. в тему больше и не заглянет.
 
Статус
Закрыто для дальнейших ответов.