• Codeby web-security - Курс "Тестирование Веб-Приложений на проникновение с нуля" от команды codeby. Общая теория, подготовка рабочего окружения, пассивный фазинг и фингерпринт, Активный фаззинг, Уязвимости, Пост-эксплуатация, Инструментальные средства, Social Engeneering и многое другое. Подробнее ...

  • Мобильный клиент нашего форума для Android гаджетов доступен в Google Play Market по этой ссылке. Клиент можно скачать с нашего форума по этой ссылке. Последняя версия МК в нашем телеграм канале вот здесь

Ошибка при установке linux-headers

kaarb

New member
02.02.2018
3
0
#1
Здравствуйте. Попытался выполнить команду
Код:
apt-get install -y dkms linux-headers-$(uname -r)
Мне система выдала вот такую ошибку

E: Unable to locate package linux-headers-4.12.0-kali1-amd64
E: Couldn't find any package by glob 'linux-headers-4.12.0-kali1-amd64'
E: Couldn't find any package by regex 'linux-headers-4.12.0-kali1-amd64'
Сам я еще совсем зеленый новичок, не бейте тапками
 

sinner67

Red Team
24.03.2017
239
269
#2
обновитесь и попробуйте снова
Код:
apt-get update
apt-get upgrade
apt-get dist-upgrade
 
23.09.2016
24
9
#3
Здравствуйте. Попытался выполнить команду
Код:
apt-get install -y dkms linux-headers-$(uname -r)
Мне система выдала вот такую ошибку

E: Unable to locate package linux-headers-4.12.0-kali1-amd64
E: Couldn't find any package by glob 'linux-headers-4.12.0-kali1-amd64'
E: Couldn't find any package by regex 'linux-headers-4.12.0-kali1-amd64'
Сам я еще совсем зеленый новичок, не бейте тапками
Здравствуйте! Я могу ошибаться, но думаю Вам поможет это:
https://codeby.net/forum/threads/oshibka-repozitoriev-kali-linux.62076/
 

zed

Member
18.01.2018
16
4
#4
это нормально для кали
обновись полностью apt-get update && apt-get dist-upgrade
и reboot
далее смотрим версию ядра uname -r
теперь смотрим apt-cache search linux-headers и apt-cache search linux-image на доступность хеадерсов и имеджа в репах
если к примеру у тебя версия используемого ядра совпадает с тем что есть в репах
то можешь выполнять свою команду apt-get install -y dkms linux-headers-$(uname -r)
но в последнее время в кали линукс установленная версия ядра отличается от исходников что содержатся в репозиториях
поэтому идешь на оф сайт
Для просмотра контента необходимо: Войти или зарегистрироваться
и ищешь 2 файла под свое ядро это
linux-headers******common*****.deb
и
linux-headers*****all*****.deb
(звездочки это твоя версия ядра и разрядность ос)
скачиваешь их и ставишь со всеми необходимыми зависимости и нужными компиляторами( которые при ошибки запуска будут требоваться к установке)
сначала устанавливаешь файл common, потом all
командой dpkg -i linux-headers******common*****.deb (выходит ошибка, смотришь чего не хватает и ставишь ставишь через apt install этот пакет)
после устанавливаешь также linux-headers*****all*****.deb
перезагружаешь ос и командой apt-cache search linux-headers и apt-cache search linux-image видишь только что установленные нами исходники ядра
и вот теперь выполняешь свою команду apt-get install -y dkms linux-headers-$(uname -r)
 
Вверх Снизу