1. Наш канал codeby в telegram. Пишем об информационной безопасности, методах защиты информации, о программировании. Не пропускай новости с кодебай, будь в тренде ! Подробнее ...

    Скрыть объявление

Ошибка в 8.0 оформлениестроки

Тема в разделе "Базы данных и администрирование", создана пользователем SeverBap, 20 ноя 2009.

  1. SeverBap

    SeverBap Well-Known Member

    Репутация:
    0
    Регистрация:
    18 сен 2007
    Сообщения:
    451
    Симпатии:
    0
    ситуация простая в этой процедуре:
    Код:
    Процедура тНоменклатураПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    ЭлементыФормы.тНоменклатура.Колонки.Количество.ТекстПодвала = "Всего позиций: "+тНоменклатура.Количество();
    Попытка
    Если ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяПриход>ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяРасход Тогда
    ОформлениеСтроки.ЦветФона = Новый Цвет(255,200,200);
    ИначеЕсли ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяПриход<ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяРасход Тогда
    ОформлениеСтроки.ЦветФона = Новый Цвет(200,255,200);
    КонецЕсли;
    Исключение
    
    КонецПопытки;
    КонецПроцедуры
    при открытии выпадает на ошибку, добавил попытку, заработала, но главное он почему то красит все строки а не одну!! в чем проблема?

    исправил надо данныестроки.суммарозничнаяприход делать! :)
     
  2. sannt

    sannt Гость

    Репутация:
    0
    Процедура тНоменклатураПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

    ЭлементыФормы.тНоменклатура.Колонки.Количество.ТекстПодвала = "Всего позиций: "+тНоменклатура.Количество();

    Если ДанныеСтроки.СуммаРозничнаяПриход > ДанныеСтроки.СуммаРозничнаяРасход Тогда
    ОформлениеСтроки.ЦветФона = Новый Цвет(255,200,200);
    ИначеЕсли ДанныеСтроки.СуммаРозничнаяПриход < ДанныеСтроки.СуммаРозничнаяРасход Тогда
    ОформлениеСтроки.ЦветФона = Новый Цвет(200,255,200);
    КонецЕсли;

    КонецПроцедуры
     
Загрузка...
Похожие Темы - Ошибка оформлениестроки
  1. bb-8
    Ответов:
    4
    Просмотров:
    55
  2. bb-8
    Ответов:
    3
    Просмотров:
    131
  3. recrut
    Ответов:
    13
    Просмотров:
    233
  4. Петручо
    Ответов:
    0
    Просмотров:
    59
  5. Tayrus
    Ответов:
    6
    Просмотров:
    150

Поделиться этой страницей