Ошибка в 8.0 оформлениестроки

Тема в разделе "1C и всё что с ней связано", создана пользователем SeverBap, 20 ноя 2009.

  1. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    ситуация простая в этой процедуре:
    Код (Text):
    Процедура тНоменклатураПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    ЭлементыФормы.тНоменклатура.Колонки.Количество.ТекстПодвала = "Всего позиций: "+тНоменклатура.Количество();
    Попытка
    Если ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяПриход>ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяРасход Тогда
    ОформлениеСтроки.ЦветФона = Новый Цвет(255,200,200);
    ИначеЕсли ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяПриход<ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяРасход Тогда
    ОформлениеСтроки.ЦветФона = Новый Цвет(200,255,200);
    КонецЕсли;
    Исключение

    КонецПопытки;
    КонецПроцедуры
    при открытии выпадает на ошибку, добавил попытку, заработала, но главное он почему то красит все строки а не одну!! в чем проблема?

    исправил надо данныестроки.суммарозничнаяприход делать! :)
     
  2. sannt

    sannt Гость

    Процедура тНоменклатураПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

    ЭлементыФормы.тНоменклатура.Колонки.Количество.ТекстПодвала = "Всего позиций: "+тНоменклатура.Количество();

    Если ДанныеСтроки.СуммаРозничнаяПриход > ДанныеСтроки.СуммаРозничнаяРасход Тогда
    ОформлениеСтроки.ЦветФона = Новый Цвет(255,200,200);
    ИначеЕсли ДанныеСтроки.СуммаРозничнаяПриход < ДанныеСтроки.СуммаРозничнаяРасход Тогда
    ОформлениеСтроки.ЦветФона = Новый Цвет(200,255,200);
    КонецЕсли;

    КонецПроцедуры
     
Загрузка...

Поделиться этой страницей