Ошибка в 8.0 оформлениестроки

SeverBap

Well-Known Member
18.09.2007
451
0
#1
ситуация простая в этой процедуре:
Код:
Процедура тНоменклатураПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
ЭлементыФормы.тНоменклатура.Колонки.Количество.ТекстПодвала = "Всего позиций: "+тНоменклатура.Количество();
Попытка
Если ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяПриход>ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяРасход Тогда
ОформлениеСтроки.ЦветФона = Новый Цвет(255,200,200);
ИначеЕсли ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяПриход<ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяРасход Тогда
ОформлениеСтроки.ЦветФона = Новый Цвет(200,255,200);
КонецЕсли;
Исключение

КонецПопытки;
КонецПроцедуры
при открытии выпадает на ошибку, добавил попытку, заработала, но главное он почему то красит все строки а не одну!! в чем проблема?

исправил надо данныестроки.суммарозничнаяприход делать! :)
 
S

sannt

Гость
#2
Процедура тНоменклатураПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

ЭлементыФормы.тНоменклатура.Колонки.Количество.ТекстПодвала = "Всего позиций: "+тНоменклатура.Количество();

Если ДанныеСтроки.СуммаРозничнаяПриход > ДанныеСтроки.СуммаРозничнаяРасход Тогда
ОформлениеСтроки.ЦветФона = Новый Цвет(255,200,200);
ИначеЕсли ДанныеСтроки.СуммаРозничнаяПриход < ДанныеСтроки.СуммаРозничнаяРасход Тогда
ОформлениеСтроки.ЦветФона = Новый Цвет(200,255,200);
КонецЕсли;

КонецПроцедуры