Ошибка в 8.0 оформлениестроки

Тема в разделе "1C и всё что с ней связано", создана пользователем SeverBap, 20 ноя 2009.

Наш партнер Genesis Hackspace
  1. SeverBap

    SeverBap Well-Known Member
    1C Team

    Регистрация:
    18 сен 2007
    Сообщения:
    450
    Симпатии:
    0
    ситуация простая в этой процедуре:
    Код (Text):
    Процедура тНоменклатураПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    ЭлементыФормы.тНоменклатура.Колонки.Количество.ТекстПодвала = "Всего позиций: "+тНоменклатура.Количество();
    Попытка
    Если ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяПриход>ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяРасход Тогда
    ОформлениеСтроки.ЦветФона = Новый Цвет(255,200,200);
    ИначеЕсли ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяПриход<ЭлементыФормы.тНоменклатура.ТекущиеДанные.СуммаРозничнаяРасход Тогда
    ОформлениеСтроки.ЦветФона = Новый Цвет(200,255,200);
    КонецЕсли;
    Исключение

    КонецПопытки;
    КонецПроцедуры
    при открытии выпадает на ошибку, добавил попытку, заработала, но главное он почему то красит все строки а не одну!! в чем проблема?

    исправил надо данныестроки.суммарозничнаяприход делать! :)
     
  2. sannt

    sannt Гость

    Процедура тНоменклатураПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

    ЭлементыФормы.тНоменклатура.Колонки.Количество.ТекстПодвала = "Всего позиций: "+тНоменклатура.Количество();

    Если ДанныеСтроки.СуммаРозничнаяПриход > ДанныеСтроки.СуммаРозничнаяРасход Тогда
    ОформлениеСтроки.ЦветФона = Новый Цвет(255,200,200);
    ИначеЕсли ДанныеСтроки.СуммаРозничнаяПриход < ДанныеСтроки.СуммаРозничнаяРасход Тогда
    ОформлениеСтроки.ЦветФона = Новый Цвет(200,255,200);
    КонецЕсли;

    КонецПроцедуры
     
Загрузка...
Похожие Темы - Ошибка оформлениестроки
  1. Rahmatov
    Ответов:
    0
    Просмотров:
    50
  2. M.Planck
    Ответов:
    5
    Просмотров:
    122
  3. Kotik222
    Ответов:
    4
    Просмотров:
    154
  4. Denybxx
    Ответов:
    5
    Просмотров:
    145
  5. heyyy
    Ответов:
    0
    Просмотров:
    187

Поделиться этой страницей